Announcement

#1 2019-12-16 16:38:46

photonoxx
Member
2019-06-03
8

Problem to generate PDF thumbnail

HI,

When I try to upload some pdf in my online Gallery, I don't have proper thumbnails generated.

I see some similar post with the same matter, but no clear solution (sometimes it seems the fix come by chance without doing anything except making a new install which I prefer avoid as a solution).

I'm hosted by o2switch french hosting provider.

If I upload files with the integrated form in Piwigo, I get this kind of error log :

Code:

[2019-12-16 14:49:20]  [INFO]  upload_file_pdf, $file_path = ././upload/2019/12/16/20191216154920-adc6c011.pdf, $representative_ext = 
[2019-12-16 14:49:20]  [INFO]  upload_file_tiff, $file_path = ././upload/2019/12/16/20191216154920-adc6c011.pdf, $representative_ext = 
[2019-12-16 14:49:20]  [INFO]  upload_file_video, $file_path = ././upload/2019/12/16/20191216154920-adc6c011.pdf, $representative_ext = 
[2019-12-16 14:49:20]  [INFO]  Handling ././upload/2019/12/16/20191216154920-adc6c011.pdf got 
[2019-12-16 14:49:20]  [INFO]  add_uploaded_file : force cache generation, derivative_url = https://www.photolib.fr/themes/default/icon/mimetypes/unknown.png

And if I upload with ftp+sync, I even don't get error message in _data/logs/ But still no thumbnail as you can see here

https://www.photolib.fr/index.php?/category/galerie1

pdf icon are displayed by "media_icon" plugin, and Charlie's content is used too to view pdf in browser.

So if somebody has an idea about the origin of the matter (or test to make) and a possible solution, it would be very nice.

I notice, too, the name displayed for pdf file is "filetype ID" and not as picture "title" (not sure it could help).

I had similar matter in an local piwigo installation, and found that imagemagick policy.xml in /etc/imagemagick.6/ unactivate pdf treatment by imagemagick, but here I don't see this kind of things.

Thanks
--
Nicolas

Piwigo 2.10.1 Dernière version ?
Système d'exploitation: Linux
PHP: 7.3.12 (Montrer les informations) [2019-12-16 15:14:22]
MySQL: 10.2.30-MariaDB [2019-12-16 16:14:22]
Bibliothèque graphique: ImageMagick 6.9.4-10

Offline

 

#2 2019-12-16 17:54:43

photonoxx
Member
2019-06-03
8

Re: Problem to generate PDF thumbnail

I don't do it before since imagemagic seems well detected, but I just try to set

$conf['graphics_library'] = 'ext_imagick';

instead of "auto"

Now, Piwigo detect :

Bibliothèque graphique: External ImageMagick 6.7.8-9

Instead of Bibliothèque graphique: ImageMagick 6.9.4-10

But now, when I upload by piwigo upload integrated tool, the thumbnail is well generated. Does somebody know why it's happening ?

Is there possible inconvenient to use older external library like that ? And if the matter happens with new version of ImageMagick, what's about the future when no more older version could be available ?

By the way, sending pdf via FTP (or copy file from cpanel file manager to avoid upload time), still doesn't generate thumbnails, may be it's normal since the function is only present in admin/include/functions_upload.inc.php , but it could nice to process the FTP uploaded files too.

Thanks
Nicolas

Offline

 

#3 2021-01-07 18:54:53

dadoc
Member
2020-06-24
12

Re: Problem to generate PDF thumbnail

Hi,
I had exactly the same problem with the PDF thumbnails, and I was just writing here to point you in the right direction - when I noticed that the post with the deciive hint came from - you!!! From your cross post in the french forum https://fr.piwigo.org/forum/viewtopic.php?pid=227272

It worked for me, thanks a lot.

Best regards
Martin



Piwigo 2.10.2
Betriebssystem: Linux
PHP: 7.2.34-8+ubuntu18.04.1+deb.sury.org+1 (Info anzeigen) [2021-01-07 18:50:21]
MySQL: 5.5.5-10.1.47-MariaDB-0ubuntu0.18.04.1 [2021-01-07 18:50:21]
Grafikbibliothek: External ImageMagick 6.9.7-4

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact