Announcement

#1 2020-01-29 16:37:54

gklis
Member
2020-01-29
2

Error when i click "Repair and optimize database"

Hello,

After upgrading from 2.9.0 to 2.10.1 i had some problems accessing my piwigo site, which went away after deleting cookies and clicking Ctlr + F5 to reload the page. Since then, things seem to work ok except one thing: When i click "Repair and optimize database" i get the following error:

Warning:  [mysql error 1067] Invalid default value for 'date'
ALTER TABLE piwigo_comments ORDER BY id; in /home/user01/public_html/gallery/include/dblayer/functions_mysqli.inc.php on line 856

It looks like the error reported here, but its not  the exactly the same:
https://piwigo.org/forum/viewtopic.php?id=27923

Any idea how could i fix it?

I just saw that in table piwigo_comments the field date has default value 0000-00-00 00:00:00.
Is this causing the problem? How could i fix it?

Thank you.

Piwigo version: 2.10.1
Operating system: Linux (Ubuntu 18.04.1)
PHP version: 7.2.24
MySQL version: 5.7.29
Graphics Library: GD 2.2.5
Piwigo URL: localhost

Last edited by gklis (2020-01-29 16:47:54)

Offline

 

#2 2020-01-29 17:25:00

gklis
Member
2020-01-29
2

Re: Error when i click "Repair and optimize database"

gklis wrote:

Hello,

After upgrading from 2.9.0 to 2.10.1 i had some problems accessing my piwigo site, which went away after deleting cookies and clicking Ctlr + F5 to reload the page. Since then, things seem to work ok except one thing: When i click "Repair and optimize database" i get the following error:

Warning:  [mysql error 1067] Invalid default value for 'date'
ALTER TABLE piwigo_comments ORDER BY id; in /home/user01/public_html/gallery/include/dblayer/functions_mysqli.inc.php on line 856

It looks like the error reported here, but its not  the exactly the same:
https://piwigo.org/forum/viewtopic.php?id=27923

Any idea how could i fix it?

I just saw that in table piwigo_comments the field date has default value 0000-00-00 00:00:00.
Is this causing the problem? How could i fix it?

Thank you.

Piwigo version: 2.10.1
Operating system: Linux (Ubuntu 18.04.1)
PHP version: 7.2.24
MySQL version: 5.7.29
Graphics Library: GD 2.2.5
Piwigo URL: localhost

Following the recommendations from this post did the trick:
[Github] Piwigo issue #670

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact