Announcement

#1 2020-04-25 13:10:07

humaila
Member
2020-04-25
3

Piwigo-2.10.2 Fatal error

Hello/Hi/Greetings,

I am new around here and kinda new with Linux.
I encounter the following error after the install:
------------------------------------------------------
Fatal error: [snuffleupagus][0.0.0.0][disabled_function] Aborted execution on call of the function 'function_exists', because its argument '$function_name' content (exec) matched a rule in /var/sentora/hostdata/zadmin/public_html/nextproject_tk/photos/admin/include/image.class.php on line 320
------------------------------------------------------

No error during the install, only when I attempt to upload photos.
Any idea what is wrong?
I also uploaded the image.class file

Piwigo version: 2.10.2
PHP version: 7.3.17
MySQL version: 5.5.64-MariaDB
Piwigo URL: http://nextproject.tk/photos/

Offline

 

#2 2020-04-25 14:19:20

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7056

Re: Piwigo-2.10.2 Fatal error

Hi :-)

Have you a graphic library installed  ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#3 2020-04-25 15:33:02

humaila
Member
2020-04-25
3

Re: Piwigo-2.10.2 Fatal error

I have Sentora installed

Offline

 

#4 2020-04-26 06:38:36

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7056

Re: Piwigo-2.10.2 Fatal error

Hi :-)

GD ? image magic ?  imagemagick ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#5 2020-04-26 08:34:05

humaila
Member
2020-04-25
3

Re: Piwigo-2.10.2 Fatal error

It is a simple Centos 7 with Sentora installed and 2 websites hosted. This is all.
No other special things installed.
Tomorrow I will receive the RPi 4 that I ordered and I will try to install OMV via SD card.
But it is weird that it doesn't work on this machine.
I also tried to burn the OMV iso on a stick but I get in trouble erasing the LVM.
I am still investigating this second setup.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact