#1 2021-09-18 03:55:04


cannot connect to server - installation page

Hey all,

I currently have the latest version of Ubuntu with LAMP installed in virtualbox and I have been trying to get PIWIGO 11.5.0 to run with nothing but fails.

This is a local install and so wouldn't think that a URL would help anyone. I am running mariadb server within the LAMP server and when I go to http://IP/piwigo the install page appears, preset on English GB. localhost is set already for database connection however since this isn't a localhost as its a VM I enter the IP address and fill in the rest of the details for the database just as I created in on the server.

All I get is "cannot connect to server". I have tried a variation of things "localhost@IP" which also fail.

Can someone tell me the best way to install this other than using a public host as I was hoping to have this as a private/local installation with just myself and family using it.

If this cant be installed on a VM that's fine but with the installs I have seen and followed on YouTube it appears that it does run on a VM just I cannot figure out why mine will not connect to the server.

If anyone is able to help that would be great.



#2 2021-09-18 15:34:19

Only trying to help

Re: cannot connect to server - installation page

If the database and the web server serving Piwigo are not on the same (virtual) host (sounds like from your description) make sure that the web server user in the VM can actually reach the database host. Try with using the mysql command line (mysql --user=user_name --password=your_password --host=host_name db_name (where host_name of course can be an IP as well)). If that doesn't work then you need to get your VM's network interface settings right.

Running Piwigo at



#3 2022-06-11 07:20:15


Re: cannot connect to server - installation page


I'm having similar issues.  Hoping for help.

I've installed Piwigo on a Linux type NAS (Asustor) server. When doing the installation config page, it will not accept localhost as HOST. I have to put in into the HOST and then it will connect to server.

Once connected, it then states that 'connection to the database was not possible.'

Reading all the threads, a couple of common themes come through like making sure privileges are right. So...

* I have checked the username, password and privilege's for the database and all looks ok. I have tried multiple variations of defining the user/role in the dbase (like changing the host to localhost, domain name, IP addresses) and that does nothing - "computer says no".

* I've also made sure that the Piwigo, MariaDB and phpMyAdmin were installed under a admin role. I can log in using the server admin role with FTP from my PC and move/delete files on the server so I would have thought the credentials were good.

Looking at the file structure, Piwigo is sitting in Docker which is right (I believe).

Some data that might help:

Piwigo v12.2.0
phpMyAdmin 5.0.4.r15
php 7.3
MariaDB 10.7.3.r58
Docker 20.10.9.r2
Apache 2.4.53.r12

I appreciate MySQL but don't have experience with it. I did do some SQL queries in phpMyAdmin to list the dbases which worked okay. I don't know how to check the handshaking between MariaDB and Piwigo?

Any ideas that will help me are welcome :-)



#4 2022-08-14 16:25:07


Re: cannot connect to server - installation page

instead of  'localhost' try   - this is similar to the pronoun "me"....every person or computer will understand that term as themself

if you are logging into the database from localhost then you have to have localhost or as the identifier.  if you are using a database on a different server then you would use the local IP or public IP of that machine.

im very new to piwigo - but im experienced somewhat with *nix and limited database usage.



Board footer

Powered by FluxBB

github twitter newsletter Donate © 2002-2022 · Contact