Announcement

#1 2022-04-06 13:02:39

ianmac
Member
2016-07-30
21

[resolved] Many similar problems after upgrade fron version 2.10.0 to 12.2.0

Hi,

Upgrade was very short 0.75 secs, SQL queries: 31

Environment

    Piwigo 12.2.0 Check for upgrade
    Operating system: Linux
    PHP: 7.3.33 (Show info) [2022-04-06 10:42:33]
    MySQL: 8.0.28 [2022-04-06 11:42:33]
    Graphics Library: ImageMagick 6.9.10-86
    Cache size 1921.58 Mo   calculated 34 minutes ago Refresh

Activated plugin list 17

    Admin Tools
    Batch Downloader
    Comments on Albums
    Crypto Captcha
    Edit Filename
    Exif View
    File Uploader
    Fotorama
    Header Manager
    Language Switch
    LocalFiles Editor
    Mobile Theme for Tablets
    OpenStreetMap
    Photo Update
    RV Akismet
    Smilies Support
    Theme Switch

Problem: when selecting a few folders, a warning comes up
mysql error 1064 You have an error in your SQL syntax; check the manual that corresponds to your MYSQL server version for the right syntax to use near 'ASC' at line 7

[some code which ends ...]
ORDER BY rank ASC
; in /home/swanland/public_html/piwigo/include/dblayer/functions_mysqli.inc.php  on line 847

Fatal error: Uncaught Error: Call to a member function fetch_assoc() on bool in /home/swanland/public_html/piwigo/include/dblayer/functions_mysqli.inc.php:908 Stack trace: #0 ...

I have four more very similar screenshots taken by my browser - if you need them.

Piwigo URL: http://

Offline

 

#2 2022-04-06 15:37:16

ianmac
Member
2016-07-30
21

Re: [resolved] Many similar problems after upgrade fron version 2.10.0 to 12.2.0

I have found a message from flop25 [19-Jan-2014] which says ....
If you have an error after the update:
- reupload all files of that new version, by ftp and by overwriting existing files

I would like to give this a try, BUT -
1, where do I find the files of that new version? - at Piwigo?
2. what is the FTP hostname? - the full domain name?
3. where do I find the existing files that I need to overwrite on my site? - what folder/directory would they have been saved to on my site's public_html directory?

Comment: if this (system reload) is a usful process to sort errors, please could we have such a process in the Maintenance Tools?

I have run the following from the Maintenance Tools -
1. repair and optimise database
2. reinitialise integrity check
and I have done a synchronization firstly as a simulation and then for real.
These actions have made no difference - the problem still exists.

Offline

 

#3 2022-04-06 17:52:09

erAck
Only trying to help
2015-09-06
1395

Re: [resolved] Many similar problems after upgrade fron version 2.10.0 to 12.2.0

This "ORDER BY rank" problem is usually because rank is now a MySQL keyword (since MySQL 8) and the column name would have to be escaped as `rank`. There are several mentions in this forum if you search. The remedy seems to be to remove the manual sort order though that is unsatisfactory.


Running Piwigo at https://erack.net/gallery/

Offline

 

#4 2022-04-07 16:50:56

ianmac
Member
2016-07-30
21

Re: [resolved] Many similar problems after upgrade fron version 2.10.0 to 12.2.0

I have been doing an analysis on those albums that error on being selected for display.
As there are 582 albums on the website I have taken a sample: those with identification numbers between 1 and 50.  The results are that 17 albums open satisactorily; seven are 'not found' - being deleted sometime in the past; and 26 albums show the error.
I wanted to check this high proportion of failing albums and so set about with the smallest section of the website, under the name of 'Roads'. Out of the total of 60 albums in this section, only 15 failed to display.  However I could not find a reason why some ablums in this sample correctly opened when selected and the others did not.
Albums can be selected for display in a variety of ways/from different points in the Piwigo design.  In all cases the album was consistent in opening or failing to open, whichever way was chosen to open the album.

Offline

 

#5 2022-04-27 17:42:25

ianmac
Member
2016-07-30
21

Re: [resolved] Many similar problems after upgrade fron version 2.10.0 to 12.2.0

I found that the solution to this problem is to go through all (582) albums and open 'sort photos order' and then 'Save settings' or 'Submit' and then check the opening of the Album. 
Result: 100% albums opened correctly.  I also found that the problem did not occur to albums created after January 2020.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact