#1 2025-11-27 22:37:48

flyerfocus
Member
2023-01-24
18

[resolved] I Can No Longer Post Photos! "Uploaded 0/12"

Hello/Hi/Greetings,

I was running 14.4.0 merrily for years on Ubuntu which is running on ESXi in a VM.  Everything was going great until the day I expanded the virtual disk from 500 GB to 750 GB.  I expanded the allocation first, in ESXi, then I expanded the disk at the OS level (as I have done many times before).  The site was back up and running again in no time.  Easy.  Right?  Until I went to upload.  Now all I see is "Uploaded 0/12" with the yellow line only moving 1/12 of the way across the screen.

I saw there was a minor update to 14.5.0, so I thought I would give that a try.  The upgrade appears to have occurred successfully and the UI does show I am on 14.5.0, but still, I cannot upload anything!  Please assist.  I use this site to take thousands of photos, at dog shows and at air races, which I give out for free.  I know there were many people at the dog show I was at last weekend who are very eager to see their puppy pictures,  How do I troubleshoot this upload problem?  Thanks in advance!

(Copy here your environment details, found on your Piwigo page [Administration > Tools > Maintenance])

Environment

    Piwigo 14.5.0 Check for upgrade
    Installed on 26 January 2023, 2 years 10 months 1 day ago
    Operating system: Linux
    PHP: 8.4.15 (Show info) [2025-11-27 21:36:15]
    MySQL: 10.6.22-MariaDB-0ubuntu0.22.04.1 [2025-11-27 13:36:15]
    Graphics Library: External ImageMagick 6.9.11-60
    Cache size N/A   never calculated Refresh

Activated plugin list 0

    an error occurred



Piwigo URL: http://wolfpackgallery.com

Last edited by flyerfocus (2025-11-28 20:03:19)

Offline

 

#2 2025-11-28 20:07:11

flyerfocus
Member
2023-01-24
18

Re: [resolved] I Can No Longer Post Photos! "Uploaded 0/12"

Here's an update that may indicate the problem is database related: 

I just tried to update the description section on the photo album from last weekend letting people know there's a problem with the server.  When I tried to save the description I got the following error:

"An error occurred while saving album settings."

Any help would be mega appreciated!

Offline

 

#3 2025-11-29 13:00:29

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
14100

Re: [resolved] I Can No Longer Post Photos! "Uploaded 0/12"

When I open your Piwigo, I see :

Deprecated: session_set_save_handler(): Providing individual callbacks instead of an object implementing SessionHandlerInterface is deprecated in /var/www/html/include/functions_session.inc.php on line 18

Warning: include(./include/search_filters.inc.php): Failed to open stream: No such file or directory in /var/www/html/index.php on line 177

Warning: include(): Failed opening './include/search_filters.inc.php' for inclusion (include_path='.:/usr/share/php') in /var/www/html/index.php on line 177

You're on PHP 8.4. Forget about Piwigo 14. Furthermore the file include/search_filters.inc.php is missing, which means the update has gone wrong somewhere.

Perform a manual update to Piwigo 16. See our guide

Offline

 

#4 2025-12-01 03:12:21

flyerfocus
Member
2023-01-24
18

Re: [resolved] I Can No Longer Post Photos! "Uploaded 0/12"

None of those errors appeared until I went from 14.0 to 14.5.  Screw it.  I scrapped the whole site and built a new one from scratch with 16.  I'll just re-load the content over time.

Offline

 

#5 2025-12-01 22:49:58

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
14100

Re: [resolved] I Can No Longer Post Photos! "Uploaded 0/12"

flyerfocus wrote:

None of those errors appeared until I went from 14.0 to 14.5.  Screw it.  I scrapped the whole site and built a new one from scratch with 16.  I'll just re-load the content over time.

as you wish but if you have your database and the "upload" or "galleries" directories, there is no reason to restart from scratch.

Offline

 

Board footer

Powered by FluxBB