Announcement

#1 2011-07-07 15:48:15

smoothzhuhai
Member
Xian
2007-01-26
9

Error after upgrade to 2.2.3

Automatic upgrade failed so I did manually http://photography.bmfbm.com/upgrade.php

           This page proposes to upgrade the database from your Piwigo old version to the new version.
           The upgrade assistant thinks you are currently running a release 2.1.0 (or equivalent).

but after I click on "upgrade from version 2.1.0 to 2.2.3" nothing seems to happen.

Then if I go to Smooth Traveller gallery:

Warning:  [mysql error 1054] Unknown column 'user_representative_picture_id' in 'field list'

SELECT
    c.*,
    user_representative_picture_id,
    nb_images,
    date_last,
    max_date_last,
    count_images,
    count_categories
  FROM phpwg_categories c
    INNER JOIN phpwg_user_cache_categories ucc ON id = cat_id AND user_id = 38
  WHERE id_uppercat is NULL
   
  ORDER BY rank
; in /photography.bmfbm.com/include/dblayer/functions_mysql.inc.php on line 654


Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /photography.bmfbm.com/include/dblayer/functions_mysql.inc.php on line 153

Warning: Cannot modify header information - headers already sent by (output started at /photography.bmfbm.com/include/dblayer/functions_mysql.inc.php:653) in /photography.bmfbm.com/include/page_header.php on line 98


It seems that my database is a mess ? On the other hand, http://photography.bmfbm.com/admin.php tells me that my current version is 2.2.3.
What do you suggest me ?
(I have already deactivated all the plugins)

Offline

 

#2 2011-07-07 15:54:13

P@t
Piwigo Team
Nice
2007-06-13
4098

Re: Error after upgrade to 2.2.3

http://photography.bmfbm.com/upgrade.php

Enter your webmaster id and password, then click "upgrade from version 2.1.0 to 2.2.3"


P@t

Offline

 

#3 2011-07-07 23:48:33

smoothzhuhai
Member
Xian
2007-01-26
9

Re: Error after upgrade to 2.2.3

p@t wrote:

Enter your webmaster id and password, then click "upgrade from version 2.1.0 to 2.2.3"

This is what I did as I described in my first message. I connected as the webmaster to have this displayed and I clicked on it, but nothing happened.

Offline

 

#4 2011-07-11 07:57:14

smoothzhuhai
Member
Xian
2007-01-26
9

Re: Error after upgrade to 2.2.3

I solved this issue after I realized that "install" directory was missing. The reason is unknown to me because I did the automatic upgrade.

After I copied the directory from the 2.2.3 install, I ran again the upgrade which, this time, completed successfully.
Then, When I came back to my piwigo instance, The message about missing column was still there.

So I extracted the following from a structure file located under install directory , and I ran it under phpmyadmin.

--
-- Table structure for table `piwigo_user_cache_categories`
--

DROP TABLE IF EXISTS `piwigo_user_cache_categories`;
CREATE TABLE `piwigo_user_cache_categories` (
  `user_id` smallint(5) NOT NULL default '0',
  `cat_id` smallint(5) unsigned NOT NULL default '0',
  `date_last` datetime default NULL,
  `max_date_last` datetime default NULL,
  `nb_images` mediumint(8) unsigned NOT NULL default '0',
  `count_images` mediumint(8) unsigned default '0',
  `count_categories` mediumint(8) unsigned default '0',
  `user_representative_picture_id` mediumint(8) unsigned default NULL,
  PRIMARY KEY  (`user_id`,`cat_id`)
) ENGINE=MyISAM;

This turnaround seemed to have worked for me, maybe because I was before on 2.1.0 which might have a structure not too different from 2.2.3. (I hope I havent't missed anything else. I'll tell you if so ...).

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact