Announcement

#1 2011-09-14 23:55:17

drsney
Member
2011-09-14
13

[SmartAlbums plugin] Warning messages, does not work with tags

Hello,
I have encountered this strange behavior after installing SmartAlbums.
When I try to manage an Album, there are some warning message and it does not find any tags:

Code:

10x (for 10 tags in db) this

Notice: Undefined index: name in /public_html/admin/include/functions.php on line 2118

Notice: Undefined index: id in /public_html/admin/include/functions.php on line 2119

and than 1x this

Warning: Cannot modify header information - headers already sent by (output started at /public_html/admin/include/functions.php:2118) in /public_html/include/page_header.php on line 98

Offline

 

#2 2011-09-15 00:50:27

flop25
Piwigo Team
2006-07-06
7037

Re: [SmartAlbums plugin] Warning messages, does not work with tags

hello
thx for reporting : this issue has already been identified and corrected


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2011-09-15 09:11:32

drsney
Member
2011-09-14
13

Re: [SmartAlbums plugin] Warning messages, does not work with tags

That's great. How can I fix it on my site ? Is there some update ?

Offline

 

#4 2011-09-15 23:08:52

sdxwt
Guest

Re: [SmartAlbums plugin] Warning messages, does not work with tags

I ran into the same problem in 2.2.5


In file admin/include/functions.php, I modified two lines in function get_taglist.  All that was changed was to  insert tag_ into the array index.

changed
'name' => $row['name'],
'id' => '~~'.$row['id'].'~~',

to

'name' => $row['tag_name'],
'id' => '~~'.$row['tag_id'].'~~',


Works for me. Your mileage may vary.

 

#5 2011-09-16 16:36:08

sdxwt
Guest

Re: [SmartAlbums plugin] Warning messages, does not work with tags

Well, I found the problem with doing what I did in the previous post.  I changed the wrong file, meant to change the one in the plugin and got myself confused.  If you did that, undo it, and do this instead:


in the plugins/SmartAlbums/include_init_cat_modify.php

change both occurance of
SELECT
    id AS tag_id,
    name AS tag_name
  FROM '.TAGS_TABLE.'

to

SELECT
    id,
    name
  FROM '.TAGS_TABLE.'

That fixed the problem without breaking some other tag funcitonality...or at least it seems to have.  We'll see what I find that I've broken tomorrow..

 

#6 2011-09-21 20:16:40

drsney
Member
2011-09-14
13

Re: [SmartAlbums plugin] Warning messages, does not work with tags

Thanks a lot, this works, but is it the "real" solution or just a temporary fix?

Offline

 

#7 2011-09-23 21:18:52

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3277

Re: [SmartAlbums plugin] Warning messages, does not work with tags

this is the solution but I can't fix it now, sorry

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact