Announcement

#1 2010-07-23 19:13:23

nabla
Guest

After Installation: Unable to login; wrong user id -> mysql error

Hi,

I installed piwigo 2.1.2, went well. Now I see the login screen. If I enter the right admin user and password, nothing happens and I still see the same screen. Also when I click on "... or browse your empty gallery". If I entered a wrong user name or password, I see a different screen: Identification Invalid password!. In addition there are some mysqgl errors: "Can't connect to local mysql server through /var/run.../piwigo/include/dblayer/functions.mysql.inc.php on line 90"

What can I do?

Btw. I am complete new to webhosting. What do I need to do to secure the installation? I just put the piwigo folder in the place where to put the "normal stuff". Can people download it there? How can I secure it?

Thanks a lot!

 

#2 2010-07-23 19:18:35

nabla
Guest

Re: After Installation: Unable to login; wrong user id -> mysql error

PS: The connection to the mysql database seems to work: I had a look into it using phpMyAdmin and it now includes 31 piwigo_ tables.

 

#3 2010-07-23 20:20:52

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13487

Re: After Installation: Unable to login; wrong user id -> mysql error

Hi nabla,

Do you have the correct connection settings in your local/config/database.inc.php ?

Offline

 

#4 2010-07-23 23:26:05

nabla
Member
2010-07-23
2

Re: After Installation: Unable to login; wrong user id -> mysql error

Hi (new registered),

well, it looks reasonable:

Code:

<?php
$conf['dblayer'] = 'mysql';
$conf['db_base'] = 'nabla';
$conf['db_user'] = 'nabla';
$conf['db_password'] = '$MYPASSWORD';
$conf['db_host'] = '$SERVER';

$prefixeTable = 'piwigo_';

define('PHPWG_INSTALLED', true);
define('PWG_CHARSET', 'utf-8');
define('DB_CHARSET', 'utf8');
define('DB_COLLATE', '');

?>

Password and server are of course the right one. My hoster also mentions a port of 3306. Do I have to enter it here?

In phpMyAdmin set up by the hoster, it is written:

Code:

MySQL

    * Server: $SERVER via TCP/IP
    * Server version: 5.0.51a-24+lenny2
    * Protocol version: 10
    * User: nabla@192.168.100.44
    * MySQL charset: UTF-8 Unicode (utf8)

Web server

    * Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch
    * MySQL client version: 5.0.51a
    * PHP extension: mysqli

phpMyAdmin

    * Version information: 3.2.5
    * Documentation
    * Wiki
    * Official Homepage
    * [ChangeLog] [Subversion] [Lists]

As I mentioned above, during the installation, piwigo was able to add tables to that database. Here is a link to what I have set up. Please keep in mind that this is the first time I set up a webpage and used something like mysql myself (of course programms I use it without letting me to interfere). Also, this hoster is a free one so maybe it does not offer full functionality?!

Offline

 

#5 2010-07-23 23:54:22

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13487

Re: After Installation: Unable to login; wrong user id -> mysql error

Can you tell us what you exactly have for the mysql host in Piwigo and PhpMyAdmin configuration files?

Offline

 

#6 2010-07-24 10:49:34

nabla
Member
2010-07-23
2

Re: After Installation: Unable to login; wrong user id -> mysql error

Ok, I am not sure what you exactly mean, but here are the full lines:
database.inc.php:

Code:

$conf['db_host'] = 'db4.cwsurf.de';

phpMyAdmin:

Code:

Server: db4.cwsurf.de via TCP/IP

Or do you need other information?

Thanks a lot!

Offline

 

#7 2010-07-24 23:26:49

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13487

Re: After Installation: Unable to login; wrong user id -> mysql error

Try the following settings in your local/config/database.inc.php:

1st test:

Code:

$conf['db_host'] = 'localhost:3306';

2nd test:

Code:

$conf['db_host'] = '127.0.0.1:3306';

3rd test:

Code:

$conf['db_host'] = 'localhost:/var/run/mysqld/mysqld.sock';

(this is the default path to MySQL socket on Debian)

Offline

 

#8 2011-10-08 09:32:49

Frank
Guest

Re: After Installation: Unable to login; wrong user id -> mysql error

I get exactly the same message as the original poster after installing piwigo from the Debian Squeeze repository. I tried all three suggested settings, to no avail.

I think the problem lies elsewhere, as I get the following php error output:

Code:

Warning: array_merge(): Argument #2 is not an array in /usr/share/piwigo/web/include/functions_user.inc.php on line 330 Warning: Invalid argument supplied for foreach() in /usr/share/piwigo/web/include/functions_user.inc.php on line 332 Notice: Undefined index: id in /usr/share/piwigo/web/include/functions_user.inc.php on line 361 Notice: Undefined index: status in /usr/share/piwigo/web/include/functions_user.inc.php on line 361 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3

SELECT cat_id
  FROM piwigo_user_access
  WHERE user_id = 
; in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 202 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4

SELECT cat_id
  FROM piwigo_user_group AS ug INNER JOIN piwigo_group_access AS ga
    ON ug.group_id = ga.group_id
  WHERE ug.user_id = 
; in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 202 Notice: Undefined index: level in /usr/share/piwigo/web/include/functions_user.inc.php on line 369 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4

SELECT DISTINCT(id)
  FROM piwigo_images INNER JOIN piwigo_image_category ON id=image_id
  WHERE category_id NOT IN (0)
    AND level> in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 202 Notice: Undefined index: level in /usr/share/piwigo/web/include/functions_user.inc.php on line 689 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'GROUP BY c.id, c.global_rank' at line 8
SELECT c.id AS cat_id, global_rank,
  MAX(date_available) AS date_last, COUNT(date_available) AS nb_images
FROM piwigo_categories as c
  LEFT JOIN piwigo_image_category AS ic ON ic.category_id = c.id
  LEFT JOIN piwigo_images AS i
    ON ic.image_id = i.id
      AND i.level<=
  GROUP BY c.id, c.global_rank in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 155 Notice: Undefined index: status in /usr/share/piwigo/web/include/functions_user.inc.php on line 390 Notice: Undefined index: id in /usr/share/piwigo/web/include/functions_user.inc.php on line 417 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM piwigo_user_cache_categories
  WHERE user_id =  in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Notice: Undefined index: id in /usr/share/piwigo/web/include/functions_user.inc.php on line 436 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 2

DELETE FROM piwigo_user_cache
  WHERE user_id =  in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Notice: Undefined index: id in /usr/share/piwigo/web/include/functions_user.inc.php on line 444 
Warning: [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''false',1317924957,'0',0,'NOT IN','0')' at line 5

INSERT INTO piwigo_user_cache
  (user_id, need_update, cache_update_time, forbidden_categories, nb_total_images,
    image_access_type, image_access_list)
  VALUES
  (,'false',1317924957,'0',0,'NOT IN','0') in /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php on line 651
Notice: Undefined index: nb_image_line in /usr/share/piwigo/web/include/functions_user.inc.php on line 246 Notice: Undefined index: nb_line_page in /usr/share/piwigo/web/include/functions_user.inc.php on line 246 Notice: Undefined index: language in /usr/share/piwigo/web/include/common.inc.php on line 129 Notice: Undefined index: language in /usr/share/piwigo/web/include/common.inc.php on line 133 Notice: Undefined index: adviser in /usr/share/piwigo/web/include/functions_user.inc.php on line 1329 Warning: Cannot modify header information - headers already sent by (output started at /usr/share/piwigo/web/include/dblayer/functions_mysql.inc.php:651) in /usr/share/piwigo/web/include/functions_html.inc.php on line 483 
You are not authorized to access the requested page
Identification Home
 

#9 2011-10-10 19:40:38

Frank
Guest

Re: After Installation: Unable to login; wrong user id -> mysql error

Something went wrong with populating the tables using dbconfig-common in Debian.

I resolved this issue by removing piwigo with apt-get purge piwigo (remove configuration files too), and reinstalling it afterwards.

 

#10 2011-10-10 20:25:13

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13487

Re: After Installation: Unable to login; wrong user id -> mysql error

Thank you for this feedback and solution Frank.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2021 · Contact