Announcement

#1 2012-11-20 22:47:29

Rolle
Guest

Broken images after syncing

Hi,

First of all, I love your gallery. It's awesome, best I've tried.

Except this frustrating issue... it won't display the images after syncing from galleries folders. I have to go through every image, refresh them one by one and then they will show up...

It's like "broken image". Tried four different piwigo versions, all the same.

Now using:

Piwigo 2.5.0beta3
Operating system: Linux (openSUSE 12.1)
PHP: 5.3.8 (Show info) [2012-11-20 22:46:35]
mysql: 5.5.16 [2012-11-20 23:46:35]
Graphics Library: External ImageMagick 6.7.2-7

http://peikko.us/kuvat

 

#2 2012-11-20 22:58:45

Rolle
Guest

Re: Broken images after syncing

Ok I guess it's the theme I'm using... sorry.

 

#3 2012-11-20 23:24:59

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing

Hi

Rolle wrote:

Ok I guess it's the theme I'm using... sorry.

what was the theme?

Don't use the beta for your real gallery! You might have trouble to update then : beta and RC are only for testing and have fun


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#4 2012-11-21 10:48:10

Rolle
Guest

Re: Broken images after syncing

flop25 wrote:

Hi

Rolle wrote:

Ok I guess it's the theme I'm using... sorry.

what was the theme?

Don't use the beta for your real gallery! You might have trouble to update then : beta and RC are only for testing and have fun

I'm using this https://github.com/saimn/simple-theme-piwigo

But I'm going to make my own.

 

#5 2012-11-21 11:04:47

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#6 2012-11-21 22:57:33

Rolle
Guest

Re: Broken images after syncing

I modified a theme based on simpleng and everything is great now, except the main image does not load if I don't replace _data/template_c/kj7kkx^%%3F^3FA^3FA299F4%%picture_content.tpl.php from default.

What part generates that and why?
I tried to replace picture.tpl and picture_content.tpl from default but it still generates it wrong. I need the part that generates it with ajax-loader-big.gif , otherwise the image won't load up.

 

#7 2012-11-21 23:38:11

Rolle
Guest

Re: Broken images after syncing

Also I have no idea why monthly view images are still broken. This happens actually in every theme.

 

#8 2012-11-22 15:03:51

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing

Rolle wrote:

Also I have no idea why monthly view images are still broken. This happens actually in every theme.

? I don't understand. I went on your website and didn't see any trouble. Pleas link to page with that issue


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2012-11-22 15:40:29

Rolle
Guest

Re: Broken images after syncing

flop25 wrote:

Rolle wrote:

Also I have no idea why monthly view images are still broken. This happens actually in every theme.

? I don't understand. I went on your website and didn't see any trouble. Pleas link to page with that issue

Not those who have been refreshed -> cached. Refresh the page until there is a broken image. All the images are broken on first sync, but after you go through them, they will be visible.

This happened before in thumbnails and other parts of the site until I made that ajax-loader fix to the theme. But it seems monthly view is the same for default theme as well, so I don't know how to fix it.

Try to refresh this couple of times... http://peikko.us/kuvat/index.php?/categ … ar-2012-10

(I don't know how many images are un-generated at the moment, so there may be working pics now)

 

#10 2012-11-22 15:43:51

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing

1-if you use Fto method, the resized pictures are generate on-call : which means the page is loaded then call are made to generate the thumbnails (3 per call) then the thumbnails appears after a few seconds

2- http://peikko.us/kuvat/index.php?/categ … ar-2012-10 there is empty spaces because there is no pictures t o display at these dates!


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2012-11-22 20:45:38

Rolle
Guest

Re: Broken images after syncing

flop25 wrote:

1-if you use Fto method, the resized pictures are generate on-call : which means the page is loaded then call are made to generate the thumbnails (3 per call) then the thumbnails appears after a few seconds

2- http://peikko.us/kuvat/index.php?/categ … ar-2012-10 there is empty spaces because there is no pictures t o display at these dates!

Yes, I realize that. There is one slot on that month, but I guess all the pictures have been generated already before, while I have been going through them.

What I meant, in monthly view the thumbnail does not appear after it's generated, you'll have to reload the page.

 

#12 2012-11-22 20:47:23

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing

okay finally got it
you're right by default the calendar view does not have the ajax loading
thx for the feedback


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#13 2012-11-22 20:50:50

flop25
Piwigo Team
2006-07-06
6975

Re: Broken images after syncing


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#14 2012-11-22 21:47:55

Rolle
Guest

Re: Broken images after syncing

flop25 wrote:

[Github] Piwigo issue #207 created

Great! Thanks!

 

#15 2012-11-23 00:22:08

Rolle
Guest

Re: Broken images after syncing

Rolle wrote:

I modified a theme based on simpleng and everything is great now, except the main image does not load if I don't replace _data/template_c/kj7kkx^%%3F^3FA^3FA299F4%%picture_content.tpl.php from default.

What part generates that and why?
I tried to replace picture.tpl and picture_content.tpl from default but it still generates it wrong. I need the part that generates it with ajax-loader-big.gif , otherwise the image won't load up.

Found the fix for this as well: http://piwigo.org/dev/changeset/16505

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact