Announcement

#1 2013-05-27 04:43:18

Mark O'Shea
Member
2013-05-27
26

'Random photos' menu option not displaying thumbnails correctly.

Hello,

When I click on the 'random photos' menu option in the 'specials menu' I get a single gallery thumbnail displaying and not the individual photo thumbnails that I would expect from a random gallery.

I've found the issue but don't know how to fix it.

The problem occurs because the link created for the random photos page appears to contain too many characters.

Here's some example links that were generated when I clicked on the 'random photos' menu option. These links do not work:

.../gallery/index.php?/list/1147,9410,1456,58,295,161,1799,8945,2470,1405,2009,1750,708,2236,8854
.../gallery/index.php?/list/1669,1261,1432,198,2419,400,9399,351,8915,1901,2505,2065,863,2604,457
.../gallery/index.php?/list/11,1952,633,2338,8735,1605,2419,1410,942,1608,9006,2431,1833,1015,1599

I've found that if I reduce the length of the link, the thumbnails display correctly. The links below are at the maximum length for the thumbnails to display:

.../gallery/index.php?/list/1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,2346
.../gallery/index.php?/list/2049,9018,1640,2011,1263,618,2425,430,23,11,2221,90,20,232
.../gallery/index.php?/list/11,1952,633,2338,8735,1605,2419,1410,942,1608,9006,2431,18

Even one character longer would stop all the thumbnails from displaying.

Any ideas what's causing this and how can I put it right?

Cheers

Mark




Piwigo Details

Piwigo version Piwigo 2.5.0
Running on my own server
Operating system: Linux
PHP: 5.3.3-7+squeeze15 (Show info) [2013-05-27 03:17:49]
MySQL: 5.1.66-0+squeeze1 [2013-05-27 03:17:49]
Graphics Library: GD 2.0
Database
9471 photos (first photo added on Wednesday 03 April 2013)
35 albums including 33 physical and 2 virtual (19440 associations)
0 tags (0 associations)
4 users
0 groups
no rate

Advanced Menu Manager             Version 3.2.5
AStat.2    Advanced statistics      Version 2.4.1
Crypto Captcha                            Version 2.0.4
Delete Hit/Rate                            Version 2.5.a
Grum Plugins Classes.3               Version 3.5.5
GThumb+                                     Version 2.5.b
Header Manager                          Version 1.0.5
LocalFiles Editor                           Version 2.5.0
Rotate Image                               Version 2.5.a
SmartAlbum                                 Version 2.1.2
UserAdvManager                         Version 2.50.6

Offline

 

#2 2013-05-27 09:01:04

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13541

Re: 'Random photos' menu option not displaying thumbnails correctly.

Offline

 

#3 2013-05-28 05:30:59

Mark O'Shea
Member
2013-05-27
26

Re: 'Random photos' menu option not displaying thumbnails correctly.

Thanks for the help.

Here's how I got the random photos to work on my gallery.

I had to edit:

/etc/php5/conf.d/suhosin.ini

and uncomment and change these two directives to 128:

suhosin.get.max_name_length = 128
suhosin.request.max_varname_length = 128

The default setting for both of these was 64, so I decided to double the values to 128, just to be sure.

Then I restarted Apache.

Cheers

Mark

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact