Announcement

#1 2016-08-12 05:17:35

riley.loader
Member
2015-04-01
10

[SOLVED] Upgraded to 2.8.2, unable to notify new users

Hello/Hi/Greetings,

I notice that since I upgraded, I can't send messages to any new users that I create. I'll be honest though, I'm not sure if this is since the upgrade or if it maybe was something happening prior. I can restore from an old backup if absolutely  necessary. I just upgraded from 2.7.x to 2.8.2 in the admin interface of the website. I copied brand-new files into place and have disabled all plugins. I'm not sure where to start looking, exactly. The new users have been added to the "subscribed" section, but then they just don't show up on the "send" area of the Notification page. I am able to move previously existing users back and forth and they disappear and appear on the "send" area as expected. Just the new users don't show up.

Any help appreciated :D

Piwigo version: 2.8.2
PHP version: 5.6
MySQL version: 5.5 (mariadb)
Piwigo URL: (it's a private family gallery)


EDIT: I notice that when I shift users back and forth between 'subscribed' and 'unsubscribed' the mail message does get sent to them. But I just don't see them listed in the "send" area. I also don't have the option to put their name down to notify about a gallery or something.

Last edited by riley.loader (2016-08-16 01:08:43)

Offline

 

#2 2016-08-16 01:08:17

riley.loader
Member
2015-04-01
10

Re: [SOLVED] Upgraded to 2.8.2, unable to notify new users

After much troubleshooting, I found the problem. It was because I have strange permissions set on my albums. Further testing would be required to be 100% sure, but right now I'm 98% sure that if a particular user or group does not have permissions to at least a single album, Piwigo will not allow one to send them a message!

I created a new user, granted him permission to albums, and suddenly was able to see them listed in the "send" list, etc. I noticed that people of "Admin" status could send, and existing users of "User" status who (as I'd forgotten I set up previously) did have access to various albums were able to be sent to. Holy cow. Got that worked out.

Now I can enjoy the new 'token' feature and send my family members emails showing them new photos that have been uploaded. Previously I was frustrated because they don't use it nearly as often as do I, so every time I wanted to send them something they'd need to reset their password. Go figure.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact