Announcement

#16 2014-07-11 10:40:04

aba
Member
2014-07-10
4

Re: How to enable TIFF support

It seems, that synchronization cannot deal with tif format at this moment. After file_ext modification it tries to work with .tif files too, but it doesn't convert them, it use them like they are standard jpg or png... and browser doesn't show them. Only download works.

Does it mean that tiff format is supported only if file is uploaded through web/flash form?

Offline

 

#17 2016-02-13 23:19:09

DancesWithWords
Member
2014-09-16
20

Re: How to enable TIFF support

I've followed this thread and applied some of what I've learned.  So far I've not been able to get tiff file support to work.

local config file has:

$conf['graphics_library'] = 'ext_imagick';
$conf['tiff_representative_ext'] = 'jpg';
// picture_ext : file extensions for picture file, must be a subset of file_ext
$conf['picture_ext'] = array('jpg','JPG','jpeg','JPEG','png','PNG','gif','GIF','bmp','BMP','tif','TIFF','tiff','CR2','cr2');

// file_ext : file extensions (case sensitive) authorized
$conf['file_ext'] = array('jpg','JPG','jpeg','JPEG','png','PNG','gif','GIF','mpg','zip','avi','mp3','ogg','tif','TIF');

I can upload a tiff file but it will not display.  Any help would be appreciated.

Operating system: Linux
PHP: 5.5.24-pl0-gentoo (Show info) [2016-02-13 16:20:16]
MySQL: 5.6.27-log [2016-02-13 16:20:16]
Graphics Library: External ImageMagick 6.9.0-3

Offline

 

#18 2016-05-09 07:56:52

Joe
Guest

Re: How to enable TIFF support

Howdy!
     I'm having the same problem that DancesWithWords is having.  I have quite a few tifs, but none of them are visible after upload (except by downloading the original).

     My config is pretty much identical to DancesWithWords as well. 

     Does anybody have any input on this? 

Thanks!

-Joe

 

#19 2016-05-09 08:13:11

flop25
Piwigo Team
2006-07-06
6918

Re: How to enable TIFF support

Joe wrote:

Howdy!
     I'm having the same problem that DancesWithWords is having.  I have quite a few tifs, but none of them are visible after upload (except by downloading the original).

     My config is pretty much identical to DancesWithWords as well. 

     Does anybody have any input on this? 

Thanks!

-Joe

Hello
You need Imagemagik as graphic library


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#20 2016-05-09 21:45:46

Joe
Guest

Re: How to enable TIFF support

Hello,

Thanks for the response!  I believe I have the Image Magick library.  Here is what is displayed on my admin page:

Piwigo version
Piwigo 2.8.0
Check for upgrade
Subscribe ************* to Piwigo Announcements Newsletter
Environment
Operating system: Linux
PHP: 5.5.26 (Show info) [2016-05-09 13:43:25]
MySQL: 5.5.43 [2016-05-09 19:43:25]
Graphics Library: External ImageMagick 6.8.6-3
Database
31111 photos (first photo added on Monday 12 July 2004)
568 albums including 568 physical and 0 virtual (31111 associations)
0 tags (0 associations)
2 users
0 groups
26460 comments
no rate

I'm very new to piwigo (migrating from G2), so, if I'm missing something obvious, don't hesitate to tell me!  Thanks!

-Joe

Last edited by ddtddt (2016-05-10 07:47:03)

 

#21 2016-05-10 20:36:42

Joe
Guest

Re: How to enable TIFF support

Ok, I did a fresh install of piwigo.  Here is the stuff I put into the LocalFiles editor (local config):


$conf['picture_ext'] = array('tif', 'tiff', 'TIF', 'TIFF', 'jpg','JPG','jpeg','JPEG','png','PNG','gif','GIF');
$conf['file_ext'] = array_merge(
  $conf['picture_ext'],
  array('tiff', 'tif', 'mpg','zip','avi','mp3','ogg','pdf')
  );
$conf['enable_formats'] = true;
$conf['format_ext'] = array('cr2', 'tif', 'tiff', 'nef', 'dng', 'ai', 'psd');
$conf['graphics_library'] = 'ext_imagick';
$conf['ext_imagick_dir'] = '/bin/';

When I do this, the webform allows me to upload tif files and I get a message indicating success after the upload completes.  However, all previews/thumbnails show up as the triangle with an exclamation point icon.

Here's what the admin page shows:
Environment
Operating system: Linux
PHP: 5.5.26 (Show info) [2016-05-10 12:35:30]
MySQL: 5.5.43 [2016-05-10 18:35:30]
Graphics Library: External ImageMagick 6.8.6-3

I would think with a fresh install, this would be easy to get going, but I'm at a loss....

Thanks!

-Joe

 

#22 2016-05-11 08:49:28

flop25
Piwigo Team
2006-07-06
6918

Re: How to enable TIFF support

it should ^^
Could you do this please and then report:
Check if an error is returned by the i.php url : in the Batch Manager, right-click on a failed picture then “Display the picture” or “copy the url to the picture”, from your browser. You can also try to display the source code of the page (Ctrl+U usually) and search (Ctrl+F) for an url with “i.php”. Then go to this url with your browser and note any error message displayed.


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#23 2016-05-11 17:50:24

Joe
Guest

Re: How to enable TIFF support

Howdy!

Ok, when I do this, I get an error message as follows:

[Image] unsupported file extension

Thanks!

-Joe

 

#24 2018-11-07 07:45:02

Joe
Member
2018-11-07
1

Re: How to enable TIFF support

Well, after quite a bit of time, I decided to give this another go.

I have gotten tif support to partially work. 

If I upload a tif via the webform (Administration -> Photos -> Add).  When I upload a tif there, everything looks hunky dorey.  I get a thumbnail and a nicely sized jpg representative shown when I click the thumbnail.

However, if I use the synchronize method of adding photos (copy files to piwigo/galleries then go to Administration -> Tools -> Synchronize), I do not get thumbnails and I do not get jpg representatives.  All tiff thumbnails show as the white box with a question mark (filename 'unknown.png'). Clicking on that gives me the page for the tif, but, with no representative....just the unknown.png again.  The tif _is_ in the system though because I can click the 'Download this file' icon and it downloads successfully.

Is this how it is supposed to work?  Is synchronize not supposed to create a thumbnail and a representative?

Thank you!!!

-Joe

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact