Announcement

#1 2019-04-02 10:57:14

buddhabaker
Member
2019-03-28
8

Clicking "Home" option crashes PiwiGo?

Hello;

When viewing my gallery there is a "Home" option at the start of the gallery's address (see image).
Whenever I click on this option Piwigo crashes with an http error 403 [ permissions error ]

What I would like to do is change the "Home" address from /piwigo/ to  be /piwigo/index.php?/category

Can this be done, please?

Many thanks for any help offered.

Piwigo 2.9.4
Operating system: Linux
PHP: 5.6.36 (Show info) [2019-04-02 09:56:13]
MySQL: 5.6.37-log [2019-04-02 09:56:13]
Graphics Library: ImageMagick 6.7.2-7


Uploaded Images

Last edited by buddhabaker (2019-04-03 13:30:22)

Offline

 

#2 2019-04-06 20:44:37

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

I raised the permissions error with my ISP and this is their reply:

####################
Hi Bill,

From what I can tell, it may be an issue with the index file itself which is not necessarily something I can help with. We are getting an error when the 403 shows up that states:

[Sat Apr 06 10:29:13 2019] [error] [client 80.82.127.194] Directory index forbidden by Options directive: /var/www/vhosts/nineoaks-fisheries.co.uk/httpdocs/piwigo/, referer: https://www.nineoaks-fisheries.co.uk/piwigo/index.php?

If I then add this line into the htaccess file (usually helps with the above error): Options +Indexes, the error does go away and it does indeed load, however it just shows me a list of files instead of anything useful really. Not sure if you want to try it yourself, just the case of throwing that line in the htaccess.

####################
Continuing with my further input.
On scanning through many queries there does appear to be numerous errors that relate to permissions. As this issue would also appear to be related to file permissions, it does raise the question "what should the permissions be?"
Having a list of permissions would help many people and WE can then check or change them for ourselves. Having such a list would be of tremendous help to many.

Can we have such a list, please?

Offline

 

#3 2019-04-07 00:08:40

executive
Member
2017-08-16
664

Re: Clicking "Home" option crashes PiwiGo?

Offline

 

#4 2019-04-07 07:33:41

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6797

Re: Clicking "Home" option crashes PiwiGo?

Hi :-)

add on local config

$conf['random_index_redirect'] = array('./index.php?/categories' => '');


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#5 2019-04-07 23:38:43

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

Thanks to
Executive and ddtddt.
I have checked every directory and file and permissions are 755 or 644 as appropriate.
I have installed the plugin LocalFiles Editor and included the $conf['random_index_redirect'] = array('./index.php?/categories' => ''); as suggested.
My pc has been switched off for a couple of minutes then re-booted and left idle all afternoon.
I have restarted Chrome and then re-checked Piwigo.
Sadly, I still have the 403 error when I click on the Home button

Any other suggestions would be welcome.

Cheers
Buddhabaker

Last edited by buddhabaker (2019-04-07 23:39:43)

Offline

 

#6 2019-04-08 22:55:09

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

Hello;

In order to overcome the current problem, crashing when the "Home" tab is clicked on. This problem also occurs on other "Home" type buttons too.

I would like to re-install Piwigo (already running latest version 2.9.4) without making any changes to the current set-up, database, etc. with the latest version to overwrite the existing files. Is this possible and how would I go about it?

Thanks in advance.
Buddhabaker

Offline

 

#7 2019-04-09 05:06:15

executive
Member
2017-08-16
664

Re: Clicking "Home" option crashes PiwiGo?

Just like you said. Unzip and overwrite. Enter your database settings into 'database.inc.php'.

Offline

 

#8 2019-04-09 12:05:56

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

Hello executive;
I have uploaded from my pc and overwritten all of the existing piwigo directories.
I've closed everything then re-booted my pc.
I've re-started Chrome
I went to the piwigo directory and entered install.php
The system returns the message "Piwigo is already installed"

I enter index.php and fire-up piwigo.

I click through the categories and albums and everything appears ok until I click on "home" when I receive the 403 Permissions Error.

Incidentally, i.php has permissions set to 777, I've tried the above with these permissions with the same result, I've also repeated these again with i.php having 755 and then again with 644 permissions. Each time clicking "Home" crashes with a 403 error.

I'm desperate to go "live" but can not until this is resolved.

Offline

 

#9 2019-04-12 17:39:32

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

A little of the conversation I've been having with a support technician at my ISP which is 34sp.com.

Alex (the tech.) has suggested changing the "Home" button to directly refer to /piwigo/index.php or  /piwigo/index.php?/categories
My response:-
Hello Alex;
thanks for the feedback.
Actually, I have already asked the Piwigo team if this can be modified to do exactly what you suggest. Unfortunately, I've had no response. I also asked if this can be modified by me like a configuration option, no response to this either!

He replied:
Good to know you have put it to them at least! If you get a response do let me know and we can see what we can do.

I responded:-
Hi Alex;
I was wondering, to run php on my site does it require any special "things" from your side or added to the htaccess file?
So, when running html, as my site does, if no file name is given the system defaults to loading index.html.
Does something needed to be done so that php defaults to index.php if no file name is provided?

He replied:
It shouldn't need anything special or specific to run, the server will have PHP installed by default so that is all that is needed to run the files, is there anything that isn't running as it should? If so what is it, let me know and I can take a look.

My web address is:-
https://www.nineoaks-fisheries.co.uk/pi … categories

As I've stated previously if I can not resolve this matter I shall have to find an alternative gallery that does run without crashing. I've wasted enough time already chasing my butt!

I just hope that you can help resolve this???

Offline

 

#10 2019-04-13 05:23:25

erAck
Piwigo Team
2015-09-06
281

Re: Clicking "Home" option crashes PiwiGo?

Make sure that your /etc/apache2/httpd.conf (or whatever Apache config file is reponsible for your domain) includes index.php in its DirectoryIndex directive. For example

Code:

DirectoryIndex index.html index.htm index.php default.html default.htm

If that's not the case and Options +Indexes in the .htaccess file makes the error go away but then gives a listing of files in the directory instead then you have a clueless hosting provider.

Btw, Piwigo does not crash there. It is simply the web server configuration does not allow an access to the directory listing (which is good) and also does not fall back to one of the available files, namely index.php (which is bad), and hence gives the 403 "access forbidden" status. The same happens if you simply surf to https://www.nineoaks-fisheries.co.uk/piwigo/ (which is nothing different from the "Home button" as you call it).


Running Piwigo at https://erack.net/gallery/

Offline

 

#11 2019-04-15 19:44:24

buddhabaker
Member
2019-03-28
8

Re: Clicking "Home" option crashes PiwiGo?

Hello;
as you rightly pointed out the issue was something on my website.
The junior technician with whom I had been conversing escalated my problems; here is their response:-

The apache config of the server is fine. It's your .htaccess that's the problem. You had a line;

DirectoryIndex index.shtml

Which effectively tells the server to ignore any other options (preventing it from failing over to other formats)

I've changed this to;

DirectoryIndex index.shtml index.html index.htm index.php


And it's now loading without issue.

Offline

 

#12 2019-04-15 22:07:02

erAck
Piwigo Team
2015-09-06
281

Re: Clicking "Home" option crashes PiwiGo?

Usually it is not necessary (or even harmful as you experienced..) to override DirectoryIndex in a .htaccess file of any directory if you don't want to restrict or change the order in which files are tried when just a directory is specified in the URL, or want to explicitly state exactly which one file is to be used.
However, great you sorted that out.


Running Piwigo at https://erack.net/gallery/

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact