Announcement

#1 2018-08-20 17:31:30

Skybound_Aviation
Member
2018-08-09
8

Piwigo giving SSL connection error

Hello there fellow piwigo users,

After I login to my gallery, I get the following error:

This site can’t provide a secure connection
www.skyboundaviation.pw sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

However, after looking at the URL that I am redirected to, it seems that a port 80 is added to my URL:

https://www.skyboundaviation.pw:80/Gallery/

Once I delete port 80 from the URL everything works fine.

I have tried the plugin suggestd in the following thread, but it has not worked:

https://piwigo.org/forum/viewtopic.php?id=28623

https:// protocol works without a problem on the rest of my website and does not come up with that error. The only time it occurs is when I login to my piwigo gallery.

Is there a way to fix the error?

Piwigo 2.9.4
Operating system: Linux
PHP: 7.0.31 (Show info) [2018-08-20 11:23:06]
MySQL: 5.6.39-cll-lve [2018-08-20 11:23:06]
Graphics Library: ImageMagick 6.9.4-10
https://www.skyboundaviation.pw/Gallery/

Offline

 

#2 2019-05-01 12:03:03

geraldmuller
Member
2019-05-01
1

Re: Piwigo giving SSL connection error

The error message ERR_SSL_PROTOCOL_ERROR error indicates that the browser is not able to initiate the secured communication at the moment. It's almost impossible to pin it down to a single cause, it could be almost anything. There is no definite guide for managing this error. However, there are few changes or settings which help you to get rid you of this error.

    Configure Correct Date and Time
    Clear Browsing Data
    Clear Your SSL State
    Disable QUIC Protocol of Chrome
    Disable your Internet Browser Extensions
    Adjust Your Internet Security and Privacy Level
    Remove your system's hosts file
    Check Your Antivirus Settings
    Check Your Firewall

Offline

 

#3 2019-05-01 13:35:36

erAck
Only trying to help
2015-09-06
1414

Re: Piwigo giving SSL connection error

Seems you removed your site (not found). However, apparently you had been hit by the reverse proxy problem, see [Github] Piwigo issue #681 and the workaround near the bottom [Github] Piwigo issue #681 (this last link should had appended the fragment #issuecomment-444916099 but apparently the board software tries to be overly smart and converts the URL removing it).


Running Piwigo at https://erack.net/gallery/

Offline

 

#4 2019-05-01 19:07:24

Zentalquabula
Member
2014-05-10
208

Re: Piwigo giving SSL connection error

Well, https://www.skyboundaviation.pw:80/Gallery/ will never work because it assumes port 443 by https and port 80 by reference. Mismatch.

Check your apache config if there is anything that adds a port 80 somewhere. Thenadd this to make your site always use https:

<VirtualHost *:80>
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI}
</VirtualHost>

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact