Announcement

  •  » Requests
  •  » PIWIGO and MYSQL 8.0

#1 2018-10-24 15:04:13

tancred23
Member
2018-10-24
1

PIWIGO and MYSQL 8.0

Hi,

I really like piwigo and want to expand my use of it including using my MySQL innodb cluster (MySQL 8.0.13) for database storage.

However there seems to be several incompatibilities (reserved words, authentication, others? ) between 2.9.4 and MySQL 8.0.

Everything runs fine with 2.9.4 on a standalone MySQL 5.7.19 instance

Downgrading to MySQL 5.7.x on my cluster is not an option

Do any of the upcoming roadmap plans (2.10 or even 3.0) include an upgrade path for 2.9.4 installs to give 8.0 compatibility?

Thanks

Piwigo version:2.9.4
PHP version: 7.0.32
MySQL version: 5.7.19 (and trying to make 8.0.13 work without success)
Piwigo URL: http://

Offline

 

#2 2018-10-24 18:51:38

erAck
Piwigo Team
2015-09-06
300

Re: PIWIGO and MYSQL 8.0

[Github] Piwigo issue #919

Last edited by erAck (2018-10-24 18:52:39)


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2019-04-04 10:14:02

danibo
Member
Zurich
2009-10-07
41

Re: PIWIGO and MYSQL 8.0

Hallo
I am still on MySql 5.6 and Piwigo 2.9.4 with theme Modus

Piwigo 2.9.4
Betriebssystem: Linux
PHP: 5.6.40 (Info anzeigen) [2019-04-04 02:30:15]
MySQL: 5.6.43 [2019-04-04 10:30:15]
Grafikbibliothek: External ImageMagick 6.7.2-7

My provider urges me to update to MySQL 5.7.

I am little insecure because I was reading some issues with MySQL 5.7 and Piwigo. Are they solved now or do you recommend to wait with the update.

Thank you for a short feedback.
daniel

PS: of couse i have a backup of the whole system ;-)

Offline

 

#4 2019-04-04 10:29:06

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13276

Re: PIWIGO and MYSQL 8.0

@danibo Piwigo 2.9.4 should work fine on MySQL 5.7 and works perfectly fine on MariaDB 10.1 (that's what we use on Piwigo.com)

The problem is indeed with the new MySQL 8, as mentioned by erAck in [Github] Piwigo issue #919

Offline

 

#5 2019-10-25 05:25:07

windracer
Member
St. Pete, FL
2014-12-28
250

Re: PIWIGO and MYSQL 8.0

Shoot ... I just ran into this after upgrading my server to Ubuntu 19.10, which included MySQL 8.0. Lots of errors because 'groups' is a reserved word so it looks like any SELECT against that 'groups' table throws the warning:

Code:

Warning:  [mysql error 1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups ORDER BY name' at line 1
SELECT id, name FROM groups ORDER BY name in /usr/local/piwigo/include/dblayer/functions_mysqli.inc.php on line 856

Is there a quick fix to this? My problem seems related, but different, than the Github issue since it's the actual table name causing the problem (and not a 'group AS groups' syntax).

Offline

 

#6 2019-10-25 23:56:30

erAck
Piwigo Team
2015-09-06
300

Re: PIWIGO and MYSQL 8.0

Likely that's from GrumPluginClasses
plugins/GrumPluginClasses/classes/GPCUsersGroups.class.inc.php line 190 that reads

    $sql="SELECT id, name FROM ".GROUPS_TABLE." ORDER BY name";

Change it to quote the table name in ` backticks, as

Code:

    $sql="SELECT id, name FROM `".GROUPS_TABLE."` ORDER BY name";

That, or any other plugin assembling such query, I didn't find another in my installation.


Running Piwigo at https://erack.net/gallery/

Offline

 

#7 2019-10-27 02:52:04

windracer
Member
St. Pete, FL
2014-12-28
250

Re: PIWIGO and MYSQL 8.0

Thanks for the tip.

In addition to GrumPluginClasses I also found the problem in plugins/AMenuManager/amm_root.class.inc.php (lines 532 and 556) and also line 170 in plugins/AdditionalPages/admin/add_page.inc.php.

That fixed the errors.

Offline

 
  •  » Requests
  •  » PIWIGO and MYSQL 8.0

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact