Announcement

#1 2019-11-04 21:15:17

J0nny
Member
2017-12-15
31

trouble displaying Google adsense adverts

Hi,

I have just added Google adsense adverts to my website but they do not show up in my piwigo gallery. Is this a google problem is is there something wrong with the way I have implemented it?  I have 2 types of ad unit, display ad and in article ad and I have put one under the photo with PWG stuffs and then, temporarily I have one in the footer inserted with Perso footer. I have the same adds and scripts on 2 static HMTML pages and they show, so its not a google acceptance problem. Just under the google add in PWG stuffs is an advert from "Booking" and that shows without a problem. Any suggestions?

Here is an example- https://www.webbaviation.co.uk/aerial/p … egory/1275

The first add is under the photo and description but above the Booking add. the second is on the bottom of the page, between powered by piwigo and the legal disclaimers / copyright notice at the bottom. Neither show up.  By comparison, following are 2 old static html pages where the ads show up without problem. the ads are under all the thumbnails and before any other text-

https://www.webbaviation.co.uk/castles/castles.htm

https://www.webbaviation.co.uk/aerial-a … eology.htm

I have read other forum posts regarding putting adsense on piwigo and people appear to have done it with  PWG stuffs without a problem.

The google automatic ad placement is switched off as I didn't want adds above my photos.

regards,

Jonnny

Piwigo 2.10.1 Check for upgrade
Operating system: Linux
PHP: 5.6.40 (Show info) [2019-11-04 15:03:34]
MySQL: 5.6.42-log [2019-11-04 15:03:34]
Graphics Library: External ImageMagick 7.0.8-50

Offline

 

#2 2019-11-04 21:37:36

J0nny
Member
2017-12-15
31

Re: trouble displaying Google adsense adverts

I've found the answer to my own problem, but it may benefit others to know what I found.

Having looked through very many pages all day I haven't seen a google add, but as soon as I posted the above, I stumbled on one displaying correctly. They seem to display OK on my album page for Westminister photos-

https://www.webbaviation.co.uk/aerial/i … tegory/586

So far they dont show elsewhere, except just one of the Westminister photo pages . https://www.webbaviation.co.uk/aerial/p … tegory/586

I think the problem is adsense does not lend itself well to a photo gallery, especially one covering landscapes and historic buildings.  It must be that google has no advertisers who want an advert against a photo of a historic building.  Either that or such pages do not generate enough traffic. I have lots of traffic on the website as a whole, but each page usually only gets a few hundred views per year.

It could be that google only applies adverts to pages which rank high in a text search. Mine rank poorly in text searches but some do well in image searches.

Interestingly the one photo which is displaying ads is my third most popular photo (1911 visits ) , however the first ( 2196 visits ) and second ( 2181 visits ) most popular do not show any adsense, nor indeed any other of the most visited pages.

google works in mysterious ways !

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact