Announcement

#1 2019-10-14 14:04:36

frederikv
Member
2019-10-14
2

Digikam / kipi upload not working on 2.10.0

Hello,

Trying to upload from digikam to a piwigo instance updated to 2.10.0 results in an error:

Failed to login into remote piwigo. Upload to Piwigo version < 2.4 is no longer supported

Piwigo version: 2.10.0
PHP version: 7.3.9-1~deb10u1
MySQL version: 10.3.17-MariaDB-0+deb10u1
Piwigo URL: https://photos.vanrenterghem.biz

On the server, I have the following in the log:

10.200.200.2 - - [14/Oct/2019:13:57:00 +0200] "POST /ws.php HTTP/1.1" 200 4316 "-" "Mozilla/5.0"

The md5sum of that file corresponds to the one of the upload package.

Offline

 

#2 2019-10-14 14:47:56

reddn
Member
DC, USA
2015-09-29
30

Re: Digikam / kipi upload not working on 2.10.0

Might want to turn on verbose logging on your server for this. Also look at the digikam code.  I wonder if they parse the first number after the decimal ( the number 1 in this case), add it as the tenths place t to the whole number 2, so in code it would be a 2.1 which is less than 2.4 .  Ive personally done some crappy parsing that does that and it did not account for number after.  Maybe going into the piwigo code and changing its version number (this make screw other things up and is probably not recommended, but I bet it would work)

Good luck.

Offline

 

#3 2019-10-14 18:51:16

erAck
Only trying to help
2015-09-06
532

Re: Digikam / kipi upload not working on 2.10.0

I confirm the digikam piwigo export plugin is stupid. Changing Piwigo include/ws_functions/pwg.php at line 127 to let ws_getVersion() (API pwg.getVersion) return '2.9.9' instead of the proper PHPWG_VERSION makes it work again.

Code:

function ws_getVersion($params, &$service)
{
  //return PHPWG_VERSION;
  // erAck: digikam Piwigo export plugin is stupid, 2.10.1 < 2.4 ...
  return '2.9.9';
}

Of course some other external may rely on the proper version being returned; also note that ws_getInfos() (admin-only API pwg.getInfos) and ws_session_getStatus() (API pwg.session.getStatus) still return the proper value.


Running Piwigo at https://erack.net/gallery/

Offline

 

#4 2019-10-14 19:39:38

erAck
Only trying to help
2015-09-06
532

Re: Digikam / kipi upload not working on 2.10.0


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2019-11-18 13:08:24

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13313

Re: Digikam / kipi upload not working on 2.10.0

Thanks a lot erAck for the report :-)

On Piwigo.com, I did this:

Code:

function ws_getVersion($params, &$service)
{
  // specific for digiKam, which considers 2.10 is inferior to 2.4 :-/
  if ('/accounts/b/i/s/bisgbkvdoa' == $_SERVER['ACCOUNT_PATH'] and isset($_SERVER['HTTP_USER_AGENT']) and 'Mozilla/5.0' == $_SERVER['HTTP_USER_AGENT'])
  {
    return '2.9.6';
  }
  return PHPWG_VERSION;
}

To make it very specific to a given account.

Unfortunately the user-agent is a basic "Mozilla/5.0" instead of a more specific user agent, for example :

* Piwigo iOS : piwigo/2.4.5 (iPhone; iOS 13.2.2; Scale/2.00)
* Piwigo Android : Piwigo-Android 1.0.2
* Wordpress : WordPress/5.2.4
* ReGalAndroid : ReGalAndroid Version : 1.2.0
* Lightroom : Lightroom%20Classic/9.0 CFNetwork/1120 Darwin/19.0.0 (x86_64)

If we had a "digiKam 6.3.9", it would be much simpler to customize the response.

Offline

 

#6 2020-02-01 16:01:05

fibule
Member
2020-02-01
1

Re: Digikam / kipi upload not working on 2.10.0

Bonjour,

Je pose ma question dans cette conversation car elle la concerne ...un peu.

Configuration:

Pc :
Ubuntu 18.04 LTS
Digikam 5.6.0
Navigateur Chromium : 79.0.3945.79

Serveur:
Yunohost : 3.6.5.3
Piwigo : 2.10.0

Je suis concerné par le dysfonctionnement du plugin d'export de Digikam (vers 5.6.0) vers Piwigo (2.10) auto hébergé.

En attendant (j'espère) la version 6.0 de Digikam corrigée au niveau du Plugin sous Ubuntu (peut-être dans la version 20.04..), quelqu'un pourrait-il m'aider à implémenter une modif provisoire telle que celle ci-dessus?

Il me manque un minimum de compétences pour savoir où toucher...sans tout casser!!!

Merci d'avance
Cordialement

Last edited by fibule (2020-02-04 16:24:17)

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2020 · Contact