Announcement

#1 2020-04-05 04:39:31

Jan Becket
Member
2015-01-17
35

entire Piwigo site vanished - cannot access

Greetings,

I was having a persistent problem with long, unintelligible (to me) warnings at the top of my home page. I created a message here on the forum about a year ago, or maybe more, and then gave up and lived with the issue. However, today I made another attempt to fix the issue and tried to rewrite the items under the "Links" menu in the configuration menu item just in case that was the cause of the problem. Here is the original links config text (which worked fine below all the lines of warning text in the home page header):

<?php

$conf['links'] = array(
    'http://www.janbecket.net' => 'Return to janbecket.net',
    'http://www.janbecket.net/wordpress/?page_id=538' => 'Apologia',
    'http://www.abookofstones.com' => 'A Book of Stones',
   );




?>

Here is what I edited and saved - without the "<?php" in the first line and without the ?> at the end.


$conf['links'] = array(
    'http://www.janbecket.net' => 'Return to janbecket.net',
    'http://www.janbecket.net/wordpress/?page_id=538' => 'Apologia',
    'http://www.abookofstones.com' => 'A Book of Stones',
   );

As far as I could see, saving the text also resulted in those items being added automatically. However when I navigated away from that page, the entire site was immediately gone. No code or error message. Just a blank white page on the screen, and no way to access the admin functions to reverse anything.

Since I noticed an issue with compatibility with php versions in this forum, I logged onto my hosting C-Panel and confirmed that my php was the latest version. I even backtracked and made 7.2 and 7.1 the active versions for my site, but that makes no difference.

I am hoping that the fix does not turn out to be deleting the entire site. Thanks for any help!

- Jan


Piwigo version: 2.10.12
PHP version: 7.3
MySQL version: 5.6.43
Piwigo URL: http://www.thebookofparis.com/piwigo/

Offline

 

#2 2020-04-05 06:49:17

Jan Becket
Member
2015-01-17
35

Re: entire Piwigo site vanished - cannot access

I forgot to add to my post that I am using only 3 plugins: Admin Tools, Right Click and Localfiles Editor. The site itself is actually one of two sub-domains on my primary website: www.janbecket.net. Thus, there are three complete installations of Piwigo in separate folders on my hosting site.

- J

Offline

 

#3 2020-04-05 06:51:38

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7067

Re: entire Piwigo site vanished - cannot access

Hi :-)

It's better use plugin local file editor for add local config

you must add <?php for gegining file without space before <


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#4 2020-04-05 06:56:52

Jan Becket
Member
2015-01-17
35

Re: entire Piwigo site vanished - cannot access

The immediate problem is that I cannot access the site in order to correct the problem.

I am only semi-literate in working under the hood. If I go into the file editor on my web hosting site through C-Panel, where would I locate the incorrect syntax in order to correct it?

thanks for any suggestions,
Jan

Offline

 

#5 2020-04-05 07:16:35

Jan Becket
Member
2015-01-17
35

Re: entire Piwigo site vanished - cannot access

I went into my file editor on my hosting site and looked for the location of the incorrect syntax, and found it in Piwigo/local/config. The problem seems to be that the <?php was placed on the first line with the other text:

<?php$conf['links'] = array(

Apparently that was what crashed my site. When I added a return to place <?php on its own line in the file editor, the site functions again. Thatʻs a relief.

However, I am back to the original problem I tried to fix. It is obvious if one goes to my home page: http://www.thebookofparis.com/piwigo/

I was hoping that if I left it alone, a Piwigo update would fix the issue. Iʻll open a fresh topic and request help.

thanks again,
- J

Offline

 

#6 2020-04-13 02:25:26

Emk
Member
2019-12-20
14

Re: entire Piwigo site vanished - cannot access

Offline

 

#7 2020-04-13 02:30:45

Emk
Member
2019-12-20
14

Re: entire Piwigo site vanished - cannot access

Also check the solution here on Stackoverflow - https://stackoverflow.com/questions/802 … ror-in-php

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact