Announcement

  •  » Extensions
  •  » Connection to server unavailable

#16 2019-03-02 21:12:08

wurdeman
Member
2019-02-25
15

Re: Connection to server unavailable

Hi guys...

My mind explodes when I deal at that level of code.  I don't know what that means or what transaction resulted in that response. 

I was hoping that when a connection isn't made, that both ends would log the event.  I wasn't able to get my guys to find a log entr.  They just came back and said nothing was blocked, so it wasn't my end rejecting, like in this case, mail.

As far as connecting for upgrades, plugins, etc., I don't know the handshaking involved.  I would think they are related.

Since I believe in KISS, what I would be testing is what is easier, mail.  If I send someone a mail, and it is rejected, either a missing mailbox, or the server rejected the email, a well documented rejection mail is received.  I am guessing mail from the forum isn't reviewed or reacted to, so if a mail came back from the forum's signup process, it would show why it wasn't sent or why it was rejected.

So in my mind, if someone who can send email from the server, and would receive the "reaction", that would be a start.  I didn't get responses to two different domains on my server.  I had to go to a Gmail signon to get a response to get on the forum, not the domain I wanted affiliated with my access here.

I actually think my first Piwigo did make a connection to the Piwigo server, but that was awhile ago so I don't remember for sure.

Appreciate your help!

Offline

 

#17 2019-03-02 22:16:23

erAck
Only trying to help
2015-09-06
1340

Re: Connection to server unavailable

executive wrote:

wurdeman wrote:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.68.rc1.el6_10.1 <<>> piwigo.org
;; global options: +cmd
;; Got answer:

Doesn't this mean piwigo.org replied to your server?

That only means his DNS resolver on internal 10.0.80.11 knows an IP for it, nothing else.


Running Piwigo at https://erack.net/gallery/

Offline

 

#18 2019-03-03 11:13:49

teekay
Member
2013-06-12
427

Re: Connection to server unavailable

What does a simple

Code:

curl -I -v https://piwigo.org

spit out?

As erAck pointed out already, outgoing HTTP requests and email send/receive are completely unrelated types of problems (the latter of which is completely out of scope on these forums).

Offline

 

#19 2019-03-05 02:30:15

wurdeman
Member
2019-02-25
15

Re: Connection to server unavailable

Thanks for the code....

root@server6 [~]# curl -I -v https://piwigo.org
* About to connect() to piwigo.org port 443 (#0)
*   Trying 87.98.147.22... Connection refused
* couldn't connect to host
* Closing connection #0
curl: (7) couldn't connect to hostexit

Offline

 

#20 2019-03-05 17:44:33

erAck
Only trying to help
2015-09-06
1340

Re: Connection to server unavailable

Code:

traceroute -p 443 piwigo.org

?


Running Piwigo at https://erack.net/gallery/

Offline

 

#21 2020-10-07 17:17:27

drewlander
Member
2020-10-07
20

Re: Connection to server unavailable

Gentlemen, I am an IT specialist / software developer by trade. I ran into this problem and came to the forums to see what others said. I was able to resolve my problem and wanted to post about it because I think this could help others who said they had better luck after switching hosts.

My situations symptoms:
Windows Computers could connect to Piwigo.org
Linux servers COULD NOT connect to Piwigo.org
Current Piwigo version installed to Ubuntu 18.04 Apache 2.4 PHP7.4-FPM*

On the linux machine I performed a dig and could resolve the server. I could not curl to get the download, nor could I even curl the main site, or wget the main site piwigo.org.  Other sites did work.  There was nothing wrong with dns resolution.  All of my servers are headless so I installed a linux workstation and tried to connect to Piwigo via google chrome web browser. I was able to make that connection, but still unable to curl and wget from command line. 

I still have no idea what the web browser is doing to bypass the cause of the problem but the web browsers were able to access the site when they were not supposed to be able to by my router configuration. The root cause was in my security gateway. At home I run a full Ubiquiti Unifi setup similar to my office. There is a setting for GeoIP filtering to allow or block traffic by country.  I allowed only US traffic when it was not working. As soon as I disabled the filter the plugins and updates worked from the site, and I could curl and wget from the command line as well. 

I cross referenced the IP from piwigo.org in whois to see who it was assigned to. It was RIPE out of Netherlands as I suspected, but that is not necessarily the country assigned to the address.  Cross referenced the geolocalization for this ip assignment https://www.geodatatool.com/en/?IP=51.38.237.64 and found this IP is assigned to France.  Added France to the allowed list in the firewall and everything works. 

Bottom line -- it was a firewalling issue on the client end blocking the connection to France. 

* with php7.4 most things work but there are some errors. Particularly with mysql and the implode function which no longer supports reversed parameters.  I will create a separate issue on this.  https://www.php.net/manual/en/migration … ecated.php Implode with historical parameter order Passing parameters to implode() in reverse order is deprecated, use implode($glue, $parts) instead of implode($parts, $glue).

Offline

 

#22 2020-10-07 17:42:33

erAck
Only trying to help
2015-09-06
1340

Re: Connection to server unavailable

Thanks for adding another possible cause.

That's a very selective "internet" though with (now) only two countries.. does that even make any sense?
Anyway.. have fun.


Running Piwigo at https://erack.net/gallery/

Offline

 

#23 2020-10-07 19:55:59

drewlander
Member
2020-10-07
20

Re: Connection to server unavailable

If I had only a Piwigo server running in my data closet at home then I would open it wide. With my dev servers for work its a completely different story. 

The takeaway I was shooting for was that even though many factors indicated an isolated problem with one device inside my network it was in fact a broader issue in the firewall blocking the traffic. It's still a mystery to me how google chrome was getting around the firewall. Its as if they are proxying the web traffic between the web browser and piwigo.org server.

Offline

 
  •  » Extensions
  •  » Connection to server unavailable

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact