Announcement

#1 2020-10-11 10:48:25

endrju83
Member
2020-10-11
11

iOS application v2.5.1 connection error (worked few days ago)

Hello,

yesterday (10.10.2020) my login to iOS app suddenly stopped working. It displayed some message like "Connection not private".. I dont remeber the exact message... (Never had this message before)
I have agreed with unsecure connection but then I was not able to login.

A few days ago (2-3) I was able to log in and since yesterday I am getting error message (I am still using the same credentials and the same domain):

Connection Error
Request failed: not found (404)

In between those days, I have not done any upgrade of the iOS app neither the web piwigo app. Also no change in PHP or MySQL version.

I do not have any SSL, so I am using both on my web and iOS app the HTTP protocol, although in the iOS app I do not specify the "HTTP". I was always using just the domain to connect and it worked.

I have tried to use "http://" before the domain but it give me the same error message.
If I specify the port ":80" then the error is:

Connection Error
Request failed: unacceptable content-type: text/html

You can try to reproduce on URL photo.ondrejkrhut.cz with user name "ios_con_error" (password is the same as the user name).
Content of my galery is private so you will see only one album with error screenshots from my iOS app (connection works via web browser).

Hopefully you can help me with this. Currently I can not use HTTPS, only HTTP. Connection via iOS app was working before without any problems and as I have said I did not performed any upgrades and the log in have stopped working. In my humble opinion something at the backend have must been changed.

Piwigo iOS version: 2.5.1 (301)
PHP version: 7.1
MySQL version: 5.6.12
Piwigo URL: http://photo.ondrejkrhut.cz/

Offline

 

#2 2020-10-11 14:42:58

erAck
Only trying to help
2015-09-06
1417

Re: iOS application v2.5.1 connection error (worked few days ago)

endrju83 wrote:

You can try to reproduce on URL photo.ondrejkrhut.cz with user name "ios_con_error" (password is the same as the user name).

Works for me. I can login and see three screenshots.


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2020-10-11 14:50:13

endrju83
Member
2020-10-11
11

Re: iOS application v2.5.1 connection error (worked few days ago)

You can log in using an iOS app?

Offline

 

#4 2020-10-11 15:07:22

endrju83
Member
2020-10-11
11

Re: iOS application v2.5.1 connection error (worked few days ago)

In the meantime, I have decided that I dont want to wait for the solution andded HTTPS support for my webhosting - so now I can connect also via iOS app.

But after this I dont know how to reproduce this connection error again.

Offline

 

#5 2020-10-11 15:17:58

erAck
Only trying to help
2015-09-06
1417

Re: iOS application v2.5.1 connection error (worked few days ago)

Ah sorry, no, misread that, just normal login. But on http://photo.ondrejkrhut.cz/tools/ws.htm using pwg.session.login also works.


Running Piwigo at https://erack.net/gallery/

Offline

 

#6 2020-10-11 16:20:32

endrju83
Member
2020-10-11
11

Re: iOS application v2.5.1 connection error (worked few days ago)

Well, first time hearing about some web services tools for piwigo.

Anyway pwg.session.login returns:
REST (xml) = 1
JSON = {"stat":"ok","result":true}
PHP serial = a:2:{s:4:"stat";s:2:"ok";s:6:"result";b:1;}
XML PRC = Fatal error: Cannot redeclare xmlrpc_encode() in /data/.../include/ws_protocols/xmlrpc_encoder.php on line 46

This was with HTTPS activated for this domain.


Now I have tried to deactivate HTTPS to check again with this web service and the result on the pwg.session.login is still the same but I am now able to log into the iOS app again.
I dont uderstand what could have changed (HTTPS was still active for ondrejkrhut.cz but not for photo.ondrejkrhut.cz).

I could try to decativate HTTPS for the whole domain if that will make any sence.

Last edited by endrju83 (2020-10-11 16:21:24)

Offline

 

#7 2020-10-11 17:06:18

endrju83
Member
2020-10-11
11

Re: iOS application v2.5.1 connection error (worked few days ago)

Okay, I have just confirmed - without HTTPS support I am no more able to connect to Piwigo iOS Application.

I have completly disabled HTTPS support for entaire domain.
Login via web broser works,
but login via iOS app is not working - same error as before

Connection Error
Request failed: not found (404)

But the response from the web service is still the same (this time without HTTPS support) http://photo.ondrejkrhut.cz/tools/ws.htm :
pwg.session.login returns:

REST (xml) =1
JSON = {"stat":"ok","result":true}
PHP serial = a:2:{s:4:"stat";s:2:"ok";s:6:"result";b:1;}
XML PRC = Fatal error: Cannot redeclare xmlrpc_encode() in /data/.../include/ws_protocols/xmlrpc_encoder.php on line 46

So I will leave my web without HTTPS support until tomorow, so you can try again.

Side note: I am able to connect to a DEMO via iOS app, but it have a HTTPS.

Last edited by endrju83 (2020-10-11 17:06:54)

Offline

 

#8 2020-10-13 15:10:47

AntonLargiader
Member
2019-04-21
7

Re: iOS application v2.5.1 connection error (worked few days ago)

I have the exact same issue. I can log in from a PC but not in the IOS app. I get the 404 error.

"Request failed: not found (404)"

http://vamotorrad.com/album

Offline

 

#9 2020-10-14 22:33:53

cryopad
Piwigo Team
Grenoble, France
2015-11-01
166

Re: iOS application v2.5.1 connection error (worked few days ago)

Hi AntonLargiader,

Your server first returns an SSL certificate containing an address *.prod.iad2.secureserver.net which is different from the address vamotorrad.com. That is why the app warns you with a message.

After accepting the risk, the Piwigo iOS app sends the following request to the server:https://vamotorrad.com/album/ws.php?format=json&method=reflection.getMethodList. The server returns an empty response. That is why you get the error "404 Not Found". If I paste the above request in Safari, I get the same error message.

To access your website, install a valid SSL certificate. If you cannot do so, disable the HTTPS mode on the server.

Best regards


If you enjoy Piwigo for iOS…
➤ We would appreciate an AppStore review.
➤ Comments, suggestions ? Tell us on GitHub…
➤ Not yet available in your language ? Help us translate it…

Offline

 

#10 2020-10-14 22:39:07

cryopad
Piwigo Team
Grenoble, France
2015-11-01
166

Re: iOS application v2.5.1 connection error (worked few days ago)

Hi endrju83,

I've just made a quick test and the iOS app connects successfully to your server with a valid SSL certificate. Perfect! Of course, I get an error 401 because I am not authorised.

Cheers


If you enjoy Piwigo for iOS…
➤ We would appreciate an AppStore review.
➤ Comments, suggestions ? Tell us on GitHub…
➤ Not yet available in your language ? Help us translate it…

Offline

 

#11 2020-10-15 03:00:41

AntonLargiader
Member
2019-04-21
7

Re: iOS application v2.5.1 connection error (worked few days ago)

cryopad wrote:

After accepting the risk, the Piwigo iOS app sends the following request to the server:https://vamotorrad.com/album/ws.php?format=json&method=reflection.getMethodList. The server returns an empty response.

Thank you very much for that. I had no idea that https was even happening in any form on my website. To the best of my knowledge I had no involvement in SSL or https.

What changed? This used to work. Did the iOS app not send the request with https before, or has my server changed the way it responds?

Offline

 

#12 2020-10-15 08:10:01

cryopad
Piwigo Team
Grenoble, France
2015-11-01
166

Re: iOS application v2.5.1 connection error (worked few days ago)

In previous versions, the app was accepting invalid SSL certificates and switching to the HTTP mode automatically in case of error.

Now it warns when the SSL certificate is invalid and tries to connect if the user wishes to access a web site providing an invalid certificate. It switches to the HTTP mode if the server does not manage the HTTPS mode.

Cheers


If you enjoy Piwigo for iOS…
➤ We would appreciate an AppStore review.
➤ Comments, suggestions ? Tell us on GitHub…
➤ Not yet available in your language ? Help us translate it…

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact