Announcement

#1 2020-10-20 18:20:00

t4c
Member
2020-10-20
4

Plugin Update fails, need debugging or logs

Hello/Hi/Greetings,

got a very fresh installation of piwigo which mentions some updates for a plugin.
After clicking install it gives me an ERROR which is truely not enough information for debugging.

Where can I see or find some debug logs or something? My php logs are empty.


Regards





Piwigo 2.10.2
PHP: 7.3.19-1~deb10u1 (Info anzeigen) [2020-10-20 18:17:43]
MySQL: 5.5.5-10.3.23-MariaDB-0+deb10u1 [2020-10-20 18:17:43]
GD 2.2.5

Offline

 

#2 2020-10-20 18:28:56

jnashpiwigo
Piwigo Team
2014-10-21
246

Re: Plugin Update fails, need debugging or logs

How about posting the error(s)?

Offline

 

#3 2020-10-21 09:22:27

t4c
Member
2020-10-20
4

Re: Plugin Update fails, need debugging or logs

How about reading my post correctly?
Piwigo just gives me one word: Error.
Which I mentioned to be not helpful.

Offline

 

#4 2020-10-21 16:13:35

jnashpiwigo
Piwigo Team
2014-10-21
246

Re: Plugin Update fails, need debugging or logs

Gotcha, read your message over and it says it gave you an ERROR - so knowing what that was would be helpful.

Check you webserver error logs and see if anything is there.

There is also the piwigo logs in the _data/logs directory - that may help as well

However, plugins are independently developed and may not provide logging details.  If you're trying to update it, you could try removing and reinstalling?

Offline

 

#5 2020-10-21 16:23:58

t4c
Member
2020-10-20
4

Re: Plugin Update fails, need debugging or logs

error logs are empty.

_data/logs does not throw anything while displaying the error banner :(.
Just the access log gave me [21/Oct/2020:16:17:58 +0200] "GET /gallery/themes/default/js/plugins/jgrowl-error.png HTTP/1.1" 200 2276
which is as useful as the "error" message itself.

Wanted to find the problem, not a workaround. Something seems to be misconfigurated on my side.

Offline

 

#6 2020-10-21 16:25:51

jnashpiwigo
Piwigo Team
2014-10-21
246

Re: Plugin Update fails, need debugging or logs

What's the plugin name?

Also, can you open the dev console in your browser and see if anything shows there?

Offline

 

#7 2020-10-21 17:22:02

t4c
Member
2020-10-20
4

Re: Plugin Update fails, need debugging or logs

Plugin is "modus", seems to be one of the preshippe ones.

Offline

 

#8 2020-10-21 17:29:46

jnashpiwigo
Piwigo Team
2014-10-21
246

Re: Plugin Update fails, need debugging or logs

Hmmm, theme built in issue - only thing I can think of is permissions perhaps?

Offline

 

#9 2020-12-06 10:57:48

soniram
Member
2020-12-06
2

Re: Plugin Update fails, need debugging or logs

Same problem here.

- Fresh installation
- Got updates notification
- The only update is for modus  version : 2.10.2.1
- Firing update all or install I'm getting an empty error popup (just says ERROR)
- nothing in nginx error log
- nothing in _data/logs/log_xxx.txt. Just these lines
[2020-12-06 9:23:48]    [DEBUG]    extract_theme_files, $main_filepath = modus/themeconf.inc.php
[2020-12-06 9:23:48]    [DEBUG]    extract_theme_files, $extract_path = ./themes/modus

Any ideas ?

Offline

 

#10 2020-12-06 13:18:56

soniram
Member
2020-12-06
2

Re: Plugin Update fails, need debugging or logs

t4c was right. Thanks t4c !!
It was a permissions problem.

I hadn't set correct permissions after moving the unziped files to my /var/www folder.

sudo chown -R www-data:www-data /var/www/...your piwigo path..
sudo chmod -R 755 /var/www/html/...your piwigo path..

These fixed the problem after a fresh install.
WARNING !! running the above commands on a running system will brake it. Perhaps someone knowing Piwigo better than me could avoid it.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact