Announcement

#1 2012-11-15 11:14:49

Geno Shishkov
Guest

Problem when i share image on Facebook

Hi,
I have one Piwigo instalation with FB plugin and  SEO frendly URL-s. On first glance everithing look fine.

http://www.algaivel.com/portfolio/pictu … 0%A2%D0%98

In source open graph meta tags looks ok. But when i share some picture in facebook  i receive PHP errors messages, It can be tested here:

https://developers.facebook.com/tools/d … %25D0%2598

Any idea why i receive that errors, and how can i avoid that?

 

#2 2012-11-15 12:05:42

Geno Shishkov
Guest

Re: Problem when i share image on Facebook

Fixed when I change in LocalFile editor plugin this configuration

$conf['picture_url_style'] = 'file';

to

$conf['picture_url_style'] = 'id-file';

 

#3 2021-05-17 03:19:29

hoco
Member
2021-05-17
1

Re: Problem when i share image on Facebook

I edited include/config_default.inc.php and made the same change suggested by Geno Shishkov and it worked for me.  Specifically:

$conf['picture_url_style'] = 'id-file';

Not only did it work, but also, previously it had been set to "id" and I was concerned than all previous links would be broken.  But, they still work even after the change.  To repeat, links formed based on id work when accessed using id-file.  That is some nice backward compatibility!

Offline

 

#4 2021-05-17 12:02:32

erAck
Only trying to help
2015-09-06
1366

Re: Problem when i share image on Facebook

For 'id' or 'id-file' Piwigo takes only the ID for image identification, you can also append any string foo after ID so it looks 123-foo in the URL.


Running Piwigo at https://erack.net/gallery/

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact