Announcement

#1 2021-11-08 12:11:29

mazreds
Member
2021-11-08
2

Cannot activate plugins

Hello/Hi/Greetings,

We installed ver. 12 and now we are not able anymore to activate any plugin... The plugin list shows up on one column only:

https://vm-podcast.csi.it/mlab/PIWIGO_PLUGINS.png

and if we click the activate button for a given plugin, it turns on but it does not work at all. If we refresh the page, the plugin is still deactivated...
We are able to install new plugins, but not to activate them...
The table piwigo_plugins is always empy, no matter which plugin we install...
When the plugin page shows up, browser raised the error: "nb_plugin is not defined":

https://vm-podcast.csi.it/mlab/PIWIGO_ERROR.png

Piwigo 12.0.0 Controllo aggiornamenti
Sistema operativo: Linux
PHP: 7.4.3 [2021-11-08 14:05:20]
MySQL: 8.0.27-0ubuntu0.20.04.1 [2021-11-08 13:05:20]
Libreria grafica: GD 2.2.5
Cache size 0.29 Mo   calculated 1 ora fa

Here is our complete phpinfo:

https://vm-podcast.csi.it/mlab/PHPINFO.png

Piwigo URL: (not a public server, sorry...)

Any ideas? Thank you in advance...

Offline

 

#2 2021-11-10 13:12:55

fseveri
Member
1970-01-01
7

Re: Cannot activate plugins

I have the same problem

This is my ambient:

Piwigo 12.0.0 Controllo aggiornamenti
Sistema operativo: Linux
PHP: 7.3.18-1+0~20200515.59+debian9~1.gbp12fa4f (Mostra le informazioni) [2021-11-10 13:12:28]
MySQL: 5.7.30 [2021-11-10 13:12:28]
Libreria grafica: GD 2.2.5
Cache size 4110.17 Mo   calculated 2 giorni fa

Offline

 

#3 2021-11-11 15:29:19

mazreds
Member
2021-11-08
2

Re: Cannot activate plugins

Hi.

We found the problem. In the italian locale messages file

language/it_IT/admin.lang.php

the single quotes (') are unproperly escaped, so they truncate JavaScript quoted string when rendered in web page, causing JS error and preventing the plugin activation from working.
We simply replaced \' with ` (ALT + 96) so everything now works properly.

Bye.

Offline

 

#4 2021-11-11 18:11:48

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13573

Re: Cannot activate plugins

I think it's related to [Github] Piwigo issue #1550

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact