Announcement

#1 2021-12-03 04:23:19

Radjin
Member
2019-08-13
10

[resolved] Admin broken

Hello all,

After running Piwigo for years without problems, tonight I broke something while removing unused plugins in preparation for the latest update as they were being shown in the incompatible list.

I removed a few without problems then I removed a fourth and began getting this error with no way to get back into admin.

Warning: include_once(./plugins/GrumPluginClasses/classes/CommonPlugin.class.inc.php): failed to open stream: No such file or directory in /var/www/radjin.net/html/community/gallery/plugins/AStat/astat_root.class.inc.php on line 18

Warning: include_once(): Failed opening './plugins/GrumPluginClasses/classes/CommonPlugin.class.inc.php' for inclusion (include_path='.:/usr/share/php') in /var/www/radjin.net/html/community/gallery/plugins/AStat/astat_root.class.inc.php on line 18

Fatal error: Uncaught Error: Class 'CommonPlugin' not found in /var/www/radjin.net/html/community/gallery/plugins/AStat/astat_root.class.inc.php:20 Stack trace: #0 /var/www/radjin.net/html/community/gallery/plugins/AStat/astat_aim.class.inc.php(18): include_once() #1 /var/www/radjin.net/html/community/gallery/plugins/AStat/main.inc.php(113): include_once('/var/www/radjin...') #2 /var/www/radjin.net/html/community/gallery/include/functions_plugins.inc.php(350): include_once('/var/www/radjin...') #3 /var/www/radjin.net/html/community/gallery/include/functions_plugins.inc.php(430): load_plugin(Array) #4 /var/www/radjin.net/html/community/gallery/include/common.inc.php(142): load_plugins() #5 /var/www/radjin.net/html/community/gallery/admin.php(16): include_once('/var/www/radjin...') #6 {main} thrown in /var/www/radjin.net/html/community/gallery/plugins/AStat/astat_root.class.inc.php on line 20

I grab a snapshot each night and copy it to a separate disk and can easily move the file back, however the file already exists leading me to believe there is a DB error rather than a file corruption. The gallery works fine except for admin access.

I would appreciate any suggestions.

Radjin

Last edited by Radjin (2021-12-03 13:05:27)

Offline

 

#2 2021-12-03 11:07:03

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13526

Re: [resolved] Admin broken

Hi Radjin,

You need to install plugin [extension by grum] Grum Plugin Classes (manually if necessary)

Offline

 

#3 2021-12-03 13:16:28

Radjin
Member
2019-08-13
10

Re: [resolved] Admin broken

Thank you very much.  That worked perfectly.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact