Announcement

#1 2022-01-06 21:20:47

Blomstrand
Member
2020-08-28
6

Upload cache issues ?

Hello :)

I'm having some really annoying issues when uploading images.
They start to compress/get corrupted when Piwigo works on them.

I'm suspecting a cache issue - and how do I resolve this ?

They look like this after a short while :
http://www.nmweb.dk/temp/screenshot.png


Piwigo 12.2.0 Opgraderingtjek
Styresystem: Linux
PHP: 8.0.14 (Vis info) [2022-01-06 20:16:50]
MySQL: 5.5.5-10.3.32-MariaDB-1:10.3.32+maria~focal [2022-01-06 20:16:50]
Grafikbibliotek: ImageMagick 6.9.10-23
Cachestørrelse 0 Mo   beregnet 13 minutter siden Opfrisk

Piwigo URL: http://www.nmweb.dk/photos

Offline

 

#2 2022-01-13 05:44:47

xdisciplex
Member
2022-01-01
5

Re: Upload cache issues ?

Having similar problems with a new install I'm trying to get up and running, many pictures being uploaded are being cut off and not loading fully so I have to delete and re-upload.

I'm also seeing incomplete uploads yet the system doesn't tell me which ones fail and I have to manually browse each folder to figure it out which is super time consuming.

Offline

 

#3 2022-01-13 10:36:02

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13541

Re: Upload cache issues ?

Hi Blomstrand,

Blomstrand wrote:

I'm having some really annoying issues when uploading images.

We're not especially experimenting this problem (on Piwigo.com I mean) so I don't suspect Piwigo 12 to be the problem compared to Piwigo 11.

On your Piwigo, in the gallery menu I see some :

1 Warning: Undefined array key "count_categories" in _data/templates_c/blablabla.file.menubar_related_categories.tpl.php on line 56

This kind of error might have side effects on upload. Please go to page [Administration > Tools > Maintenance] and update photos infos and album infos.

Offline

 

#4 2022-01-13 10:37:45

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13541

Re: Upload cache issues ?

Hi xdisciplex,

xdisciplex wrote:

Having similar problems with a new install I'm trying to get up and running, many pictures being uploaded are being cut off and not loading fully so I have to delete and re-upload.

Which upload method do you use? Web upload in the administration, like Blomstrand?

xdisciplex wrote:

I'm also seeing incomplete uploads yet the system doesn't tell me which ones fail and I have to manually browse each folder to figure it out which is super time consuming.

I agree, that's very painful and I sometimes have this problem too. We need to find a way to list the photos in error at the end of upload.

Offline

 

#5 2022-01-13 13:24:55

xdisciplex
Member
2022-01-01
5

Re: Upload cache issues ?

Yeah using the web upload in the admin console.  I'm on HostPapa with the latest version installed using the Softaculous installer they have in their CPanel.

I've noticed today if I upload in chunks of 10-15 I haven't had any partially loaded files, but occasionally still have files missing.  So at least if I do 10 at a time I can more quickly find out which one didn't upload.

Would love an error, or even just an alphabetized summary of what did successfully upload.  I'm numbering everything so if I see a gap in the numbers I can quickly see which file failed to upload.  Gallery had that option but also gave a summary 50/50 files successfully uploaded for instance.

Offline

 

#6 2022-01-13 13:46:42

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13541

Re: Upload cache issues ?

Offline

 

#7 2022-01-13 21:35:02

Blomstrand
Member
2020-08-28
6

Re: Upload cache issues ?

plg wrote:

Hi Blomstrand,

Blomstrand wrote:

I'm having some really annoying issues when uploading images.

We're not especially experimenting this problem (on Piwigo.com I mean) so I don't suspect Piwigo 12 to be the problem compared to Piwigo 11.

On your Piwigo, in the gallery menu I see some :

1 Warning: Undefined array key "count_categories" in _data/templates_c/blablabla.file.menubar_related_categories.tpl.php on line 56

This kind of error might have side effects on upload. Please go to page [Administration > Tools > Maintenance] and update photos infos and album infos.

Also had the issues on Piwigo 11.

It usually happens after 3-4 images.. But I've also seen it with single pictures.

Just done the update on photos and albums.

Offline

 

#8 2022-01-18 07:41:07

cryopad
Piwigo Team
Grenoble, France
2015-11-01
165

Re: Upload cache issues ?

@Blomstrand,

Could you please have a look at the CPU load of your server when you upload a series of photos and come back to us? I have observed several times that upload issues were related with an overloaded CPU.


If you enjoy Piwigo for iOS…
➤ We would appreciate an AppStore review.
➤ Comments, suggestions ? Tell us on GitHub…
➤ Not yet available in your language ? Help us translate it…

Offline

 

#9 2022-01-18 21:18:01

Blomstrand
Member
2020-08-28
6

Re: Upload cache issues ?

cryopad wrote:

@Blomstrand,

Could you please have a look at the CPU load of your server when you upload a series of photos and come back to us? I have observed several times that upload issues were related with an overloaded CPU.

Hi

I'm not able to do that, as it is a hostet site.

Offline

 

#10 2022-01-19 04:35:46

xdisciplex
Member
2022-01-01
5

Re: Upload cache issues ?

cryopad wrote:

@Blomstrand,

Could you please have a look at the CPU load of your server when you upload a series of photos and come back to us? I have observed several times that upload issues were related with an overloaded CPU.

I did some uploads in the past 14 hours and checked my cPanel stats, CPU usage didn't go any higher than 25% on my instance within the shared hosting and RAM only gobbled up about 425MB during the uploads.

Offline

 

#11 2022-01-22 08:18:54

xdisciplex
Member
2022-01-01
5

Re: Upload cache issues ?

I'm starting to think this may have more to do with the host provider than the software.  I dumped HostPapa after they complained Piwigo was draining resources.  I'm on Sulana Hosting now and added 59 files in a single transfer with no partial or missing files.  I had to resort to 10 at a time with HostPapa and even then still had issues.

I've just completed an upload of another album (92 pics @ 112MB) using the web form and had no issues.  I also noticed when opening an album, I no longer have to refresh every page to cache the images, it loads all of them the first time and quickly.

Hosting seems to be the culprit in my part.  If this changes I'll come back with more feedback, but for now thanks for the help and raising the bug plg & Blomstrand.

Offline

 

#12 2022-01-28 11:35:49

Blomstrand
Member
2020-08-28
6

Re: Upload cache issues ?

xdisciplex wrote:

I'm starting to think this may have more to do with the host provider than the software.  I dumped HostPapa after they complained Piwigo was draining resources.  I'm on Sulana Hosting now and added 59 files in a single transfer with no partial or missing files.  I had to resort to 10 at a time with HostPapa and even then still had issues.

I've just completed an upload of another album (92 pics @ 112MB) using the web form and had no issues.  I also noticed when opening an album, I no longer have to refresh every page to cache the images, it loads all of them the first time and quickly.

Hosting seems to be the culprit in my part.  If this changes I'll come back with more feedback, but for now thanks for the help and raising the bug plg & Blomstrand.

I wouldn't be surprised if it's a hosting issue. I'm using One.com, and I'm not that impressed with their serverspeed. Even their own controlpanel takes ages to load.
Maybe I should take a more serious look at moving my site.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact