Announcement

#1 2022-03-06 05:33:25

klinsinow
Member
2019-01-20
4

Piwigo PHP 8.0 compatibility?

Recently Bluehost upgraded it's PHP servers and broke some Piwigo functionality. Website works after reverting back to PHP 7.3 on Host. Below were the issues with PHP 8.0.


Piwigo 12.2.0 (was 11.5 when stopped working, I upgraded thinking that would help, which didn't)
Operating system: Linux
PHP: 8.0.16
MySQL: 5.7.23-23
Graphics Library: ImageMagick 6.9.10-68
Cache size 6869.07 Mo

Issues
1. Upload from Lightroom using Piwigo Export Plug-In vs3.1.0 no longer able to login and has error text: Error processing server response. trailing garbage at byte 28 of: {"stat":"ok","result":true}Deprecated: Directive 'allow_url_include' is deprecated in Unknown on line 0.

2. Not able to add images manually through website. Basically the album selection pulldown menus do not work (nothing shown in the list).

3. Keywords on left of main screen all have code instead of just text (i.e. /home1/jeffspho/public_html/_data/templates_c/ljbwkp^bfa63e235ebb16536a9d707f50be0b318694aa3d_0.file.menubar_tags.tpl.php on line 37
" href="index/tags/7-backpacking" title="display photos linked to this keyword">backpacking

4. If I go to PHP 8.1 on host, has (Deprecated: strip_tags(): Passing null to parameter #1 ($string) of type string is deprecated in /home1/jeffspho/public_html/include/functions_html.inc.php on line 534) across top of website about 10 times as well as still issue with keywords listing code instead of just the keyword.

5. Huge list of plugins (actually almost all) were non-functional with PHP 8.0


Are other people having issues with Piwigo and PHP 8.0 or 8.1?

I performed upgrade to Piwigo 12.2.0, however should I instead do a fresh install? If recommended, is there an export and import for the image database that I would use?

Thanks for anyone's insight on the issues!

Again, website working for me now with PHP 7.3, however by reading forums I thought Piwigo would support PHP 8.0. And eventually, bluehost may decide to drop PHP7.3 which would cause website to not function.

Offline

 

#2 2022-03-06 10:31:02

Katryne
Member
2016-12-03
179

Re: Piwigo PHP 8.0 compatibility?

Hello ! I installed a new Piwigo 12.2.0 2 weeks ago. Most plugins did not work, some giving blank pages, when I discovered that Ionos installed php8 by default for new domains/sub-domains. Without any plugin, Piwigo seemed to run correctly with php8. I did not test further and came back to php 7.4 to install my usual plugins. I will wait untill they are mended before testing again php8.
Plugins are the problem with php8, I think and most of them do not depend on the Piwigo  team.


https://photos.revestou.fr/  v.12.2 - https://dardennes.revestou.fr/ v.11.5 - http://photos.katrynou.fr/ v.11.5 https://album.chauvigne.info/ v.12.2
Système d'exploitation: Linux - Hébergeur 1&1-Ionos PHP: 7.4.29 - MySQL: 5.7.38
Bibliothèque graphique: External ImageMagick 6.9.10-23

Offline

 

#3 2022-03-13 11:35:28

matthys
Member
2014-04-02
148

Re: Piwigo PHP 8.0 compatibility?

I just did a test upgrading to PHP: 8.0.8 and I guess there are still some problems :-(

Plugins (I used) causing problem where:
Social Buttons

Warning: Attempt to read property "value" on null in /var/www/localhost/_data/templates_c/110vykv^ccbd11aef2aaecc80e874858eca7b26308c48c7c_0.file.facebook.tpl.php on line 28

After disabling it it was gone .... but still:

I also got these from the menu bar under Tags and Menu:
/var/www/localhost/_data/templates_c/110vykv^8fada83f5f47f8632a8aae9a195a9f9925a84f5e_0.file.menubar_tags.tpl.php on line 37
/var/www/localhost/_data/templates_c/110vykv^182776a969c923e5aa1bcac60e5485111be38b0a_0.file.menubar_menu.tpl.php on line 45


    Piwigo 12.2.0 Check for upgrade
    Operating system: Linux
    PHP: 8.0.8 (Show info) [2022-03-13 11:21:08]
    MySQL: 8.0.28-0ubuntu0.21.10.3 [2022-03-13 11:21:08]
    Graphics Library: External ImageMagick 6.9.11-60
    Cache size N/A   never calculated Refresh

<strike>Gone do a rollback to PHP7.4</strike> = have not done this for the moment

Last edited by matthys (2022-03-14 11:36:24)

Offline

 

#4 2022-03-13 12:15:10

matthys
Member
2014-04-02
148

Re: Piwigo PHP 8.0 compatibility?

These menu errors/warnings are related to BlancMont XL theme, which I guess is also not supported any longer :-(

Thought it also could be related to the Smarty plugin used by Piwigo.

PS ... suppress error and warnings did the trick but doesn't mean it's fixed :-(
Added to Local config:

Code:

$conf['show_php_errors'] = E_ALL & ~E_DEPRECATED & ~E_NOTICE & ~E_WARNING;

Last edited by matthys (2022-03-13 13:05:13)

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact