Announcement

#1 2022-04-05 00:31:45

grantiago
Member
2022-04-04
10

errors with videoJs plugin

Hi Thank you to the entire piwigo team. I appreciate your efforts. I need a little help getting videojs to run.
I followed the instructions here: https://github.com/Piwigo/piwigo-videoj … -2-install

I have root access and and installed all the dependencies with apt install. They all run fine from the command line. VideoJs is creating the thumbs on upload. I can upload by browsing to the video or drag and drop. The videos play.

The errors: I have no exif - meta data for videos. no film effect.

When I try to edit the video after upload I get this error.

Code:

Mediainfo error reading file. Is MediaInfo install? Is MediaInfo in path?
Is the video accessible & readable, Try to run the command manually.
--Full --Output=XML --Language=raw './upload/2022/04/03/20220403082014-ec4e4f03.mp4'
output: sh: 1: --Full: not found

in addition in the videojs plugin synchronize tab the program dependencies all have a green check but show no values in the text area.

I am getting this error:

Code:

You ask me to do nothing, are you sure?

In my apache error log

Code:

sh: 1: /dev/null: Permission denied
sh: 1: /dev/null: Permission denied
sh: 1: /dev/null: Permission denied
sh: 1: /dev/null: Permission denied

my directories and files are all owned by the apache user  www-data. All the directories are 755 (except uploads and it's subdir which are all 777). piwigo set that not me. That is for another question. The files are all 644.

If I add the following to the config.inc file for piwigo the thumb creation on upload fails as well.

Code:

$conf['vjs_mediainfo_dir'] = '/usr/bin/mediainfo';
$conf['vjs_exiftool_dir'] = '/usr/bin/exiftool';
$conf['vjs_ffprobe_dir'] = '/usr/bin/ffprobe';
$conf['ffmpeg_dir'] = '/usr/bin/ffmpeg';

dependency versions from the command line.

Code:

 mediainfo --version
MediaInfo Command line,
MediaInfoLib - v17.12

ffmpeg -version
ffmpeg version 3.4.8-0ubuntu0.2 Copyright (c) 2000-2020 the FFmpeg developers
built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)

 exiftool 20220404154435-c46640f4.jpg
ExifTool Version Number         : 10.80

ffprobe --version
ffprobe version 3.4.8-0ubuntu0.2 Copyright (c) 2007-2020 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.5.0-3ubuntu1~18.04)

my system info:

Code:

Piwigo 12.2.0 Check for upgrade
Operating system: Linux
PHP: 7.4.28 (Show info) [2022-04-04 15:19:06]
MySQL: 5.7.37-0ubuntu0.18.04.1-log [2022-04-04 15:19:06]
Graphics Library: ImageMagick 6.9.7-4
Cache size 1211.7 Mo   calculated 3 days ago Refresh
 Activated plugin list4
Admin Tools
Embedded Videos
LocalFiles Editor
VideoJS

NAME="Ubuntu"
VERSION="18.04.6 LTS (Bionic Beaver)"

Last edited by grantiago (2022-04-05 14:36:05)

Offline

 

#2 2022-04-17 00:22:52

rajdude
Member
2021-05-18
71

Re: errors with videoJs plugin

You may want to check out the HUGE amount of troubleshooting I have done in this thread

https://piwigo.org/forum/viewtopic.php?id=29250

BTW, VideoJS does NOT need mediainfo properly working for making thumbnails and that film effect. It only needs ffmpeg.

So if your thumbs are being generated, all is well.

Now that I re-read your post, maybe the film affect needs something more than ffmpeg. In my installation, film effect is somehow working.

To remove the message...

You ask me to do nothing, are you sure?

...you gotta uncheck that checkbox "only perform a simulation (nothing will be changed in the database)"

Good luck!

Offline

 

#3 2022-04-26 15:11:25

grantiago
Member
2022-04-04
10

Re: errors with videoJs plugin

Thanks for the reply. I'm getting the "you ask me to do nothing message" with the perform simulation box checked or unchecked.

I believe I've narrowed it down to a permissions problem. my apache log shows:
    sh: 1: /dev/null: Permission denied
Every time I submit the synchronize form.
I'm checking this now.
On another note, it would be great if the form retained the values on submit.

Offline

 

#4 2022-04-26 15:54:42

rajdude
Member
2021-05-18
71

Re: errors with videoJs plugin

That sux :-(
Check permissions on the folders of piwigo, maybe the ffmpeg process does not have write permissions on the folders where it is trying to write those jpeg posters to.

And yeah, I am struggling with the same thing.........the form does not retain the values on submit. I have even tried to change this file, as mentioned in the wiki, but nothing happens.


'(piwigo-installation-directory)/plugins/piwigo-videojs/admin/admin_photo.php'



BTW, I just added my knowledge to this plugin's wiki:
https://github.com/Piwigo/piwigo-videoj … ing-system

Hope that helps someone in the future.



grantiago wrote:

Thanks for the reply. I'm getting the "you ask me to do nothing message" with the perform simulation box checked or unchecked.

I believe I've narrowed it down to a permissions problem. my apache log shows:
    sh: 1: /dev/null: Permission denied
Every time I submit the synchronize form.
I'm checking this now.
On another note, it would be great if the form retained the values on submit.

Offline

 

#5 2022-05-07 20:40:16

grantiago
Member
2022-04-04
10

Re: errors with videoJs plugin

Hi.
I created a fresh install on my local server. The plugin is configured according to the wiki.
I am still getting errors from the videoJS plugin. No thumbs are generated. I can manually create the thumbs from the command line with ffmpeg. I haven't confirmed it, but I am beginning to suspect modsecurity may have some role in the errors on my production server.

my config.inc.php file:

Code:

<?php

/* The file does not exist until some information is entered 
below. Once information is entered and saved, the file will be created. */
$conf['vjs_mediainfo_dir'] = '/usr/bin/mediainfo';
$conf['vjs_exiftool_dir'] = '/usr/bin/exiftool';
$conf['vjs_ffprobe_dir'] = '/usr/bin/ffprobe';
$conf['ffmpeg_dir'] = '/usr/bin/ffmpeg';

/* videojs */
$conf['upload_form_all_types'] = true;
$conf['sync_chars_regex'] = '/^[a-zA-Z0-9-_. ]+$/';

$conf['show_exif'] = true;
$conf['show_exif_fields'] = array(
  'Make',
  'Model',
  'ExifVersion',
  'Software',
  'DateTimeOriginal',
  'FNumber',
  'ExposureBiasValue',
  'FILE;FileSize',
  'ExposureTime',
  'Flash',
  'ISOSpeedRatings',
  'FocalLength',
  'FocalLengthIn35mmFilm',
  'WhiteBalance',
  'ExposureMode',
  'MeteringMode',
  'ExposureProgram',
  'LightSource',
  'Contrast',
  'Saturation',
  'Sharpness',
  'bitrate',
  'channel',
  'date_creation',
  'display_aspect_ratio',
  'duration',
  'filesize',
  'format',
  'formatprofile',
  'codecid',
  'frame_rate',
  'latitude',
  'longitude',
  'make',
  'model',
  'playtime_seconds',
  'sampling_rate',
  'type',
  'resolution',
  'rotation',
  );

?>

https://github.com/Piwigo/piwigo-videojs/wiki/Configuration#videojs-plugin

getting the following errors.

Code:

    [Sat May 07 12:17:02.372780 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 52, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.372864 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 52, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.372901 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 52, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.374233 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 77, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.374327 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 84, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.374363 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 112, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.374395 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/include/function_sync2.php on line 202, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.376651 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/admin/admin_sync.php on line 175, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.377997 2022] [php7:notice] [pid 103337] [client 192.168.1.2:52715] PHP Notice:  Trying to access array offset on value of type null in /mnt/tera/www/test/plugins/piwigo-videojs/admin/admin_sync.php on line 190, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync
    [Sat May 07 12:17:02.383034 2022] [php7:warn] [pid 103337] [client 192.168.1.2:52715] PHP Warning:  Cannot modify header information - headers already sent by (output started at /mnt/tera/www/test/plugins/piwigo-videojs/admin/admin_sync.php:190) in /mnt/tera/www/test/include/page_header.php on line 94, referer: http://test.piwi.lan/admin.php?page=plugin&section=piwigo-videojs%2Fadmin%2Fadmin.php&tab=sync

Offline

 

#6 2022-09-18 00:06:11

grantiago
Member
2022-04-04
10

Re: errors with videoJs plugin

Ok. took me a day, but I got this to work.
From this post: [Github] piwigo-videojs issue #162
I made the following the changes to the mysql table in my piwigo db.

Code:

UPDATE myPrefix_config SET value="a:0:{}" WHERE param="vjs_sync"

before making that sql change my apache error log had nothing more than

Code:

permission denied  dev/null

After making the sql update, I had to go to the videojs pluging and on the settings tab  save the settings. Before I was just hitting the sync  tab and nothing was saving. Now saving the settings, go to the sync tab and sync ;-)

all working well for now.

The PHP 7.4 End of Life date is November 28, 2022.
Those of you on a shared hosting service should look into what your host is planning. I couldn't find a single piwigo plugin compatible with piwigo 13 and php 8.x. Including this one. good grief.

Offline

 

#7 2022-09-28 15:18:58

grantiago
Member
2022-04-04
10

Re: errors with videoJs plugin

I forget one step. sorry for the clutter. In addition to the sql update above. (which is overwritten when you save the plugin settings)
I made the changes outlined in the last post in this thread: https://piwigo.org/forum/viewtopic.php?id=31765

gabydinu wrote:

what worked for me: in file include/exiftool.php at line 58 change from:

$exif['duration'] = round($general['Duration']*1000, 0);
to
  $exif['duration'] = round($general['MediaDuration'], 0);

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact