Announcement

#1 2022-04-07 04:14:24

BobDeming
Member
2013-03-08
41

php compatibility

Hi,

My site is showing a great many seemingly unrelated errors in Piwigo 12.2.0.  These errors arose all at one time about the end of March.


i am wondering about the compatibility of php version 8.0.16 used by Piwigo and version ea-php 80 used by my web host.  I have discussed this with representatives of the hosting company, and they say there have no recent changes in their operating environment.

Can anone tell me if the two versions of php , 8.0.16 and ea-php 80, are compatible?

Thank you,

Bob Deming


    Piwigo 12.2.0
    Operating system: Linux
    PHP: 8.0.16 (Show info) [2022-04-06 20:05:38]
    MySQL: 5.7.23-23 [2022-04-06 20:05:38]
    Graphics Library: ImageMagick 6.9.10-68
    Cache size N/A   never calculated

https://filmpac.org/Gallery2/index.php

Offline

 

#2 2022-04-07 11:59:51

erAck
Only trying to help
2015-09-06
1585

Re: php compatibility

ea-php80 is EasyApache PHP 8.0 used in conjunction with cPanel. Like a regular PHP 8 wrapped in some selector package, see https://docs.cpanel.net/ea4/php/easyapa … i-package/ and your hosting provider should know details.

That being said, while Piwigo 12.2 is mostly compatible with PHP 8 it is not completely ready yet, there are still some dirty corners needing cleaning. I'd recommend using PHP 7.4 instead. While it is not actively developed anymore it still gets security support until November 2022 (see https://www.php.net/supported-versions ).


Running Piwigo at https://erack.net/gallery/

Online

 

#3 2022-04-08 22:16:52

BobDeming
Member
2013-03-08
41

Re: php compatibility

Hello erAck,

Thank you very much for your explanation of the relationships between php versions and Piwigo version 12.2.
I have just finished a fairly pointed conversation with my web host (Bluehost) regarding their arbitrary change to php8 without telling anyone about it.

I have put my domain back on php7.3 and all is working well.  Bluehost says they will continue to offer 7.3 and 7.4 until they no longer receive security updates.

Thanks again for your attention to my posts, and for your explanation of the situation.

Bob Deming.

Offline

 

#4 2022-04-09 02:03:42

erAck
Only trying to help
2015-09-06
1585

Re: php compatibility

PHP 7.3 is already EOL though since November now.. PHP 7.4 works fine.


Running Piwigo at https://erack.net/gallery/

Online

 

#5 2022-12-25 10:41:07

piwent
Member
2020-10-24
96

Re: php compatibility

What's the latest word on this? My hosting provider is nagging to upgrade to 8.0. But on this page:

https://piwigo.org/doc/doku.php?id=user … all:before

7.0 or 7.1 is recommended.

I'm currently using 7.4, but that reaches EOL on Jan 1.

I realize that it's probably not a big deal, but wanted to get up to date.

Offline

 

#6 2022-12-25 10:57:42

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13634

Re: php compatibility

Currently, Piwigo 13.x core supports PHP 8.1 BUT some (many) plugins still have syntax errors with PHP 8 :-/ We're (slowly, not as a priority) helping maintainers to make them compatible.

Offline

 

#7 2022-12-26 04:11:40

piwent
Member
2020-10-24
96

Re: php compatibility

Thanks!

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2023 · Contact