Announcement

#1 2024-02-28 14:26:10

sse450
Member
2024-02-28
4

Problem in uploading from Android phone

Hello,

Piwigo app on my phone connects to the server fine. When I select some pictures on the phone and select Upload Photos, it looks like uploading is OK. Progress bars extends to the end of the line. Then, it waits about 1min, then the phone gives me a Warning: "some of your photos could not be uploaded".

However, after some time like 5min, the picture appears on the server in the selected album.

What is wrong with my setup?

By the way, Piwigo is running in a docker image (linuxserver) and using a subdomain reverse proxy to access piwigo.

Thank you.

Environment
    Piwigo 14.2.0 Check for upgrade
    Installed on 18 November 2023, 3 months 1 week 3 days ago
    Operating system: Linux
    PHP: 8.3.3 (Show info) [2024-02-28 16:10:46]
    MySQL: 10.11.5-MariaDB-log [2024-02-28 16:10:46]
    Graphics Library: ImageMagick 7.1.1-26
    Cache size 7.05 Mo   calculated 3 months ago Refresh

Activated plugin list 0
    No plugin activated

Piwigo URL: https://piwigo.onartstructures.com

Offline

 

#2 2024-02-28 18:53:27

erAck
Only trying to help
2015-09-06
2091

Re: Problem in uploading from Android phone


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2024-03-05 12:12:51

sse450
Member
2024-02-28
4

Re: Problem in uploading from Android phone

Thank you. It works.

But do I have to invoke this API call on the server every time I upload picture from my phone?

Offline

 

#4 2024-03-05 13:46:11

erAck
Only trying to help
2015-09-06
2091

Re: Problem in uploading from Android phone

If you don't want to wait for the timeout then yes.


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2024-03-05 14:48:08

sse450
Member
2024-02-28
4

Re: Problem in uploading from Android phone

OK. Thank you.

Is there a way to disable it on the server?

Offline

 

#6 2024-03-05 17:48:54

erAck
Only trying to help
2015-09-06
2091

Re: Problem in uploading from Android phone

If you have a "not so large gallery" (< 100k photos) you could try to set the threshold from which the lounge is used to a lower value, e.g. if you have much less than 50k photos then add this to your local config (using LocalFiles Editor):

Code:

$conf['lounge_activate_threshold'] = 50000;

Running Piwigo at https://erack.net/gallery/

Offline

 

#7 2024-03-07 09:07:50

sse450
Member
2024-02-28
4

Re: Problem in uploading from Android phone

It works.

The only problem is that Android app taints all uploads as error. But, for me it is minor issue as uploads are OK.

Thank you very much.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact