Piwigo.org

You are not logged in. (Register / Login)

Post a reply

Write your message and submit

Click in the dark area of the image to send your post.

Go back

Topic review (newest first)

mistic100
Yesterday 11:00:14

As it uses the webservice, it's HTTP. Or HTTPS if you have a certificate on your website.

gregor3000
Yesterday 08:38:36

Hi,

I hope I am posting in the right place, but I've been googling a bit and google is not as good as it used to be - what transfer protocol is used at PLoader?

I am asking since I would like 2 users (Windows, Kubuntu)  to connect to server form a different apartment and would need to use some secure protocol like sFTP  or similar. I planned to do "automatic" transfer via sFTP and then maybe do a rescan of folders, but looks like pLoader would make it all a bit easier. I am just wondering about the protocol used during transfer.

joeuser
2015-05-06 00:25:41

dutchguru wrote:

Is pLoader only usable for webmanager and administrator, so a simple user cannot send by pLoader and/or some Android client ?

PLoader is usable by any user. The same for the Android app.

joeuser
2015-05-06 00:23:05

Sandor wrote:

Hey there

I've got an problem with ploader, anytime I start it an klick on connect it crashes.
It just shut down and nothing else happen.
I've tried wit download it new and start with admin rights, but every time the same happen.

I hope someone can help me

Greets Sandor


P.S. Sorry for my bad english

See my last post about which folder to delete...

joeuser
2015-05-06 00:21:56

I have taken the Linux source and created a new windows version with a fix for https.

Unzip the file and run the pLoader.bat to launch pLoader.

The .bat file sets some environment variables needed for the newer version of ImageMagick to work.

You can use urls with either "http://" or "https://". If neither is included, it will assume http://

If you have used the previous version, you will probably have to delete the settings (.pLoader) folder because it has saved information in a format not compatible with the newer version of perl/Wx.

on xp: "C:\Documents and Settings\**USERNAME**\Local Settings\Application Data\.pLoader"
on win7: "C:\Users\**USERNAME**\AppData\Local\.pLoader"

If  you have problems, you can run pLoader.debug.console.bat which will print error messages in a window which can be posted here and I can try to help resolve the problem.

If you use a self-signed certificate for your website, replace "web_server.cer" with your certificate file - using the same name. (Or edit the pLoader.bat file to set the correct location/name for your certificate with "HTTPS_CA_FILE=path\????.cer"

I have made a small change from the above posted fix to allow "http://" to be entered also...

I also changed the version to 1.6s

Code:

--- wxApp.pm.orig    2010-05-07 19:46:58.000000000 +0200
+++ wxApp.pm    2015-05-04 16:10:46.962768300 +0200
@@ -67,6 +67,10 @@
 use Wx::Locale qw/:default/;
 use utf8;
 
+use Net::SSL;
+use Crypt::SSLeay;
+
+
 $|=1;
 
 __PACKAGE__->mk_accessors(
@@ -169,7 +173,7 @@
     );
 
     $self->version(
-        '1.6'
+        '1.6s'
     );
    
     # to check if we can use stored cache
@@ -678,7 +682,8 @@
 
     $self->_init_branding;
    
-    if ($self->site_url !~ /^http:/){
+#    if ($self->site_url !~ /^http:/){
+    if ( ($self->site_url !~ /^http:/) && ($self->site_url !~ /^https:/) ){
         $self->site_url(
             sprintf(
                 "http://%s",

Included in the zip is the src folder and the build folder with the settings I used to create it.

Also included is a modules folder which contains libraries for ImageMagick. Probably not all are needed, but they are not so big.

https://mega.co.nz/#!PJ4DzDqK!-2CoxFt_j … d3L6lNErDc

dutchguru
2015-03-22 11:55:01

Is pLoader only usable for webmanager and administrator, so a simple user cannot send by pLoader and/or some Android client ?

Sandor
2014-03-11 15:32:07

Hey there

I've got an problem with ploader, anytime I start it an klick on connect it crashes.
It just shut down and nothing else happen.
I've tried wit download it new and start with admin rights, but every time the same happen.

I hope someone can help me

Greets Sandor


P.S. Sorry for my bad english

Kbroeren
2014-02-21 20:36:26

Same problem here as GG

GG
2014-02-19 13:45:41

Hi,

I like pLoader tool and if I chose Piwigo it is also for this capability to upload a whole directory (and even a tree of directories) easily.

Since this week-end, I try to upload a directory.
- I launched the tool
- I added a new album
- I added some pics to be sent
- Application crashed

Now, if I try to open it again, I can fill the login form but I cannot reach the upload form (the one in which one choose photos to be sent). The login form disappears, as usually, but the main application does not appears... The Windows tasks managers show that there is no pLoader process running.

My brother was able to send pics without troubles.

Does this errors sounds familiar to someone?
Maybe should I clean some working/temp files? Or install it again in another directory?

plg
2014-01-10 20:53:04

I confirm pLoader doesn't work over HTTPS :-/

I have made a tiny change in src/Uploader/GUI/wxApp.pm :

Code:

$ svn diff src/Uploader/GUI/wxApp.pm 
Index: src/Uploader/GUI/wxApp.pm
===================================================================
--- src/Uploader/GUI/wxApp.pm   (revision 12803)
+++ src/Uploader/GUI/wxApp.pm   (working copy)
@@ -678,7 +678,7 @@
 
     $self->_init_branding;
     
-    if ($self->site_url !~ /^http:/){
+    if ($self->site_url !~ /^https?:/){
         $self->site_url(
             sprintf(
                 "http://%s",

(juste added "s?" in the if condition)

and it works fine!

Now the problem is that it's perfect for Linux because you run pLoader from sources but on Windows/Mac you run pLoader from a build. I don't know how to create this build :-/ If you know how to do, let me know and I would be happy to publish a new version of pLoader.

Martian
2014-01-10 19:11:43

Hi,

I have my private Piwigo site with allowed only HTTPS and Basic HTTP authentication enabled. I was expecting that the following URL provided to pLoader 1.6 would manage to connect me to my albums, but I noticed an issue.

URL example: https://Username:Password@example.com/albums/

Unfortunately I got the following error:

Can't connect to https::80 (Bad hostname 'https:')
Connection to http://https://Username:Password@example.com/albums/ failed.

It seems like that pLoader automatically adds http:// in front of what I have written in the "Piwigo url" field.
I tried also following format, but without success:

Username:Password@example.com:443/albums/

Do you know if this kind of access is supported or at least if this can be fixed easily? Should I open BUG for that with some details? Note that I also tried this URL from Shotwell in Linux and it worked, but I need Windows client too. :)


Cheers,
Martin

mistic100
2013-12-29 14:01:31

yes
no limit
that's exactly the purpose of the software... it does nothing else

why don't you give a try ?

haritha
2013-12-29 12:19:15

By using Ploader can we upload any number of files on single click??
Upto how many MB of files can be uploaded at once?
can we direclty upload images from computer to piwigo...??

flop25
2013-11-08 09:47:13

Hi
sry about that, but we advise people to use the Administration page to upload picture, since pLoader is no more in developpment just updated in case of bugs.

Connie McNeill
2013-11-08 00:14:50

Would love to be able to use this, but it does not work for us because our server requires a URL beginning https:// and pLoader will not allow this -- it requires http://.

Board footer

Powered by FluxBB

twitter facebook google+ newsletter Donate Piwigo.org © 2002-2015 · Contact