Announcement

#1 2010-05-25 20:42:26

Liam
Guest

Upload Photos error messages

Hey again everyone,

I'm having an issue with the web upload of photos, I keep getting these errors:

Code:

Warning: getimagesize(././upload/2010/05/25/thumbnail/TN-20100525085625-6293d646.jpg) [function.getimagesize]: failed to open stream: No such file or directory in /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php  on line 266

Warning: filesize() [function.filesize]: stat failed for ././upload/2010/05/25/thumbnail/TN-20100525085625-6293d646.jpg in /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php on line 267

Warning: Cannot modify header information - headers already sent by (output started at /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php:266) in /Users/earlnich/Sites/piwigo/include/page_header.php on line 98

And I'm not sure what it means. The actual images themselves are up (I can open up the link to the real image and it shows it to me), but the thumbnails do not exist (they aren't even in the thumbnail directory).

Thanks for your help!
Liam

 

#2 2010-05-25 20:48:27

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13143

Re: Upload Photos error messages

Hi Liam,

Are the photos resized?
Can you describe the exact content of your "upload" directory?
Are you using MySQL as database? (we've found a bug on SQLite for photo upload yesterday)
Is GD library installed? (on the administration home click on "show info" link and search "GD" on the page)


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#3 2010-05-26 07:51:54

Liam
Guest

Re: Upload Photos error messages

Ah. You're right; seemed to be my GD library. However, now I'm receiving these errors -- any ideas?

Code:

Warning: imagesx(): supplied argument is not a valid Image resource in /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php  on line 213

Warning: imagesy(): supplied argument is not a valid Image resource in /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php on line 214

Warning: Cannot modify header information - headers already sent by (output started at /Users/earlnich/Sites/piwigo/admin/include/functions_upload.inc.php:213) in /Users/earlnich/Sites/piwigo/include/page_header.php on line 98

Thanks!
Liam

 

#4 2010-05-26 16:42:31

Liam
Guest

Re: Upload Photos error messages

It seems that it's only an issue when I try and upload a PNG file; I get perfect, error-free, thumbnail creation when I upload a JPG image.

Is there anyway that I can get this to work with PNG -- I don't want to have to convert all my images!

Thanks!
Liam

 

#5 2010-05-26 16:45:18

Liam
Guest

Re: Upload Photos error messages

Alright, I've found the answer: if I change like 45 in functions_upload.inc.php to '.png' instead of '.jpg', the thumbnail creation of the png images works perfect.

However, I am unable to batch upload png images (the uploader only looks for jpg images)?

Thanks,
Liam

 

#6 2010-05-26 16:47:47

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13143

Re: Upload Photos error messages

Liam wrote:

It seems that it's only an issue when I try and upload a PNG file; I get perfect, error-free, thumbnail creation when I upload a JPG image.

Is there anyway that I can get this to work with PNG -- I don't want to have to convert all my images!

Thanks!
Liam

Hum... this issue has already been reported in the chinese forum (well, Winson the Piwigo chinese forum admin notified me since I don't read chinese ;-).

http://cn.piwigo.org/forum/viewtopic.php?id=15704

I've just created a feature request in the bugtracker: [Bugtracker, ticket 1701, fixed] support PNG files for upload

Thank you for the investigation, stay tuned :-)


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#7 2010-05-26 16:50:24

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13143

Re: Upload Photos error messages

Liam wrote:

Alright, I've found the answer: if I change like 45 in functions_upload.inc.php to '.png' instead of '.jpg', the thumbnail creation of the png images works perfect.

OK, good I know what to change/add now :-)

Liam wrote:

However, I am unable to batch upload png images (the uploader only looks for jpg images)?

Yes. In admin/themes/default/templates/photo_add_direct.tpl, line 110, adapt:

Code:

    'fileExt'        : '*.jpg;*.JPG;*.jpeg;*.JPEG',

Latest blog post (May 3rd 2018) New subscription form

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact