Announcement

#1 2012-07-03 19:03:01

Bob
Guest

Error after upgrading to 2.4 from 2.3.4

This is not a critical error...

The error occurs when performing a History search from the administrator's module where element type is picture.  The search must return results.

At the top of the page the following error is displayed:

Code:

Warning: [mysql error 1054] Unknown column 'high_filesize' in 'field list'

SELECT
    id,
    IF(name IS NULL, file, name) AS label,
    filesize,
    high_filesize,
    file,
    path,
    representative_ext
  FROM piwigo_images
  WHERE id IN (4,16,24,23,19,32,26,22,15,29,27,25,21,11,28,14,13,9,7,12,1856,1855,1854,1853,1852,1851,1850,1849,1848,1847,1846,1845,1844,1843,1842,1841,1840,1839,1838,1837,1836,1835,1834,1833,1832,1831,1830,1829,1828,1827,1826,1825,1824,1823,1822,1821,1820,1819,1818,1957,1956,1955,1954,1953,1952,1950,1951,1948,1949,1817,1958,1989,1990,1991,1992,1993,1994,1995,1996,1997,1998,1786,1785,1784,1783,1782,1781,1780,1779,1778,1777,1776,1775,1774,1773,2064,2063,2062,2061,2060,2059,2058,2057,2056,2055,2053,2054,2052,2051,2050,2049,2048,2047,2046,2045,2044,2042,2043,2041,2040,2039,2038,2037,2036,2035,2034,2033,2032,2031,2030,2029,2028,2027,2026,2025,2024,2023,2022,2021,2020,2019,2018,2017,2016,2015,2014,2013,2012,2011,2010,2009,2008,2007,2006,2005,2004,2003,2002,2001,2000,1999,1924,1923,1922,1921,1920, in /var/www/pics/include/dblayer/functions_mysql.inc.php on line 770
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /var/www/pics/include/dblayer/functions_mysql.inc.php on line 153

Also, the Element results column has values like (#) unknown file name, where # is a number.

I was about to begin debugging, but decided to post here to see if anybody else was having the same problem.

It should be stated that the upgrade script warned me that the community plugin was not compatible with version 2.4.  So before proceeding with the upgrade, I deactivated it and deleted it.  The upgrade was successful.  Also, I do not have any plugins activated.

Thanks for all your help

 

#2 2012-07-03 19:23:57

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Error after upgrading to 2.4 from 2.3.4

Offline

 

#3 2012-07-04 04:02:18

gaptser
Member
Boston
2012-07-03
13

Re: Error after upgrading to 2.4 from 2.3.4

Thanks for everything you guys are doing!!!!!

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact