Announcement

#1 2013-05-24 18:56:40

Gewgaw
Member
2013-05-24
6

Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

This is a strange situation -- two days ago, everything was working perfectly.  Suddenly, yesterday, the thumbnail images in "Admin > Albums > Photos Sort Order" started to appear broken/missing.  (See attached screenshot)

The thumbnail images on the gallery site itself are fine, and I have no problems seeing images in any other part of the Admin pages.  It's only on the Photos Sort Order page where this problem appears!

I did a right-click on the missing images and opened them in a new tab, and it appears that the server is giving a 500 error when trying to load that URL.

Piwigo is fully updated to the latest version.

Please help!  Feel free to message me if you need more information about my install.

Thanks in advance....


Uploaded Images

Last edited by Gewgaw (2013-05-24 19:05:59)

Offline

 

#2 2013-05-24 19:36:59

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

Hello
Really only on that admin page? Even if you do Edit on those thumbnails?
Could you provide a link? it might help Thx


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2013-05-24 19:46:14

Gewgaw
Member
2013-05-24
6

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

Email sent with piwigo Admin site.  All other thumbnails in the Admin site appear properly, including in Batch Manager, Album Edit, etc.

Offline

 

#4 2013-05-27 14:15:07

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

Hi
did yoy generated the thumbnails online normally or on local? Could you check the server log or any errors_log files


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2013-05-27 16:30:25

Gewgaw
Member
2013-05-24
6

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

The thumbnails were generated automatically as part of the image upload process, I thought.  I did not do any locally generated thumbnails.  Before, when I first installed Piwigo, this was working perfectly -- when I uploaded images, the thumbnail for the Photo Sort Order page in Admin would appear just fine.

Offline

 

#6 2013-05-27 16:38:36

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

it would be interesting to access to the server log or to know what changed on the server


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2013-05-27 16:42:28

Gewgaw
Member
2013-05-24
6

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

OK I will try to get it, please stand by.

Offline

 

#8 2013-05-27 17:06:44

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

Hey!
Don't send me all your logs! Just open it and check for 500 errors


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2013-05-27 17:16:22

Gewgaw
Member
2013-05-24
6

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

I see no 500 errors in the access logs from May 19 through May 27.  Some 404 errors, mostly 200 codes.

Offline

 

#10 2013-05-27 17:18:17

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

and in today logs, since I tried to load the thumbnails


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2013-05-29 19:26:51

Gewgaw
Member
2013-05-24
6

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

Here are the errors that were thrown by the Photos Sort Order page.  Anyone have any idea about what is going on???


============

[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] PHP Fatal error:  Uncaught exception 'ImagickException' with message 'The kernel must contain a square number of elements' in /home/iamachinery/public_html/gallery/admin/include/image.class.php:469, referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] Stack trace:, referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #0 /home/iamachinery/public_html/gallery/admin/include/image.class.php(469): Imagick->convolveimage(Array), referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #1 [internal function]: image_imagick->sharpen(1), referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #2 /home/iamachinery/public_html/gallery/admin/include/image.class.php(93): call_user_func_array(Array, Array), referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #3 /home/iamachinery/public_html/gallery/i.php(566): pwg_image->__call('sharpen', Array), referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #4 /home/iamachinery/public_html/gallery/i.php(566): pwg_image->sharpen(1), referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68] #5 {main}, referer: http://www.iamachinery.com/gallery/admi … sort_order
[Mon May 27 05:11:18 2013] [error] [client 130.79.67.68]   thrown in /home/iamachinery/public_html/gallery/admin/include/image.class.php on line 469, referer:
http://www.iamachinery.com/gallery/admi … sort_order

Offline

 

#12 2013-06-05 16:47:38

Daniele G.
Guest

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

The patch is to go to admin panel -> configuration - options - photo sizes , show details (in the upper right corner) and the check all sizes pressing "edit" and disable sharpening (set to 0).

The problem come when you install imagemagick on the server. Piwigo by default check and use it over the "plain" GD library to create thumbnails and reduced web images.
At line 469 of image.class.php is the error:
  function sharpen($amount)
  {
    $m = pwg_image::get_sharpen_matrix($amount);
    return  $this->image->convolveImage($m);
  }
When sharpen is > 0 here it uses a sharpen matrix that is not a power of two, and this is a requirement for a call to image magick convolveImage, see http://doc.gnu-darwin.org/ImageMagick/w … agick.html

-convolve <kernel>

convolve image with the specified convolution kernel

The kernel is specified as a comma-separated list of integers, ordered left-to right, starting with the top row. The order of the kernel is determined by the square root of the number of entries. Presently only square kernels are supported.

 

#13 2013-06-05 17:17:38

flop25
Piwigo Team
2006-07-06
6918

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

I notify rvelices


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#14 2013-06-05 18:36:21

rvelices
Piwigo Team
2005-12-29
1960

Re: Broken/Missing thumbnail images in Admin > Albums > Photos Sort Order

I don't see another solution than the suggested one (sharpen = 0).

It must be the imagick version which is not compatible, because the convolution kernel is a 3x3 matrix which is square and number of elements is power of 2

(In addition I dont have a testing platform)

Last edited by rvelices (2013-06-05 18:36:51)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact