Announcement

#1 2014-05-02 13:09:06

CoolPenguin
Member
2014-05-02
10

Two issues - admin password / images not showing in ie 6 and 7

Greetings,

Hi guys, developed this site http://www.ukapparelwholesale.co.uk/ sometime ago and we have been using it fine. However I have found two issues.

I now cannot log in with either Admin account! I get invalid password for both, even after a password reset.

The second issue, which prompted me to need to log in, is the fact that the system is selectively displaying images to the customer account when viewed through ie 6 and 7 (from XP).

I am worried as I cannot even check the versions as I cannot log in.

Attached is an image of the photos not showing in IE.

Piwigo version: unknown
PHP version: unknown
MySQL version: unknown
Piwigo URL: http://www.ukapparelwholesale.co.uk/


Uploaded Images

Offline

 

#2 2014-05-06 10:30:29

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Two issues - admin password / images not showing in ie 6 and 7

Hi CoolPenguin,

Sorry for this late reply.

When I open your website, I don't see any photo. It means that photos are private and that you had to log in to see the photos. So I suppose the login is working.

As I can't reproduce (no photo to display) it's really hard to investigate. Can you send me a username/password by private message?


Uploaded Images


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#3 2014-05-06 12:56:10

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

I have responded privately, thanks for getting back to me.

I have manged to log in now with an admin account (not sure why it worked today).

Anyway this just leaves the issue with images not displaying in IE6 and 7 on Windows XP as shown in the original attachment.

Offline

 

#4 2014-05-06 13:47:40

flop25
Piwigo Team
2006-07-06
6918

Re: Two issues - admin password / images not showing in ie 6 and 7

CoolPenguin wrote:

Anyway this just leaves the issue with images not displaying in IE6 and 7 on Windows XP as shown in the original attachment.

did you test on other web browser?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#5 2014-05-06 15:33:42

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Two issues - admin password / images not showing in ie 6 and 7

I gave a try with IE11 in Doc Mode 7 and I don't see any problem :-/


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#6 2014-05-06 16:23:54

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

Yes mate, I've tested it on everything, I cannot replicate the error even with the IE browser emulator. But the problem exists and can be seen here if you emulate ie 6 and 7 - http://www.browserstack.com/

It's come about as two users still use xp and and I have seen the issue first hand.

Offline

 

#7 2014-05-06 16:28:01

flop25
Piwigo Team
2006-07-06
6918

Re: Two issues - admin password / images not showing in ie 6 and 7

still use xp and ie6&7... hmm are you managing a gallery for a firm where IT departement is reduced to one intern who tries to fix hundred of computers each day? ^^


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#8 2014-05-06 17:19:32

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13182

Re: Two issues - admin password / images not showing in ie 6 and 7

Said another way (but I perfectly agree with flop25), Windows XP is no longer officially maintained. IE6 and IE7 should be the past, not the present.

The good news is that Mozilla Firefox can be installed on obsolete Windows XP so this is certainly the way the problem should be fixed (as long as we can't reproduce it)


Latest blog post (November 9th 2018) Why Flickr could not remain free for ever

Offline

 

#9 2014-05-06 17:41:13

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

Sorry flop, comments really not helpful mate.

It is only a small firm with three PCs, and two of them run Windows XP.

What is odd is why it displays some images and not others. I just wanted someone to have a look, the issue can be reproduced on browserstack. See link above.

Please can you just view the problem as any suggestions are much appreciated.

Offline

 

#10 2014-05-06 17:43:28

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

PS - the version is 2.5.3

Offline

 

#11 2014-05-06 17:46:55

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

And here is the issue in browser stack -


Uploaded Images

Offline

 

#12 2014-05-06 18:22:14

flop25
Piwigo Team
2006-07-06
6918

Re: Two issues - admin password / images not showing in ie 6 and 7

Short answer: thanks for reporting but this bug won't be investigated


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#13 2014-05-06 19:55:18

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

Thanks Flop I can't imagine there are not other users of XP about? I only wanted someone to take a look, I can't believe this bug has not been noticed anywhere before which lead me to believe it could be our install.

While I understand that reverse engineering may not not be worthwhile, I had hoped someone would take a look.

A bit disappointed really.

Offline

 

#14 2014-05-06 19:56:17

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Two issues - admin password / images not showing in ie 6 and 7

CoolPenguin wrote:

I can't imagine there are not other users of XP about

There are... on IE8, not 7 or 6

anyway now the support of XP has been officially abandoned by Microsoft, it's totally insane to keep using Internet Explorer on this system

Offline

 

#15 2014-05-07 12:26:48

CoolPenguin
Member
2014-05-02
10

Re: Two issues - admin password / images not showing in ie 6 and 7

OK, support issues aside, do other people's galleries work on IE 6/7/8? I really wanted to know if it was us, or it is an issue with Piwigo?

Would updating Piwigo help?

L

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact