Announcement

#1 2014-11-04 08:21:41

marfig
Member
2013-12-12
36

VideoJs metadata testing

Hello,
according to this topic: http://piwigo.org/forum/viewtopic.php?p … 41#p155341
I've applied pwg patch and git version of the plugin and it looks well.

Regarding metadata: it's ok, only I would vote to add there video resolution information.

And last thing, I have some compatibility issue with video effect of previews, please see my attachment. All of them are videos and only few of them have video effect. I'm not fully sure, what is responsible for this. But, would be possible to add possibility to choose from current video effect and watermark with play icon, something like this:
http://www.hadassahinternational.org/fi … mepage.jpg


Thank you
Best Regards
Martin


Uploaded Images

Offline

 

#2 2014-11-04 08:28:13

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

OK, so one update, it was enough to change preview size in the GThumb+ settings. So now I have all videos as videos :) but.. if there is any chance to update previews with play icon, I think it's more common way, how to inform user, that this is video, or?
Thanks
Martin

Offline

 

#3 2014-11-04 11:14:37

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

Hello,
after previous updates, I've added two gpx files to my galleries and I've ran synchronization from piwigo admin starting page and I've got these two warnings:

Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/p/plugins/piwigo-videojs/main.inc.php on line 60
Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/p/plugins/piwigo-videojs/main.inc.php on line 60

Do you have idea what is it about?

Thanks
Martin

Offline

 

#4 2014-11-05 18:29:05

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

Hello,

Thanks for testing and feedback.
Glad it works
I will add the video resolution information.

By default PWG will use the poster to generate thumbnail.
To have the media icon, you need to remove the poster.
There is an option to add a overlay on the poster so you can make a difference between Video and Photo.

For the PHP warning, I will test and checks. I think i did fix that already.
Please make sure you use the latest Git version.

Offline

 

#5 2014-11-06 12:18:46

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

I added the video resolution information in the metadata view.
I added support for WebVTT file (subtitles).

For which content type did you see this error? a video? an image? a GPX track?
I am not able to reproduce the issue.

Last edited by xbgmsharp (2014-11-06 12:42:10)

Offline

 

#6 2014-11-06 12:48:25

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

Hi,
I have git version from 6.11. and after synchronization, which contains 1 new gpx file I see on the top of the admin page:
Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/p/plugins/piwigo-videojs/main.inc.php on line 60

btw resolution feature has been already posted to the git? because I can't see it :)

(is it necessary to remove and install videojs plugin, or should be enough to replace content of plugin folder?)

Thanks
Regards
Martin

Offline

 

#7 2014-11-06 13:04:15

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

The video resolution code is committed. You need to add the new type in the EXIF array in you local config.
I updated the documentation to reflect the change. https://github.com/xbgmsharp/piwigo-vid … add-videos

Sorry but I don't understand how to reproduce the issue.
You add which type of file? Sync from PWG or VideoJS?

It is enough to replace content of plugin folder. No restore is need.

Offline

 

#8 2014-11-06 13:27:50

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

Thanks, video resolution is working fine :)

Regarding warnings:
I copied gpx file into gallery folder, went to Admin page and run synchronization. GPX file was successfully added and warning appeared.

Thanks
Regards
Martin

Offline

 

#9 2014-11-06 13:48:44

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

Thanks I was able to reproduce it.
It is now fixed.

Offline

 

#10 2014-11-07 06:11:50

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

I confirm warning message disappeared.
Thank you
Regards
Martin

Offline

 

#11 2014-11-07 08:25:51

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

Hello,
there is one more thing, common for videoJs and OSM plugin, there are missing some translations to (at least) Czech.
1. I can most probably help with this translation, how to do it?
2. Would be possible, in case, that translation to user language is missing to display original English texts instead of current technical name?

Thanks
Regards
Martin

Offline

 

#12 2014-11-07 13:19:51

marfig
Member
2013-12-12
36

Re: VideoJs metadata testing

thanks to ddtddt, I've added several translations, but unfortunately elements for exif parts aren't part of videojs, where are these texts located?

Also, what are the next steps, how to get newly translated texts to my installation?

Thank you
Best Regards
Martin

Offline

 

#13 2014-11-07 13:27:01

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

I used uppercase word in the code to avoid having to modify the source code for typo.
This way all translations are manage separately.

The piwigo team just integrate their tools with Github.
The translate tool should now push directly to the github repository the updated language.

To install the newly translated texts to your installation, do a 'git pull' or replace the folder with a newer archive.

Offline

 

#14 2015-03-31 20:27:16

jnashpiwigo
Member
2014-10-21
131

Re: VideoJs metadata testing

Couple of problems I have:

I have encoded mp4 files and they play fine.

However, no metadata is displayed.  (first problem)  - am I missing a setting or something?  running 2.7.4

Also, digging in to the source, I see that mediainfo is used to pull GPS coords from the file.

The second problem:  mediainfo isn't picking up the coordinates from the mp4:  (no xyz tag I suppose)
However, exiftool shows the GPS coords...

Code:

XMP Toolkit                     : Image::ExifTool 9.90
GPS Altitude Ref                : Above Sea Level
GPS Latitude                    : 44 deg 54' 36.00" N
GPS Longitude                   : 110 deg 19' 59.88" W
Creation Date                   : 2014:08:06 14:34:42-06:00
Make                            : Apple
Camera Model Name               : iPhone 5s
Software                        : 7.1.2
Audio Sample Rate               : 44100
Video Frame Rate                : 29.982
Avg Bitrate                     : 12.3 Mbps
GPS Altitude                    : 1882 m Above Sea Level
GPS Latitude Ref                : North
GPS Longitude Ref               : West
Image Size                      : 1280x720
Rotation                        : 0
GPS Position                    : 44 deg 54' 36.00" N, 110 deg 19' 59.88" W

The 'xyz' tag is in my original .MOV file from the iphone, but when reencoding to x264 for the web, it won't copy them over...

Last edited by jnashpiwigo (2015-03-31 20:29:34)

Offline

 

#15 2015-03-31 21:19:43

xbgmsharp
Member
1970-01-01
213

Re: VideoJs metadata testing

However, no metadata is displayed.  (first problem)  - am I missing a setting or something?  running 2.7.4

You need:
* PWG >= 2.7.4
* Configure PWG to recognize the metadata, https://github.com/xbgmsharp/piwigo-vid … ta-support
* Piwigo-videojs plugin from GitHub, Version 2.7.a does enable the metadata display as PWG core was not ready for it yet.

The last point is the one you more likely missed.
All will be fine in the next release of PWG 2.8 and the plugin version 2.8.a.

Also, digging in to the source, I see that mediainfo is used to pull GPS coords from the file.

That is correct as specify in the documentation, https://github.com/xbgmsharp/piwigo-videojs/wiki
You can override or manually set the GPS coords using OSM plugin.
The 'xyz' tag is include in video from mobile OS using Android5 and all IOS version.
I did not know exiftool support video. I will look into it. It could be a good alternative as MediaInfo still did not fix an output bug.

Could you please provide the output of mediainfo? If there is an alternative metadata ID, I can add support for it.
Can you provide a sample video? Or provide the command you use to transcode your video from the iPhone MOV.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact