Announcement

#1 2015-03-07 11:51:45

sridharb
Member
2015-03-07
25

Piwigo on Windows - spaces in directories and filenames

Hi,

I am an user of Gallery v2 and am evaluating migrating to piwigo based on greyDragon's recommendations.

What I have been frustrated with is the problems with spaces in directories and the problems that it creates. I have been able to get past the synchronization problem by adding a space to the regex.

When I try to create a thumbnail, I get this:

PHP Fatal error:  Uncaught exception 'ImagickException' with message 'unable to open image `././galleries/vkdas2538/1979/Vidya Appa Office/01068_n_8abqfpspy573.jpg': No such file or directory @ error/blob.c/OpenBlob/2617' in C:\piwigo\admin\include\image.class.php:416

It would seem like it is because of the space in the album name.

It looks like this is a deal breaker because I don't agree with suggestions elsewhere about tools to strip out spaces etc. These days, filenames like these should work.

Is this something that will be looked at in the future or is this a limitation that we will have to live with?

Thanks,
Sridhar
Piwigo version: 2.7.4
PHP version: 5.6.6
MySQL version: 5.6.22
Apache: 2.4.12
Windows 7 x64

Offline

 

#2 2015-03-07 11:57:02

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13283

Re: Piwigo on Windows - spaces in directories and filenames

Hi sridharb,

It should work. I suppose you have modified the $conf['sync_chars_regex'] in your local configuration to accep space char.

When you say "when I try to create a thumbnail", what do you exactly do?

Offline

 

#3 2015-03-07 13:19:49

sridharb
Member
2015-03-07
25

Re: Piwigo on Windows - spaces in directories and filenames

I am following the instructions in the menalto2piwigo plugin.

I copied the albums over to the galleries folder. [I have a lot of photos, but that shouldn't matter. I did hit a exec_time maximum, which I overcame by increasing it because the server is local and administered by me.]

Then, I synchronized - first in simulated mode. This is when I had to add the space in the regex. Then I did for real and it seemed to work fine. It complained about exif and I had to enable php_exif.dll in my php.ini. All ok, but requiring some searching, but still fine.

Now, I anticipate that I am done. But, I see no thumbnails as well as no pictures at all when I go to view them. By no pictures, I mean that I see the metadata about the picture and the album that it is contained in - all seems to have been imported fine, but the picture is not displayed - it is only a blank box with the picture's name on it - almost like it is formatted for a screen reader for the blind.

So, I thought I have to create thumbnails - something that I have to in Gallery2 as well when "bulk importing" pictures like we did now. I went to Batch Manager, selected all the photos and got it started on "Generate Multiple Size Images". This chugged on for a long time - as an aside, it would be good if this process were independent of the browser window as once I mistakenly opened another webpage in this window while this was going on (instead of in a new tab) and I had to restart from scratch. It finished and still there was nothing.

I then selected only one image and made it generate. This gave me the error that I had mentioned in my earlier post. I have come across someone asking to configure imagick "externally". However, I eschewed it to see how the default worked. It seemingly doesn't. Should I try the external configuration? If so, what should I put in the path - I see examples of /usr/bin. My convert is the system path - do I need to do anything specific?

Please let me know if you need additional details.

Thanks,
Sridhar

Offline

 

#4 2015-12-22 05:11:25

sridharb
Member
2015-03-07
25

Re: Piwigo on Windows - spaces in directories and filenames

I am going to try migrating from my G2 to the latest version again.

PLG: any reply to my previous post?

Thanks,
Sridhar

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2020 · Contact