Announcement

  •  » Extensions
  •  » Social Connect - Given URL is not allowed by the Application

#1 2015-03-24 20:22:40

shastss
Member
2015-03-23
4

Social Connect - Given URL is not allowed by the Application

Hello/Hi/Greetings,

I am trying to get the Social Connect plugin to work.

I have gotten my Application/Client ID and Application Secret from Facebook. Put them in the Providers page, saved and attempted a login using my personal credentials.  I called my app in development in facebook mshbm.com, my site url for the gallery is mshbm.com/gallery.  Did I create a mismatch or are there problems with periods in the facebook app in development?

I am getting this error when logging with my fb credentails, same ones i created the app/client id with:

Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.



Piwigo version: 2.7.4
PHP version: 5.4.38 (Show info) [2015-03-24 13:22:22]
MySQL version: 5.5.42-37.1-log [2015-03-24 13:22:22]
Piwigo URL: http://mshbm.com/gallery


Uploaded Images

Last edited by shastss (2015-03-24 20:26:25)

Offline

 

#2 2015-03-26 00:06:25

shastss
Member
2015-03-23
4

Re: Social Connect - Given URL is not allowed by the Application

A Bit surprised no one had the answer.

I found it myself and wanted to leave followup for the next person who has this issue.  In the developer.facebook.com page for my app id, there is a "Add a platform" button, where I selected website and then put in the url to my website gallery.  I think I missed this because of the older youtube video I watched didn't point this out. Actually several older videos do not point this out. First timer here.

It works now.

Good luck to all,

Steve


Uploaded Images

Last edited by shastss (2015-03-26 00:57:57)

Offline

 

#3 2015-03-26 09:24:03

mistic100
Former Piwigo Team
Lyon (FR)
2008-09-27
3271

Re: Social Connect - Given URL is not allowed by the Application

If you used the last version is already indicated in the help

1.    Go to https://developers.facebook.com/apps and create a new application
2.    Fill out any required fields such as the application name and description
3.    Go to Settings -> Advanced and set Valid OAuth redirect URIs to http://galerie.strangeplanet.fr/plugins … e=Facebook
4.    Go to Settings -> Basic and fill the contact email
5.    Click on Add Platform, choose Website and set the Site URL to http://galerie.strangeplanet.fr/
6.    Go to Status & Review and set the app public by clicking the big button on top-right
7.    Once you have registered, copy and past the created application credentials into this setup page

point 5

Offline

 
  •  » Extensions
  •  » Social Connect - Given URL is not allowed by the Application

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact