Announcement

#1 2016-01-05 22:13:33

CT27
Guest

Piwigo Setup on Synology

Hello,

I'm new to Piwigo, ran Galler3 for many years but left it 5 years ago when i go a Synology NAS running PhotoStation.   PhotoStation is effortless and quick but does not provide much beyond the basics and the security structure is not very adaptable. 

I setup Piwigo 2 nights ago and am enjoying it very much.  My ultimate goal is to run Piwigo on the Synology NAS alongside PhotoStation.  I'm 75% of the way there and looking to the community to help me make the final tweaks. I feel this would also be useful for future Synology users.

<<<<<<My problem>>>>> at this point is that my bulk load created albums but no images. In cases where I manually setup an image I get the Original to load but none of the thumbnails appear. Plus the bulk process i used below times out after 120 seconds thus i think prematurely stopping the synchronization.

So far I have done the following:
1.         created a symbolic link in my piwigo directory to my Synology photo directory.  ln -s '/volume1/photo/Family Photos' '/volume1/web/piwigo/galleries2'  (this can also be done using a php program another user posted in the forum)
2.         In the Piwigo admin console I created a new gallery using this new folder ./galleries2/
3.         modified './piwigo/admin/include/functions.php' by adding '@eaDir' to the array found around line 529.  This helped by excluding the '@eaDir' folder Synology creates inside each directory to hold the thumbnail images used by PhotoStation and UPnP.
4.         Ensured all by directories (i want them to be albums) HAVE NO SPACES as directed by the Piwigo admin page.  If spaces are found everything within the folder will become a directory (yes, that means each file name becomes a directory) and it's a disaster.
5.          From the admin console to got Tools >> Site Manager and click Synchronise next to your gallery (galleries2 in my case)
6.           Click the radio next to directories + files; uncheck simulation, click Submit
7.         Wait and most likely you'll get a 120 second timeout (not sure what to do here yet)

Piwigo version: 2.7.4
PHP version: 5.6.13
MySQL version:  5.5.45-MariaDB
Piwigo URL: private

 

#2 2016-01-05 22:42:45

flop25
Piwigo Team
2006-07-06
6900

Re: Piwigo Setup on Synology

hello
try first to sync only folders ; check server logs for any erros
and you still can refresh the page sending previous info


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2016-01-05 23:06:44

CT27
Guest

Re: Piwigo Setup on Synology

Conducted the task as suggested and all the directories are generated correctly. [Wish i could drop and image in here]. 

I checked the database and the piwigo_categories table is populated correctly with the 80+ folders/albums.  I checked the piwigo_images directory and have nothing (other than the two manual ones i did prior). 

It appears the Sync is just not picking up the images.  On average my images are 5MB in size. Resolution is 3648x5472.  Do you think the image resolution is too large?

Sorry to ask but I'm still new to Piwigo.  Where are the system log files for Piwigo?  Once directed I can grep away at the results and find stuff.

Any suggestions on next steps?   FYI.....afer some research it appears my version of Synology does not have Imagemagick but I do have GD.

Thanks in advance.

 

#4 2016-01-05 23:18:51

ct27
Guest

Re: Piwigo Setup on Synology

when trying to sync directories and files:

Fatal error: Maximum execution time of 240 seconds exceeded in /volume1/web/piwigo/admin/site_reader_local.php on line 91

 

#5 2016-01-06 04:55:09

ct27
Member
2016-01-06
6

Re: Piwigo Setup on Synology

ok, getting closer.   
helpful post: http://piwigo.org/doc/doku.php?id=user_ … es_missing

The issue is not related to image size (which is under the 20MB limit) or the image resolution.

I learned that if I don't explicitly select an album in section 'reduce to single existing album' of the synchronize tool the process will not work.  Once I selected a single item (2015-10-04) it runs and updates the database for that single album. 

<<<<Problem>>>>>> is though I have 88 albums in 2015, to do this manually for each one is not possible......I have over 15 years of photos to import.

Is this a problem anyone else has had with the synchronize tool? How do i select multiple or let it run for everything in the list?

---------------------
Also, there were no log files because i needed to turn on debug mode. To do this:
1. read this article http://piwigo.org/doc/doku.php?id=user_ … onf_locale (it updates ./local/config/config.inc.php)
2. add this line to the file $conf['enable_i_log'] = true;
3. save and close
4. kick-off a process that will now generate log data

The log file is located at   ./_data/tmp/i.log

Last edited by ct27 (2016-01-06 17:46:59)

Offline

 

#6 2016-01-06 05:08:15

ct27
Member
2016-01-06
6

Re: Piwigo Setup on Synology

community...I'm making progress and posting in hopes this helps someone else.  Still looking for guidance from the community as i progress.

So, at this point i linked an existing folder full of images and have been able to successfully update the database with albums and images.  From the website all the boxes (without images) are falling into place and if i choose to view the original image it displays.

My issue now has to do with technical problems while generating the thumbnails.  My synology model does not have Imagemagick for php.  When i try to execute: https://mycloud/piwigo/i.php?/galleries3/2015/2015-02-15/DSC06865-th.JPG I get an error [External ImageMagick] Corrupt image array ( ). Any thoughts?

Also, i I try to use the batch manager to generate the images it just sits but doesn't do anything.

Offline

 

#7 2016-01-06 07:09:02

ct27
Member
2016-01-06
6

Re: Piwigo Setup on Synology

****Update to post based on Flop25 comments about not updating ./include either

Got it working...needs more tweaking but it's working....

So, i stepped through the i.php process line by line adding debug statements and managed to walk a file through until i again reached the error '[External ImageMagick] Corrupt image array ( ).'. This time i knew i had eliminated everything and fully unmasked the root cause.  Did some research and discovered how to tell piwigo to NOT use imagemagick and instead use GD.

to do this:
1. read this article http://piwigo.org/doc/doku.php?id=user_ … onf_locale (it updates ./local/config/config.inc.php)
2. Use the suggested plugin to set $conf['graphics_library'] = 'gd';
3. save and close

I only suggest making this change if your server does not support ImageMagick. My Synology DS213j does not so I have no choice.

At this point i just let the system begin to generate images for whatever i could get into the Database.

//*******************************************//
//
//   SHOUT OUT------Flop25, thank you for all your help.  I was
//    able to resolve my problem by reading all
//   your old posts from helping many other people over
//   multiple years.  Thank you!!!
//
//*******************************************//

Last edited by ct27 (2016-01-06 17:37:32)

Offline

 

#8 2016-01-06 07:15:09

flop25
Piwigo Team
2006-07-06
6900

Re: Piwigo Setup on Synology

wow I'm waking up ; my day starts well ^^
thank you very much and just a last suggestion: better use the Local Config as described in http://piwigo.org/doc/doku.php?id=user_ … onf_locale


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#9 2016-01-06 17:34:58

ct27
Member
2016-01-06
6

Re: Piwigo Setup on Synology

thanks, updated post to reflect suggestion.

I have 2 minor issues remaining.

1. How do I get the synchronizer to sync an entire album.  For example I have 88 sub-albums under an album named '2015'.  How do I get the tool to sync everything without timing-out/crashing. Right now I'm forced to do one at a time.
   
2. After resolving Issue #1 above I'll have all the necessary database entries to begin generating SM, Medium, LG, Square, etc. images.  Again how do I get the tool to just process everything without having to go album by album.


I have performance issues but I'll blame that right now on my ARM v7 processor and inability to run ImageMagick.  I'll get back to this after purchasing a quad-core Synology.

Offline

 

#10 2016-01-06 19:33:38

flop25
Piwigo Team
2006-07-06
6900

Re: Piwigo Setup on Synology

1) boost a little bit the cpu Mine is just an Atom™ D425 it handles Piwigo whereas I have 2 gallery and my public one is quite big
2) go to the Batch manager


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#11 2016-03-21 18:14:28

nicod
Guest

Re: Piwigo Setup on Synology

For information, instead of switching to gd, I have it working on synology using image magick with this in local/config/config.inc.php :

<?php
$conf['graphics_library'] = 'ext_imagick';
$conf['ext_imagick_dir'] = '/usr/syno/bin/convert';
?>

 

#12 2016-03-24 16:44:07

ct27
Member
2016-01-06
6

Re: Piwigo Setup on Synology

I  just updated to Synology 6.0 (was running beta 2 last time i posted) and am trying to install Piwigo again.

My instructions above helped me get to where I needed to be quickly but I'm now receiving the below error.  I have seen other forums about this errror but nothing that helped me resolve.

Warning: is_dir(): open_basedir restriction in effect. File(./galleries2/) is not within the allowed path(s): (/etc.defaults:/etc:/usr/syno/synoman:/tmp:/var/services/tmp:/var/services/web:/var/services/homes) in /volume1/web/piwigo/admin/site_reader_local.php on line 53

Has anyone else run into this issue and know how to resolve?

Offline

 

#13 2016-03-24 17:06:34

flop25
Piwigo Team
2006-07-06
6900

Re: Piwigo Setup on Synology

ct27 wrote:

I  just updated to Synology 6.0 (was running beta 2 last time i posted) and am trying to install Piwigo again.

My instructions above helped me get to where I needed to be quickly but I'm now receiving the below error.  I have seen other forums about this errror but nothing that helped me resolve.

Warning: is_dir(): open_basedir restriction in effect. File(./galleries2/) is not within the allowed path(s): (/etc.defaults:/etc:/usr/syno/synoman:/tmp:/var/services/tmp:/var/services/web:/var/services/homes) in /volume1/web/piwigo/admin/site_reader_local.php on line 53

Has anyone else run into this issue and know how to resolve?

Hello
Nothing related to Piwigo.

Check for sever config


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact