Announcement

#1 2018-10-13 22:22:03

Swirti
Member
2018-10-13
2

Identification problem

Hello,

After the update to version 2.9.1, I can't connect, the following message appears on a blank page:
Piwigo encountered an unrecoverable error
[Hacking attempt] the input parameter "redirect_decoded" is not valid
#1    check_input_parameter /home/swirti44/public_html/photos/identification.php(50)


The identification.php file is fine:
{
  $_POST['redirect_decoded'] = urldecode($_POST['redirect']);
}
check_input_parameter('redirect_decoded', $_POST, false, '{^'.preg_quote(cookie_path()).'}');
$redirect_to = '';
if ( !empty($_GET['redirect']) )


In config_default.inc.php, I have the parameter $conf['gallery_url'] = null;


If I want to login via this URL, I have the error whereas before 2.9.1, it worked.
   http://photos.swirti.com/identification … categories


If I login via this URL, i.e. without the redirection, it's okay
   http://photos.swirti.com/identification.php
   


What should I do to fix this problem?

Thank you for your help

Piwigo version: 2.9.4
PHP version: 5.6.35
MySQL version: 5.6.41-84.1
Piwigo URL: http://photos.swirti.com

Offline

 

#2 2018-10-15 20:52:07

rfreitaz
Member
2013-07-15
11

Re: Identification problem

Me too

Swirti wrote:

Hello,

After the update to version 2.9.1, I can't connect, the following message appears on a blank page:
Piwigo encountered an unrecoverable error
[Hacking attempt] the input parameter "redirect_decoded" is not valid
#1    check_input_parameter /home/swirti44/public_html/photos/identification.php(50)


The identification.php file is fine:
{
  $_POST['redirect_decoded'] = urldecode($_POST['redirect']);
}
check_input_parameter('redirect_decoded', $_POST, false, '{^'.preg_quote(cookie_path()).'}');
$redirect_to = '';
if ( !empty($_GET['redirect']) )


In config_default.inc.php, I have the parameter $conf['gallery_url'] = null;


If I want to login via this URL, I have the error whereas before 2.9.1, it worked.
   http://photos.swirti.com/identification … categories


If I login via this URL, i.e. without the redirection, it's okay
   http://photos.swirti.com/identification.php
   


What should I do to fix this problem?

Thank you for your help

Piwigo version: 2.9.4
PHP version: 5.6.35
MySQL version: 5.6.41-84.1
Piwigo URL: http://photos.swirti.com

Offline

 

#3 2018-10-15 21:18:50

Swirti
Member
2018-10-13
2

Re: Identification problem

Hello,

Finally, I think I've solved the problem.

In my home page, in the line below, it seems that a slash is missing before index.php
<a href="identification.php?redirect=index.php?/categories">

With the slash as below, it works
<a href="identification.php?redirect=/index.php?/categories">

Offline

 

#4 2018-10-15 22:27:58

rfreitaz
Member
2013-07-15
11

Re: Identification problem

It did not work here, even adding the slash. I will try to disable the plugins.

Offline

 

#5 2018-10-15 22:52:20

rfreitaz
Member
2013-07-15
11

Re: Identification problem

[SOLVED]
Some plugin was blocking the page. So, rename the plugin folder and works. Now i'll see what plugin caused the problem.
Thank you Swirti for the answer.

Last edited by rfreitaz (2018-10-15 22:55:55)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact