Announcement

#16 2021-11-23 10:34:31

erAck
Only trying to help
2015-09-06
1494

Re: Admin Interface Broken After Upgrade to 12.1.0

Try what I wrote 5 messages earlier?


Running Piwigo at https://erack.net/gallery/

Offline

 

#17 2021-11-23 19:04:54

paulleslie
Member
2015-03-09
9

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi,

I just followed this post from eRack:

[Forum, post 182050 by erAck in topic 31634] Admin-interface doesnt work after upgrade to 12.1.

The directions are very simple. You can access the local/config/config.inc.php though your file manager. Add the line that is provided in the other post and then just open this file in your browser: upgrade_feed.php ( put the full http address for the file) and hit enter.

Thats it!

Offline

 

#18 2021-11-23 20:31:52

LouiseC
Member
2021-11-23
5

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi erAck and paulleslie, thanks for getting back to me. The directions are simple, if I can figure out where the local/config/config.inc.php is located. I assume it is on host provider, so I went in and logged onto my CPanel and went to the file manager. Searched and could not find a file by that name. I looked in the files that I have on my system and did not find the file. Please tell me more of where I may find the file. Thanks...LouiseC

Offline

 

#19 2021-11-24 01:34:00

erAck
Only trying to help
2015-09-06
1494

Re: Admin Interface Broken After Upgrade to 12.1.0


Running Piwigo at https://erack.net/gallery/

Offline

 

#20 2021-11-24 04:06:50

LouiseC
Member
2021-11-23
5

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi erAck, In my home directory I did not have a Local folder so, I created the local folder, the I create the config folder in the local folder and then the file config.inc.php with the 3 lines in the config folder.

<?php
$conf['check_upgrade_feed']  =  true;
?>

It didn't work, I still got the same error message. Question, should there be a space in front and after of the equal sign?.....LouiseC

Offline

 

#21 2021-11-24 09:37:39

LouiseC
Member
2021-11-23
5

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi erAck, just dawn on me that I need to look for the link to piwigo folder. I was able to locate the local/config/config.inc.php file and inserted the one line. Unfortunate that did not fix the problem.
Anything else I can try?..LouiseC

Offline

 

#22 2021-11-24 13:53:55

erAck
Only trying to help
2015-09-06
1494

Re: Admin Interface Broken After Upgrade to 12.1.0

Does the file have the <?php tag on the first line and ?> on the last line?
Did you invoke http://YourPiwigoSite/upgrade_feed.php in your browser?

If yes to both then I don't know.


Running Piwigo at https://erack.net/gallery/

Offline

 

#23 2021-11-24 16:09:26

LouiseC
Member
2021-11-23
5

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi erAck, thanks for taking me step by step thru the process of fixing the problem. It's working!

Offline

 

#24 2021-11-24 19:07:49

erAck
Only trying to help
2015-09-06
1494

Re: Admin Interface Broken After Upgrade to 12.1.0

Yay \o/


Running Piwigo at https://erack.net/gallery/

Offline

 

#25 2021-11-27 18:08:01

TimDaly
Member
2021-03-07
5

Re: Admin Interface Broken After Upgrade to 12.1.0

Hello ErAck

I've just tried your fix and it worked a treat. Many thanks and also for pointing me in the right direction

Best wishes - Tim

Offline

 

#26 2021-11-29 10:24:34

russmcclay
Member
2017-08-24
28

Re: Admin Interface Broken After Upgrade to 12.1.0

Hi Brian --

If you ever find a solution, please post here and I'll do the same.  I really regret upgrading to 12.1.0.  I've been using Piwigo for years and if I ever get it working again I will be very very reluctant to ever upgrade again.  This is really unfortunate.

Cheers,
Russ

BrianO10 wrote:

Hi Folks,
I just upgraded to 12.1.0 from 11.5 (I believe) and the Admin interface (all parts of it) results in the error shown below.  My website was working well before the upgrade.  The normal user interface (seeing the albums and photos) still works, but always throws this error when I try to access the Admin functions.  Any suggestions on how to recover?  I have a backup but would like to understand/fix this.
Thanks for any help you can provide,
Brian


Warning: Use of undefined constant LOUNGE_TABLE - assumed 'LOUNGE_TABLE' (this will throw an Error in a future version of PHP) in *****.com/Piwigo/admin/include/functions.php on line 3271



Warning:  [mysql error 1146] Table '******_db.LOUNGE_TABLE' doesn't exist

SELECT
    image_id
  FROM LOUNGE_TABLE
; in *******.com/Piwigo/include/dblayer/functions_mysqli.inc.php on line 864


Fatal error: Uncaught Error: Call to a member function fetch_assoc() on bool in *****.com/Piwigo/include/dblayer/functions_mysqli.inc.php:925 Stack trace: #0 *******.com/Piwigo/admin/include/functions.php(3273): query2array('\nSELECT\n ima...', NULL, 'image_id') #1 *****.com/Piwigo/admin.php(254): get_orphans() #2 {main} thrown in *****.com/Piwigo/include/dblayer/functions_mysqli.inc.php on line 925

Offline

 

#27 2021-11-29 13:57:28

k5
Member
2017-11-05
25

Re: Admin Interface Broken After Upgrade to 12.1.0

hello

russmcclay wrote:

Hi Brian --

If you ever find a solution, please post here and I'll do the same.  I really regret upgrading to 12.1.0.  I've been using Piwigo for years and if I ever get it working again I will be very very reluctant to ever upgrade again.  This is really unfortunate.

Cheers,
Russ

BrianO10 wrote:

Hi Folks,
I just upgraded to 12.1.0 from 11.5 (I believe) and the Admin interface (all parts of it) results in the error shown below.  My website was working well before the upgrade.  The normal user interface (seeing the albums and photos) still works, but always throws this error when I try to access the Admin functions.  Any suggestions on how to recover?  I have a backup but would like to understand/fix this.
Thanks for any help you can provide,
Brian


Warning: Use of undefined constant LOUNGE_TABLE - assumed 'LOUNGE_TABLE' (this will throw an Error in a future version of PHP) in *****.com/Piwigo/admin/include/functions.php on line 3271



Warning:  [mysql error 1146] Table '******_db.LOUNGE_TABLE' doesn't exist

SELECT
    image_id
  FROM LOUNGE_TABLE
; in *******.com/Piwigo/include/dblayer/functions_mysqli.inc.php on line 864


Fatal error: Uncaught Error: Call to a member function fetch_assoc() on bool in *****.com/Piwigo/include/dblayer/functions_mysqli.inc.php:925 Stack trace: #0 *******.com/Piwigo/admin/include/functions.php(3273): query2array('\nSELECT\n ima...', NULL, 'image_id') #1 *****.com/Piwigo/admin.php(254): get_orphans() #2 {main} thrown in *****.com/Piwigo/include/dblayer/functions_mysqli.inc.php on line 925

Something is missing from the MySQL database.
The lounge table.
Just add it.

Offline

 

#28 2021-11-29 14:38:17

erAck
Only trying to help
2015-09-06
1494

Re: Admin Interface Broken After Upgrade to 12.1.0

k5 wrote:

Something is missing from the MySQL database.
The lounge table.
Just add it.

That is not the actual cause and not a real solution (though it may silence this very error but not work otherwise). Note it is LOUNGE_TABLE not piwigo_lounge, where LOUNGE_TABLE is a constant that should be defined to $prefixeTable.'lounge' but apparently is not. See also include/constants.php


Running Piwigo at https://erack.net/gallery/

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2022 · Contact