Announcement

  •  » Engine
  •  » Piwigo 13.4.0- PHP-Version ?

#1 2023-01-16 17:45:49

John.B
Member
2016-03-27
46

Piwigo 13.4.0- PHP-Version ?

Hello/Hi/Greetings,

which PHP version (8.0 or 8.1) is preferable for the current Piwigo version 13.4.0 ?

Best regards
John

Offline

 

#2 2023-01-16 19:07:58

erAck
Only trying to help
2015-09-06
2075

Re: Piwigo 13.4.0- PHP-Version ?

8.0, but even then not all quirks specifically with plugins are ironed out, you'll have to try.


Running Piwigo at https://erack.net/gallery/

Offline

 

#3 2023-01-16 21:47:41

k5
Member
2017-11-05
68

Re: Piwigo 13.4.0- PHP-Version ?

Hello/Hi/Greetings,

I would say 8.0 or 8.1
i prefer 8.1 for me

there is no big difference

Best regards

Offline

 

#4 2023-01-17 09:45:44

John.B
Member
2016-03-27
46

Re: Piwigo 13.4.0- PHP-Version ?

Thanks for the information. I tried PHP version 8.0 and 8.1.

I couldn't find any bugs by using version 8.0.

But my provider supports PHP version 8.0 only until December 2023.

For version 8.1  I had some problems with the plugins "Extended Description" and "Thumbnail Tooltip" :


Deprecated: substr_count(): Passing null to parameter #1 ($haystack) of type string is deprecated in /mypages/xyz/plugins/ExtendedDescription/include/events.inc.php on line 331

Deprecated: strip_tags(): Passing null to parameter #1 ($string) of type string is deprecated in /mypages/xyz/plugins/ThumbnailTooltip/include/class.inc.php on line 48

Warning: Cannot modify header information - headers already sent by (output started at /mypages/xyz/plugins/ExtendedDescription/include/events.inc.php:331) in /mypages/xyz/include/page_header.php on line 99


Is it possible to report these bugs somewhere?

Last edited by John.B (2023-01-17 09:49:00)

Offline

 

#5 2023-01-17 17:34:57

erAck
Only trying to help
2015-09-06
2075

Re: Piwigo 13.4.0- PHP-Version ?

Those are only Deprecated messages telling that some PHP feature will cease to work in a later PHP version. The Warning then is a result of displaying the messages. Exclude them from being displayed, or better, log to file instead.
See [Forum, post 183126 by erAck in topic 31852] Menubar tags issue after 12.2.0 upgrade.

To report them you could submit an issue with the individual plugin, i.e.
https://github.com/Piwigo/ExtendedDescription/issues
https://github.com/Piwigo/Piwigo-Thumbn … tip/issues
if they aren't already.


Running Piwigo at https://erack.net/gallery/

Offline

 

#6 2023-01-18 12:53:25

John.B
Member
2016-03-27
46

Re: Piwigo 13.4.0- PHP-Version ?

Hello "erAck",

thanks a lot for the info. I decided to use your old hint:
 

Code:

$conf['show_php_errors'] = E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_WARNING;

A few years ago I had a similar statement in my "local/config/config.inc.php" for "Thumbnail Tooltip"- but I removed it with a newer version.

I will have a look at github.com, maybe there are solutions for the individual plugins.

Offline

 
  •  » Engine
  •  » Piwigo 13.4.0- PHP-Version ?

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact