Announcement

#1 2024-05-25 21:01:37

GaryK4
Member
2018-03-29
9

Trouble migrating to a new server

Currently, I self host on a Raspberry Pi. Previously, I moved to a Proxmox VM running Debian. That server died.
I server running the same Proxmox, Debian.
I copied the files and the database from the Raspberry Pi to the Debian. When I run it I get errors.
_______________________
Warning: Attempt to read property "errno" on null in /var/www/html/photo/include/dblayer/functions_mysqli.inc.php on line 839

Warning: Attempt to read property "error" on null in /var/www/html/photo/include/dblayer/functions_mysqli.inc.php on line 839
Piwigo encountered a non recoverable error
[mysql error ]
Access denied for user 'tng'@'localhost' (using password: YES)

#1    my_error /var/www/html/photo/include/common.inc.php(122)
#2    include_once /var/www/html/photo/index.php(11)
_______________________

The user 'tng'@'localhost' in Mariadb has full access.

Are there any config files that needs to be exited?
Anny suggestions?

Offline

 

#2 2024-05-26 07:10:21

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
7215

Re: Trouble migrating to a new server

Hi :-)

php release ?

piwigo release ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#3 2024-05-26 13:03:43

GaryK4
Member
2018-03-29
9

Re: Trouble migrating to a new server

php: 8.2.18

Piwigo: 13.8.0

mysql  Ver 15.1 Distrib 10.11.6-MariaDB, for debian-linux-gnu (x86_64)

----------- From server Raspberry pi -------
php: 8.0.5
Piwigo: 13.8.0

mysql  Ver 15.1 Distrib 10.3.27-MariaDB, for debian-linux-gnueabihf (armv8l)

Offline

 

#4 2024-05-26 21:08:33

erAck
Only trying to help
2015-09-06
2075

Re: Trouble migrating to a new server

Piwigo 13 isn't ready for PHP 8.2, you need Piwigo 14.4.0, and anyway a safer bet is PHP 8.1 as extension plugins don't get ready for newer PHP versions.


Running Piwigo at https://erack.net/gallery/

Offline

 

#5 2024-05-28 23:32:07

GaryK4
Member
2018-03-29
9

Re: Trouble migrating to a new server

I went the hard way. Installed the latest version and moved all the images manually to the new version.
Then I made a program to update piwigo_images table name and comment field.
Everything seems to be working now.

Offline

 

Board footer

Powered by FluxBB

github twitter newsletter Donate Piwigo.org © 2002-2024 · Contact