Announcement

#1 2012-07-01 12:28:19

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

[resolved] Forbidden Error When Up Arrow Clicked

I am testing 2.4 and am using the Elegant theme.  When I click the up arrow or at the top of the image, I get linked to http://www.geoffschultz.org/photos/inde … 3/start-15 which generates the following:

Forbidden

You don't have permission to access /photos/index.php on this server.

If I delete the "/start-15" from the URL, there's no problem.

-- Geoff

Last edited by geoffschultz (2012-07-03 15:06:09)

Offline

 

#2 2012-07-01 12:50:17

pewe
Member
2012-03-16
439

Re: [resolved] Forbidden Error When Up Arrow Clicked

Out of interest (I'm not a developer) I tried your link and had the error, so I went into your gallery and found a problem here
http://www.geoffschultz.org/piwigo/pict … category/3

If you look on this page, there is no thumbnail for the next image, and if you go to that image it is that page where your problem link is found.

Every other page is OK, so I suspect it may be a problem with that missing thumbnail.

To regenerate the thumbnail (if your not sure how - if you are ignore this)

Go into the 'admin/photos/batch manager', select album in 'add filter', select that album then tick the box on the culprit image.
Now in the 'choose an action' drop down box below select 'generate multiple size images' and tick the box for thumbnail.

See if that solves the problem.

Offline

 

#3 2012-07-01 13:16:25

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

Re: [resolved] Forbidden Error When Up Arrow Clicked

Pewe,

Thanks, but that isn't the issue.  I think that you just happened to look at the gallery when I was deleting an image and replacing it with a new version & I hadn't generated the thumbnail yet.  I also noted that I have the same issue with other themes when they specify a value for the /start parameter.

-- Geoff

Last edited by geoffschultz (2012-07-01 17:51:54)

Offline

 

#4 2012-07-01 13:57:38

pewe
Member
2012-03-16
439

Re: [resolved] Forbidden Error When Up Arrow Clicked

The error also appears when you have more than one page of thumbnails and try to change the page - I assume it is using the same code for the link.

I have just been experimenting with Piwigo so have not uploaded a large number of photos so only have one page - I'll try and find the time to upload more and see what happens.

I wonder if others are experiencing the same issue - would be nice if they dropped by to confirm one way or the other.

Offline

 

#5 2012-07-01 14:04:45

flop25
Piwigo Team
2006-07-06
6975

Re: [resolved] Forbidden Error When Up Arrow Clicked

Don't know if it contains further info, but you might check the server log
Do you have a security mod enabled in apache ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#6 2012-07-01 14:25:19

pewe
Member
2012-03-16
439

Re: [resolved] Forbidden Error When Up Arrow Clicked

I wasn't sure what the links meant so I delved further and this is what I found - not sure if it'll help.

The end of the link is pointing at the image number to start the display of thumbnails on a page.

The -15 in yours is the default image number for the start of the second page of thumbnails - because the default number of thumbnails per page is set at 15 (at least for the elegant theme - others may be different.)

I set my number of thumbnails to 3 for guests, then tried the links (page number and the up arrow) and it works perfectly using -3 - so I assume it would for the default of 15 if I had more images.

As a suggestion, try setting the number of thumbnails to a different value (it is set at the bottom of the Users/Manage page) and see if that makes any difference.

If not, then as 'flop' suggests, maybe it is a server setting somewhere - but I wouldn't have a clue as to what it might be - although if it is a server setting problem I'm sure others would have reported it in the past as setting the number of thumbnails and the link formatting has been around for some time in previous versions - unless of course there has been a significant change to the coding for this in v2.4.

Offline

 

#7 2012-07-01 14:29:12

flop25
Piwigo Team
2006-07-06
6975

Re: [resolved] Forbidden Error When Up Arrow Clicked

It has been not changed for a long time , and you're the first reporting that, so that's why i' m thinking of a server particularity


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#8 2012-07-01 17:48:43

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

Re: [resolved] Forbidden Error When Up Arrow Clicked

What I don't understand is that I can access

http://www.geoffschultz.org/photos/inde … ry/3/start

but if you specify a value (i.e. "-15"), I get the 403 error.

What's also strange is that I can't find any errors in the server log.

-- Geoff

Last edited by geoffschultz (2012-07-03 11:16:31)

Offline

 

#9 2012-07-03 15:05:43

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

Re: [resolved] Forbidden Error When Up Arrow Clicked

This was resolved on my end.  It ended up being an error in the rewrite rules within my .htaccess.  There was a problem handling "-" symbols in parameters.

-- Geoff

Last edited by geoffschultz (2012-07-03 15:43:57)

Offline

 

#10 2012-07-03 15:12:45

pewe
Member
2012-03-16
439

Re: [resolved] Forbidden Error When Up Arrow Clicked

Nice that you got it sorted.

Will make a mental note of your resolution ;-)

Offline

 

#11 2012-07-03 15:13:43

flop25
Piwigo Team
2006-07-06
6975

Re: [resolved] Forbidden Error When Up Arrow Clicked

geoffschultz wrote:

This was resolved on my end.  It ended up being an error in the rewrite rules within my .htaccess.  There was a problem handling "-" signs in parameters.

-- Geoff

great news ! the code was from Piwigo 2.4 or ... ?


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#12 2012-07-03 15:43:17

geoffschultz
Member
Marlborough, MA, USA
2012-07-01
148

Re: [resolved] Forbidden Error When Up Arrow Clicked

flop25 wrote:

great news ! the code was from Piwigo 2.4 or ... ?

I am running 2.4

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact