Announcement

#1 2013-04-26 10:47:44

MasinAD
Member
2012-09-09
13

[resolved] Manual restore of Piwigo backup

Hi,

in early March, I prepared my server for an upgrade, and the backups seem to have failed. I only have an incomplete backup of my Piwigo gallery. That's no big deal, as I have almost all photos on my local hard disk. And I have the MySQL dump of the Piwigo database.

My problem now is how can I rename all the original image files accordingly that they match Piwigos naming scheme in the database. And where do I put them afterwards? Where does Piwigo store the uploaded image files?

I don't want to just re-install and re-import all the images because there are weeks worth of work done tagging all the images – we are talking about 6000+ files.

I'd be glad for any help, you can give me.

Sincerely,
MasinAD

Piwigo 2.4.x

Offline

 

#2 2013-04-26 12:00:16

MasinAD
Member
2012-09-09
13

Re: [resolved] Manual restore of Piwigo backup

More information and another path to solution:

The backup was corrupted, but I was able to extract all files as it seems – at least I don't notice any file missing. But when accessing the gallery after uploading all files, Piwigo says there was 6073 images but all thumbnails are just warning triangles. When displaying a single image, sometimes the image is shown but most the time it isn't. This is reproducable in such way, if the image is shown, it's always shown; if it isn't, it won't get shown on successive attempt.

This might be because of wrong directory and file permissions. But what might be right? Currently all files and directories have 770, the owner is larp-bb:larp-bb, the user owning the site. Apache runs as www-data, and www-data is member of group larp-bb.

Offline

 

#3 2013-04-26 12:22:58

MasinAD
Member
2012-09-09
13

Re: [resolved] Manual restore of Piwigo backup

And even more information:

When viewing images in original size they are displayed. There seems to be a problem with the scaled images.

Offline

 

#4 2013-04-26 12:38:05

MasinAD
Member
2012-09-09
13

Re: [resolved] Manual restore of Piwigo backup

Addendum:

Error: "60 photos can not be regenerated" when trying to generate multiple size images. The progress bar fills quite quickly, but afterwards Piwigo throws this error. I double-checked, the permissions were wrong (subdirs of _data were owned by larp-bb:larp-bb) but fixing it (sudo chown -R www-data:www-data _data) didn't help either. I don't understand it :-(.

Offline

 

#5 2013-04-26 13:07:08

MasinAD
Member
2012-09-09
13

Re: [resolved] Manual restore of Piwigo backup

Now, I tried setting up a new Piwigo and take a look at the permissions. Afterwards, I gave www-data ownership of all files and folders.

A friend reminded me of Piwigo's requirements, so I installed imagemagick and php5-gd. I forgot to install them after the OS upgrade of my server. But to no avail.

Offline

 

#6 2013-04-26 22:17:22

MasinAD
Member
2012-09-09
13

Re: [resolved] Manual restore of Piwigo backup

The solution was quite simple, but finding the right problem was difficult.

ImageMagick wasn't installed.

$ sudo apt-get install libmagickwand-dev
$ sudo pecl install imagick
and adding "extension=imagick.so" in /etc/php5/apache2/php.ini with the editor of your choice.

Thanks for your attention.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact