Piwigo.org

You are not logged in. (Register / Login)

Announcement

#1 2016-03-09 17:18:53

Maic
Guest

After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Tags: [error]

Hello,

I recently upgraded my PIWIGO installation to version 2.8.0. and now I get two error-messages in the admin-panel:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; LocalSiteReader has a deprecated constructor in /www/htdocs/w0097a97/www.sensorart.de/piwigo/admin/site_reader_local.php on line 25

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w0097a97/www.sensorart.de/piwigo/admin/site_reader_local.php:25) in /www/htdocs/w0097a97/www.sensorart.de/piwigo/include/page_header.php on line 101

But these two warnings only appear if I select "Recent Fotos" / "Batch Manager" / "Caddie" / "Orphaned Fotos". If i select any other menu item, the warning will not shown.

I think that strange behavior will have something to do with the admin.php, but I can't solve this problem by myself.

Any suggestions?

Thanks in advance.

Piwigo version: 2.8.0
PHP version: 7.0.2
MySQL version: 5.6.27
Piwigo URL: http://www.sensorart.de/piwigo/
Host: All-Inkl.com

Used Theme: Stripped

Used Plug-Ins: Add < head > element, Admin Tools, Grum Plugin Classes, GThumb+, Lightbox, LocalFiles Editor, PersoFavicon, Sitemap

 

#2 2016-03-09 19:14:02

Maic
Guest

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Aloha,

I just want to add some new informations ;-)

A few minutes ago, I installed a fresh PIWIGO 2.8.0. at a another free domain on my webspace, with no additional themes or plugins. To my amazement the same error occured!

Same PHP-Version, same MySQL, everything similar to my productive installation of PIWIGO, except the plugins.

Now I have run out of ideas :-(

P.S: I also tested the new test-installation with different PHP-Versions (5.5, 5.6, 7.0.2), but this changes absolutely nothing ...

 

#3 2016-03-09 20:09:43

Zentalquabula
Member
Registered: 2014-05-10
Posts: 61

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Be aware that many pages are routinely cached. Old pages will thus appear functional for a time.

Offline

 

#4 2016-03-09 21:50:41

Maic
Guest

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Aloha!

I seriously doubt that caching is the cause of this problem.

Remember, I have the same problems with a fresh & clean installation of this Piwigo version. Furthermore I used different browsers for testing (Firefox, Chrome, Edge, IE, Opera, Vivaldi) and the error appears every time.  I also tested the new installation via a cellular connection and the warnings are still appear.

I am very sorry, but this answer can't be the solution for the problem that I have described.

See ya, Maic.

 

#5 2016-03-09 21:57:07

mistic100
Former Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 3267
Website

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Configure your installations to not show Deprecated messages, they should not be displayed on production websites.

I'll fix the problem.

Offline

 

#6 2016-03-09 23:22:54

Maic
Guest

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

:-/

Sounds for me like a "Mexican Paintshop". Don't repair, just spray paint over it ...

I tried to hide the error-messages by adding these lines to my .htaccess, but with no success:

php_flag display_startup_errors off
php_flag display_errors off
php_flag html_errors off

The error-messages still appear and - tadaa - I found another bug:

My Piwigo uses the Grum Plugin Classes 3.5.9 and the AdvancedMenuManager 3.2.9.

With both activated I get the following error-messages in the admin-panel and also in the gallery:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; AMM_AIM has a deprecated constructor in /www/htdocs/w0097a97/www.sensorart.de/piwigo/plugins/AMenuManager/amm_aim.class.inc.php on line 20

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/w0097a97/www.sensorart.de/piwigo/plugins/AMenuManager/amm_aim.class.inc.php:20) in /www/htdocs/w0097a97/www.sensorart.de/piwigo/include/page_header.php on line 101


Are you still thinking that it has something to do with the caching?

P.S: Productive site / test site makes no difference. The errors appear on both installations.

 

#7 2016-03-10 08:05:18

CharlieM
Member
Location: Gloucester, UK
Registered: 2015-04-27
Posts: 64

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Most hosts these days allow you to put a php.ini file into the root public html folder.

You can turn errors off using this:-

http://php.net/manual/en/errorfunc.conf … lay-errors

It's perfectly acceptable to do this, most PHP installations are configured not to show errors. The messages you are getting are about deprecated functions and syntax. Not in fact errors as such but advisory notices.

Offline

 

#8 2016-03-10 08:06:01

nicolas
Former Piwigo Team
Registered: 2004-12-30
Posts: 1162
Website

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

The warnings you see are caused by php7 engine because of a deprecated feature : http://php.net/manual/fr/migration70.deprecated.php

I like you comparaison with mexican paintshop ! :-) Hiding warning is not the right solution and it's not always available on shared providers.

Offline

 

#9 2016-03-10 08:06:51

mistic100
Former Piwigo Team
Location: Lyon (FR)
Registered: 2008-09-27
Posts: 3267
Website

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

I never said it was related to caching.
And I never said environment are different BUT it's bad practice to show errors on production environment (it can leak sensible data).

http://php.net/manual/en/function.error-reporting.php

I fixed the problem in Piwigo core, it will be in 2.8.1
But I don't maintain Advanced Menu Manager.

And Deptecated messages are absolutely NOT critical.

Offline

 

#10 2016-03-10 13:47:18

Maic
Guest

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Thanks for your efforts to all of you.

@CharlieM: This is the case at these webhoster. Shared webhosting = no possibility to disable the php-warnings.

@Nicholas: Yes, I know, but this project has to be run under PHP7 for some special circumstances :-(

@mistic100: Thanks for your hints, answers and the quick repair of the Piwigo-Core. I can hardly wait to install 2.8.1 ;-)

Next question: Where is the best place in this forum to put a request about the AdvancedMenuManager problem? Should I ask the Plugin-Autor directly?

 

#11 2016-03-10 14:29:50

ddtddt
Piwigo Team
Location: Quetigny - France
Registered: 2007-07-27
Posts: 6686

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Maic wrote:

Next question: Where is the best place in this forum to put a request about the AdvancedMenuManager problem? Should I ask the Plugin-Autor directly?

Hi :-)

Plugin author don't participe actualy to Piwigo

Piwigo 2.8 is only 2 day ;-)
In the few day if AdvancedMenuManager isn't update post a new topic


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#12 2016-03-10 14:33:00

plg
Piwigo Team
Location: Nantes, France, Europe
Registered: 2002-04-05
Posts: 13080
Website

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

I'm going to check [extension by grum] Advanced Menu Manager and [extension by grum] Grum Plugin Classes on my PHP 7 virtual machine.


Latest blog post (March 23th 2017) Piwigo.com Enterprise plans, now official!

Offline

 

#13 2016-03-10 18:52:11

CharlieM
Member
Location: Gloucester, UK
Registered: 2015-04-27
Posts: 64

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

Maic wrote:

@CharlieM: This is the case at these webhoster. Shared webhosting = no possibility to disable the php-warnings.

Not true of all shared webhosting at all. Heart Internet for one, they also allow local php.ini files. I'm pretty sure Fasthosts do too and they are offering PHP 7.

Last edited by CharlieM (2016-03-10 18:55:19)

Offline

 

#14 2016-05-14 03:03:17

lesel
Member
Registered: 2015-03-25
Posts: 3

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

I'm getting these errors with Advanced Menu Manager  Revision 3.2.9 plugin updated to recent version.

Notice: Use of undefined constant GPC_PATH - assumed 'GPC_PATH' in /home/xxx/piwigo/plugins/GrumPluginClasses/classes/GPCCore.class.inc.php on line 663

Notice: Use of undefined constant GPC_PATH - assumed 'GPC_PATH' in /home/xxx/piwigo/plugins/GrumPluginClasses/classes/GPCCore.class.inc.php on line 815

Notice: Use of undefined constant GPC_PATH - assumed 'GPC_PATH' in /home/xxx/piwigo/plugins/GrumPluginClasses/classes/GPCCore.class.inc.php on line 820

Notice: Use of undefined constant GPC_PATH - assumed 'GPC_PATH' in /home/xxx/piwigo/plugins/GrumPluginClasses/classes/GPCCore.class.inc.php on line 663

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/piwigo/plugins/GrumPluginClasses/classes/GPCCore.class.inc.php:663) in /home/xxx/piwigo/include/page_header.php on line 101

Warning: Undefined script gpc.inputList is required by someone in /home/xxx/piwigo/include/template.class.php on line 1770

Last edited by lesel (2016-05-15 19:04:27)

Offline

 

#15 2016-05-14 06:17:16

ddtddt
Piwigo Team
Location: Quetigny - France
Registered: 2007-07-27
Posts: 6686

Re: After update to PIWIGO 2.8.0 I get warnings in the admin-panel

@lesel

have you update plugin ?


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact