Piwigo.org

You are not logged in. (Register / Login)

Announcement

#31 2017-11-12 06:22:48

erio
Member
Registered: 2017-05-09
Posts: 2

Re: Force HTTPS plugin

Hi all,

I just update the Force_HTTPS to the latest version via the update interface.  But after a server reboot, it said:

"sitename" redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

I cleaned all cookies and caches but no luck. How can I temporarily disable the Force_HTTPS entension so that I can access the site?  Thank you.

Erio

Offline

 

#32 2017-11-12 10:14:16

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

erio wrote:

Hi all,

I just update the Force_HTTPS to the latest version via the update interface.  But after a server reboot, it said:

"sitename" redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

I cleaned all cookies and caches but no luck. How can I temporarily disable the Force_HTTPS entension so that I can access the site?  Thank you.

Erio

Hi erio,
You can delete the plugins/Force_HTTPS folder and it will restore your access.
One question meanwhile:
- do you have HTTPS forced any other way than with the plugin (i mean, do you have a virtual host or .htaccess file file redirects connections from port 80 to 443 ?
In this case, the redirect issue could be solved by commenting line 98 of the main.inc.php of the plugin

Code:

      default:
//        force_https_set_header_http();

This issue in this case will be fixed in upcoming version.

Offline

 

#33 2017-11-12 12:41:09

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

Version 2.0.2 released and available for update. It should fix reported issues.
Enjoy !
Arnaud (bonhommedeneige)

Offline

 

#34 2017-11-12 15:59:53

erio
Member
Registered: 2017-05-09
Posts: 2

Re: Force HTTPS plugin

Thanks!  I just removed the folder in the morning and it works again.  And now I re-install the F_HTTPS again and it works!

Offline

 

#35 2017-11-12 16:31:45

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

erio wrote:

Thanks!  I just removed the folder in the morning and it works again.  And now I re-install the F_HTTPS again and it works!

Great ! Thanks for the  feedback, it helps improving the plugin ! Apart from the admin interface which could be enhanced, I think it is not far to be usable for every kind of situation.

Offline

 

#36 2017-11-12 18:01:46

gnurob
Member
Registered: 2016-10-29
Posts: 13

Re: Force HTTPS plugin

Thanks for making the 301/302 changes, etc., its great to have that fix.

How about the problem with HTTP and HTTPS both being canonical?
e.g. <link rel="canonical" href="/gallery/"> is listed for both pages.

What should happen, is that the full URL to the page, for both versions, should be given with https:// under the canonical. I'm sure Google isn't all that dump, but apparently there is a little penalty for not being perfect about it.

Maybe it's in Piwigo, versus the plug-in, but who to suggest it to...

Offline

 

#37 2017-11-12 19:20:18

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

gnurob wrote:

How about the problem with HTTP and HTTPS both being canonical?
e.g. <link rel="canonical" href="/gallery/"> is listed for both pages.

I did not inquire in the canonical subject. From what I've seen so far it seems to be handled in the core of Piwigo (index.php and functions.inc.php). There's is a TODO caption in the functions.inc.php get_root_url()  2.9.2 function, maybe that's the key...

Code:

function get_root_url()
{
  global $page;
  if ( ($root_url = @$page['root_path']) == null )
  {// TODO - add HERE the possibility to call PWG functions from external scripts
    $root_url = PHPWG_ROOT_PATH;
    if ( strncmp($root_url, './', 2) == 0 )
    {
      return substr($root_url, 2);
    }
  }
  return $root_url;
}

Offline

 

#38 2017-11-14 17:05:01

jeroens
Member
Registered: 2017-11-14
Posts: 2

Re: Force HTTPS plugin

Hi,

I have a similar problem as mentioned before. I installed Force_https, I think it said the server was OK, now everything is blocked. The error is "The site cannot deliver a secure connection"

I tried deleting the plugin folder as discussed before. This failed because the owner seems to be not me
unfortunately, it says owner 48. I see all plugins have the same owner "48" where all other folders have owner "39747"  How come the plugins have a different owner?

Any ideas about alternatives for deleting the plugin for now?
Of course I can ask my hosting company to delete it and I will. But I wondered if anyone has experienced this before and how to solve it yourself?

Offline

 

#39 2017-11-14 19:43:57

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

jeroens wrote:

Hi,

I have a similar problem as mentioned before. I installed Force_https, I think it said the server was OK, now everything is blocked. The error is "The site cannot deliver a secure connection"

I tried deleting the plugin folder as discussed before. This failed because the owner seems to be not me
unfortunately, it says owner 48. I see all plugins have the same owner "48" where all other folders have owner "39747"  How come the plugins have a different owner?

Any ideas about alternatives for deleting the plugin for now?
Of course I can ask my hosting company to delete it and I will. But I wondered if anyone has experienced this before and how to solve it yourself?

Hi,
To solve the problem you could try deleting the configuration keys in the database

DELETE FROM piwigo_config where param like 'force_https'

or (if you use an older version)

DELETE FROM piwigo_config where param like 'fhp%'

In the admin panel you have a test that you have to do before activating. It can not be ok with the test (the page should be displayed successfully) within the admin and not ok after activation, unless I missed something in the plugin.
When did you install it ?

Hope it will solve your issue

Arnaud (bonhommedeneige)

Offline

 

#40 2017-11-14 22:54:10

jeroens
Member
Registered: 2017-11-14
Posts: 2

Re: Force HTTPS plugin

Hello Arnaud,

Thank you for your help. It worked, I can now access piwigo once more.
When I go back to the plugin I have a remaining problem see the errors in the attached screenshot.

However I also realize know I was triggered by the message
""Your hosting server does support HTTPS"

This made me think it was OK
Next I enabled the HTTPS boxes for global activation and partial activation. BTW I am not really an expert on this topic I thought this would not harm.

I did not see a test link or button and it still does not show see the screenshot attached.

I installed today and downloaded the latest version.
I am running piwgo 2.9.2
My host domain runs on PHP 5.6 and Fast-CGI. The database is MySQL

Thanks in advance

Jeroen

Offline

 

#41 Today 09:37:57

bonhommedeneige
Member
Location: France
Registered: 2013-05-03
Posts: 21

Re: Force HTTPS plugin

Hi

You're right, if it indicates "Your server support HTTPS", then you don't have the test link (i'll add it anyway in an upcoming release), it's then normal that you can't locate it.
Can you repost your screenshot as I can't see it in your previous post ?
Thanks !
Arnaud (bonhommedeneige)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2017 · Contact