Announcement

#1 2018-02-27 08:08:19

Haz_69
Member
2015-01-19
22

Piwigo is NOT sending me emails

Hello/Hi/Greetings,

Piwigos has stopped sending mails to me after a user registration? Not with the community extenson either.

I can't find any settings to change?

BR Hans

•Piwigo 2.9.3
•Operativ system: Linux
•PHP: 5.6.31 (Visa info) [2018-02-27 07:05:38]
•MySQL: 5.5.5-10.1.30-MariaDB-1~xenial [2018-02-27 07:05:38]
•Grafikbibliotek: GD bundled (2.1.0 compatible)


Piwigo URL: http://www.karlskogabilder.se

Offline

 

#2 2018-03-01 09:41:17

flop25
Piwigo Team
2006-07-06
6838

Re: Piwigo is NOT sending me emails

Hello
you would need to first check the log of your server (postfix, Dovecot ...). There, you should see comprehensive errors on what's going on


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#3 2018-03-02 07:45:05

Haz_69
Member
2015-01-19
22

Re: Piwigo is NOT sending me emails

How?

Offline

 

#4 2018-03-06 13:20:32

Haz_69
Member
2015-01-19
22

Re: Piwigo is NOT sending me emails

Its not my server!

Offline

 

#5 2018-03-06 15:33:27

Ralf
Member
Dorsten-Lembeck
2012-05-08
154

Re: Piwigo is NOT sending me emails

Hi,

if you log in to your web space you should see a directory where the logfiles are stored.
Usually they are named 'access.log' or similar.
Download the file, open in an editor (it is just a text file) and look for error messages.

You can also try the following things:
Lgin to your Piwigo Backend - as a logged in Admin send yourself a message with the contact form.
If this works you are not allowed to send emails with a sender mail adressw  which is not registered at your e-mail account.
To fix this, you can setup Piwigo to send emails through smtp.
This can be done by configuring the local files editor plugin.

$conf['smtp_host'] = 'your smtp host:Port(usually 25)';
$conf['smtp_user'] = smtp user';
$conf['smtp_password'] = 'your smtp password#';
$conf['mail_sender_email'] = 'your mail adresse';
$conf['mail_allow_html'] = true;
$conf['smtp_secure'] = null;

Note: With settings mails will be send without SSL.
In my case ssl did not work - the settings above work for me.
If you do not the correct port number or credentials you need to contact your provider.


There are only two kinds of music:
Rock and Roll

Offline

 

#6 2018-03-06 17:58:20

Haz_69
Member
2015-01-19
22

Re: Piwigo is NOT sending me emails

Thx alot ! Worked perfectly!

BR Hasse

Offline

 

#7 2018-03-09 13:48:26

Wauchsam
Member
2018-03-08
12

Re: Piwigo is NOT sending me emails

Good Morning All...  can you explain more for a dummy.  what file s config'ed with the local file editor, the config it shows is empty, tried to build it but get syntax error.

/config/config.inc.php

<?php


/* The file does not exist until some information is entered
below. Once information is entered and saved, the file will be created. */
$conf['smtp_host'] = 'mail.sweetpea.xyz:465(usually 25)';
$conf['smtp_user'] = 'sweetpea@sweetpea.xyz';
$conf['smtp_password'] = 'password';
$conf['mail_sender_email'] = 'sweetpea.xyz@sweetpea.xyz';
$conf['mail_allow_html'] = true;
$conf['smtp_secure'] = true;



?>

Just need more info if you would please

Last edited by Wauchsam (2018-03-09 13:58:19)

Offline

 

#8 2018-03-09 16:28:03

Ralf
Member
Dorsten-Lembeck
2012-05-08
154

Re: Piwigo is NOT sending me emails

Hi,

It is just normal that the file is empty at the beginning.

In Local Files Editor you have different tabs.
The first one is 'Local configuration'. You only see two php tags here and between the tags a hint, that the file is empty.

Just put the smtp settings between the php tags in the local configuration tab.

Don't forget to change the settings to your smtp server with the correct credentials.


There are only two kinds of music:
Rock and Roll

Offline

 

#9 2018-03-09 19:15:06

Wauchsam
Member
2018-03-08
12

Re: Piwigo is NOT sending me emails

Thank you, I got that far, but errors sending,  the server uses sll on port 465 what would be the syntax for:$conf['smtp_secure'] =null;


<?php


/* The file does not exist until some information is entered
below. Once information is entered and saved, the file will be created. */
$conf['smtp_host'] = 'sub5.mail.dreamhost.com:465(usually 25)';
$conf['smtp_user'] = 'sweetpea@sweetpea.xyz';
$conf['smtp_password'] = 'XXXXXXX';
$conf['mail_sender_email'] = 'sweetpea.xyz';
$conf['mail_allow_html'] = true;
$conf['smtp_secure'] = ssl;





?>


Uploaded Images

Last edited by Wauchsam (2018-03-09 21:01:31)

Offline

 

#10 2018-03-09 21:28:41

executive
Member
2017-08-16
333

Re: Piwigo is NOT sending me emails

"(usually 25)" is not part of the host name.
"sweetpea.xyz" is not an email address

Offline

 

#11 2018-03-10 01:04:50

Wauchsam
Member
2018-03-08
12

Re: Piwigo is NOT sending me emails

thought thru all of that

and came up with this
$conf['smtp_host'] = 'sub5.mail.dreamhost.com:465';
$conf['smtp_user'] = 'sweetpea@sweetpea.xyz';
$conf['smtp_password'] = 'XXXXXXXX';
$conf['mail_sender_email'] = 'sweetpea@sweetpea.xyz';
$conf['mail_allow_html'] = true;
$conf['smtp_secure'] = ssl;

tired ports 465 587
also with sll tls and nul

same response ever time
One time I just deleted all of it and tired and it said sent successful  but never got an email
I called my host and they don't know either

Offline

 

#12 2018-03-10 06:38:19

Ralf
Member
Dorsten-Lembeck
2012-05-08
154

Re: Piwigo is NOT sending me emails

Hi,

try if this works:
Port: 25
Replace 'ssl' with null.

Last edited by Ralf (2018-03-10 06:39:44)


There are only two kinds of music:
Rock and Roll

Offline

 

#13 2018-03-10 16:19:15

Wauchsam
Member
2018-03-08
12

Re: Piwigo is NOT sending me emails

same thing

$conf['smtp_host'] = 'sub5.mail.dreamhost.com:25';
$conf['smtp_user'] = 'sweetpea@sweetpea.xyz';
$conf['smtp_password'] = '@1Christi1';
$conf['mail_sender_email'] = 'sweetpea@sweetpea.xyz';
$conf['mail_allow_html'] = true;
$conf['smtp_secure'] = null;

in the
$conf['mail_allow_html'] = true;  <--------should true be in 'true'  or just   true
$conf['smtp_secure'] = null;  <---------same here

also what troubles me it the error seen in the previous post
error() http://github ...........  why is it calling for github?

Last edited by Wauchsam (2018-03-10 16:21:41)

Offline

 

#14 2018-03-10 16:57:16

Ralf
Member
Dorsten-Lembeck
2012-05-08
154

Re: Piwigo is NOT sending me emails

Are you sure that this is correct?

'sweetpea@sweetpea.xyz';

sweetpea.xyz seems to be not a valid domain.


There are only two kinds of music:
Rock and Roll

Offline

 

#15 2018-03-10 17:11:29

Wauchsam
Member
2018-03-08
12

Re: Piwigo is NOT sending me emails

go look at www.sweetpea.xyz <---click here


and sweetpea@sweetpea.xyz is a good email

Last edited by Wauchsam (2018-03-10 17:15:04)

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact