Announcement

#1 2018-08-27 02:47:46

Photomike
Member
2018-08-27
5

PHP 7.2 and 2.9.4 Error

Piwigo 2.9.4
    Operating system: Linux
    PHP: 7.2.8 [2018-08-26 20:42:34]
    MySQL: 10.1.31-MariaDB-cll-lve [2018-08-26 20:42:34]
    Graphics Library: External ImageMagick 6.7.2-7

https://www.firstchoicephoto.ca/gallery


Error on top of all pages:

Deprecated: Function create_function() is deprecated in /home/fchoice/public_html/gallery/include/constants.php on line 44

I checked other posts that ended in saying all problems were fixed for PHP 7.2

Any help appreciated.

You will need to spell out if I need to do any code changes as I am not that good at doing code changes.

Offline

 

#2 2018-08-28 15:07:05

windracer
Member
St. Pete, FL
2014-12-28
218

Re: PHP 7.2 and 2.9.4 Error

Known issue: [Github] AdminTools issue #9, should have been fixed in Admin Tools 2.9.4.1. See here.

Offline

 

#3 2018-08-28 17:17:22

Photomike
Member
2018-08-27
5

Re: PHP 7.2 and 2.9.4 Error

It appears that I have the update already and still I am getting the error.

https://www.firstchoicephoto.ca/Piwi.jpg

Last edited by Photomike (2018-08-28 17:23:27)

Offline

 

#4 2018-08-29 02:58:45

windracer
Member
St. Pete, FL
2014-12-28
218

Re: PHP 7.2 and 2.9.4 Error

In local/config/config.inc.php (via Local Files Editor extension) I have:

Code:

$conf['show_php_errors'] = E_ALL ^ E_DEPRECATED;

To hide those kind of messages.

Offline

 

#5 2018-08-29 13:51:49

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13175

Re: PHP 7.2 and 2.9.4 Error

Hi Photomike,

Can we see what you have on line 44 of file include/constants.php ?


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#6 2018-08-29 17:10:42

Photomike
Member
2018-08-27
5

Re: PHP 7.2 and 2.9.4 Error

If I knew how to find that I would be happy to :-)

Offline

 

#7 2018-08-29 18:59:49

plg
Piwigo Team
Nantes, France, Europe
2002-04-05
13175

Re: PHP 7.2 and 2.9.4 Error

Photomike wrote:

If I knew how to find that I would be happy to :-)

download your file include/constants.php on your computer. Open it with a text editor (like notepad), go on line 44 and copy the content of this line. Then paste it as a reply on this forum topic :-)


Latest blog post (May 3rd 2018) New subscription form

Offline

 

#8 2018-08-29 21:04:07

Photomike
Member
2018-08-27
5

Re: PHP 7.2 and 2.9.4 Error

Will try and figure out how to download a file.  Once again I am not someone that writes code so this is not something I have ever done.

SO I went to click on the tool icon in the top right corner and I get:

parsererror SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Then when I went to the admin/users I am getting DataTables warning: table id=userList - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

I was able to read up on JSON and found a way to read that problem and it was related to the database of the users and it also indicated that the problem was in line 44 of this issue. 

Here is what I could find (I changed out the listed Email addresses for the ***@Emailaddress.ca for privacy)

<br />
<b>Deprecated</b>:  Function create_function() is deprecated in <b>/home/fchoice/public_html/gallery/include/constants.php</b> on line <b>44</b><br />
{"sEcho":0,"iTotalRecords":"4","iTotalDisplayRecords":"4","aaData":[["1","admin","Webmaster","***@Emailaddress.ca","","Admins","0000-00-00 00:00:00"],["2","guest","Guest",null,"","","0000-00-00 00:00:00"],["11","galleryadmin","Webmaster","***@Emailaddress.ca","","","2014-06-23 13:22:10"],["34","Linda","User","***@Emailaddress.ca","","","2018-05-28 13:56:53"]]}

Last edited by Photomike (2018-08-29 21:25:43)

Offline

 

#9 2018-09-23 02:17:01

Photomike
Member
2018-08-27
5

Re: PHP 7.2 and 2.9.4 Error

Looks like help has ended. Frustrating to be left hanging!

I found this on what I think is line 44 that is the error... .userStats {margin-top:10px;} but without help really doe nothing.

Offline

 

#10 2018-09-23 20:06:29

flop25
Piwigo Team
2006-07-06
6851

Re: PHP 7.2 and 2.9.4 Error

windracer wrote:

In local/config/config.inc.php (via Local Files Editor extension) I have:

Code:

$conf['show_php_errors'] = E_ALL ^ E_DEPRECATED;

To hide those kind of messages.


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2018 · Contact