Announcement

  •  » Extensions
  •  » [resolved] anti-spam - stopped working effectively since 2.8 upgrade

#1 2016-03-28 19:14:35

todd
Member
2014-11-27
32

[resolved] anti-spam - stopped working effectively since 2.8 upgrade

Hello/Hi/Greetings,

I was using "Easy Captcha" prior to the 2.8 upgrade and wasn't getting any spam comments. As soon as I upgraded to 2.8 I started getting massive amounts of spammer comments. I then noticed that "Easy Captcha" wasn't working anymore... I then installed "Crypto Captcha" and it's working but I am still getting too many, at least 10 spammer comments per day that I have to delete...

I did get some reports from friends over the months prior to the upgrade that sometimes the 'tic tac toe' entry didn't work with "Easy Captcha" (if they played correctly it would still say incorrect and they'd have to try a number of times) so I am wondering if that was why I wasn't seeing any spam before the upgrade to 2.8. Are spammers really taking the time to enter captchas?

Is there anything else I can easily do? I want my friends to be able to enter guest comments (because they won't comment at all if I require registration) but not have to deal with deleting spam comments all the time...

Thanks,
Todd

Piwigo version: 2.8
PHP version: 5.6.19
MySQL version: 10.0.20-MariaDB-cll-lve
Piwigo URL: http://www.idontwanttolistthisandgetevenmorespam.com

Offline

 

#2 2016-03-28 19:18:10

todd
Member
2014-11-27
32

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

It would be great if we could have an option where links are not allowed in comments. Maybe that would deter spammers/

Offline

 

#3 2016-03-28 22:27:37

ddtddt
Piwigo Team
Quetigny - France
2007-07-27
6767

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

Hi :-)

Go to administrion > Plugins > manage
activate  [extension by Piwigo Team] LocalFiles Editor

Go to Administration > plugin > localfileEditor > tab 'local config

paste

<?php

$conf['comment_spam_max_links'] = 0;


?>


You love Piwigo so don't hesitate to participate, learn more on the "Contribute to Piwigo" page. If you don't have much time for contribution, you can also help the project with a donation.

Offline

 

#4 2016-03-28 23:49:49

todd
Member
2014-11-27
32

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

ddtddt wrote:

Hi :-)

Go to administrion > Plugins > manage
activate  [extension by Piwigo Team] LocalFiles Editor

Go to Administration > plugin > localfileEditor > tab 'local config

paste

<?php

$conf['comment_spam_max_links'] = 0;


?>

awesome thanks so much! :)

Offline

 

#5 2018-09-24 17:54:23

chazzo
Member
2014-10-17
8

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

I know this is an old thread, but I just wanted to say thanks to ddtddt:

$conf['comment_spam_max_links'] = 0;

From the name 'comment_spam_max_links' I wondered whether this fix might need the Easy Captcha plugin to be installed, but I've discovered that it works fine on its own.

I'm having trouble getting Easy Captcha to work, and I'd prefer not to use a captcha at all if I can help it. But Akismet just doesn't seem to be working any more. It's OK most of the time, and stops a lot of spam, but then every week or so I get hit by 100 comments.

This seems like a perfect solution – after all, all comment spam contains links, doesn't it?

Charles

Last edited by chazzo (2018-09-24 18:03:35)

Offline

 

#6 2018-09-24 22:27:32

flop25
Piwigo Team
2006-07-06
6960

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

not all spam contains link, that can also be text for back SEO


To get a better help : Politeness like Hello-A link-Your past actions precisely described
Check my extensions : more than 30 available
who I am and what I do : http://fr.gravatar.com/flop25
My gallery : an illustration of how to integrate Piwigo in your website

Offline

 

#7 2018-09-24 23:26:55

chazzo
Member
2014-10-17
8

Re: [resolved] anti-spam - stopped working effectively since 2.8 upgrade

not all spam contains link, that can also be text for back SEO

Ah, OK. I'll see what happens. Of the spam that gets past Akismet, I can't remember seeing any without links. But if Akismet's stats are correct, it is catching 96–98% of the spam, so I have no idea what is in the ones it does catch. The remaining 2–4% is enough to give me a headache :-)

Offline

 
  •  » Extensions
  •  » [resolved] anti-spam - stopped working effectively since 2.8 upgrade

Board footer

Powered by FluxBB

github twitter facebook google+ newsletter Donate Piwigo.org © 2002-2019 · Contact